aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.subdir.mk
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>2000-01-21 11:08:23 +0000
committerSatoshi Asami <asami@FreeBSD.org>2000-01-21 11:08:23 +0000
commitf682f47599b52b74aa0cfda8635dc8ec25c30bca (patch)
tree3c280543ba0b57d8098cd5fcbcd9a8eadafa4b8f /Mk/bsd.port.subdir.mk
parentfdf822da8c949fd490f06c77651e568a7fc3e630 (diff)
downloadports-f682f47599b52b74aa0cfda8635dc8ec25c30bca.tar.gz
ports-f682f47599b52b74aa0cfda8635dc8ec25c30bca.zip
(1) Add new USE_BISON directive, which will expand to BUILD_DEPENDS on
4-current post bison-removal and to a no-op otherwise. Note this should only be used when the software in question uses a feature in bison that is not in byacc -- otherwise it should be patched to use byacc (or detect the absense of bison correctly). [bsd.port.mk] (2) Do not assume all category names are lowercase. In particular, remove package links by removing them one by one, instead of doing a "rm [a-z]*/${PKGNAME}.tgz". [bsd.port.mk] (3) Do not assume the category name doesn't include a path separator (/). Make links accordingly. [bsd.port.mk,README.category,README.port] (4) Do not assume all category makefiles are directly under ${PORTSDIR}. [bsd.port.mk,README.category] (5) Add new "package-name" target which prints out the directory name to be used in the parent README.html. [bsd.port.subdir.mk] (2) through (5) are in preparation for going to multi-level categories. They shouldn't make any difference yet, but are committed first so people can start testing.
Notes
Notes: svn path=/head/; revision=24870
Diffstat (limited to 'Mk/bsd.port.subdir.mk')
-rw-r--r--Mk/bsd.port.subdir.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/Mk/bsd.port.subdir.mk b/Mk/bsd.port.subdir.mk
index 3169eb72be48..a84a02060d8a 100644
--- a/Mk/bsd.port.subdir.mk
+++ b/Mk/bsd.port.subdir.mk
@@ -194,6 +194,9 @@ README= ${TEMPLATES}/README.category
HTMLIFY= sed -e 's/&/\&amp;/g' -e 's/>/\&gt;/g' -e 's/</\&lt;/g'
+package-name:
+ @echo ${.CURDIR} | sed -e 's^.*/^^'
+
README.html:
@echo "===> Creating README.html"
@> $@.tmp