aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.subdir.mk
diff options
context:
space:
mode:
authorJosef Karthauser <joe@FreeBSD.org>2000-03-22 20:36:55 +0000
committerJosef Karthauser <joe@FreeBSD.org>2000-03-22 20:36:55 +0000
commit97315fc9f27b54289717939b9dcf99d9cc20b552 (patch)
treef325ba0d5bcb949d389591f60356601441c4f806 /Mk/bsd.port.subdir.mk
parent831aee2711c4186bf0cadcfdaea0af662063faff (diff)
downloadports-97315fc9f27b54289717939b9dcf99d9cc20b552.tar.gz
ports-97315fc9f27b54289717939b9dcf99d9cc20b552.zip
Additions to the 'make search' mechanism.
* You can now 'make search' from a ports subdirectory. This will will restrict the search to ports within this subdirectory. * Added an additional search option to search just the port names, e.g. 'make search name=foo' will only return ports that have 'foo' in their name. Approved by: asami
Notes
Notes: svn path=/head/; revision=26963
Diffstat (limited to 'Mk/bsd.port.subdir.mk')
-rw-r--r--Mk/bsd.port.subdir.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/Mk/bsd.port.subdir.mk b/Mk/bsd.port.subdir.mk
index a84a02060d8a..8887b3102fe8 100644
--- a/Mk/bsd.port.subdir.mk
+++ b/Mk/bsd.port.subdir.mk
@@ -34,6 +34,9 @@
# depend, depends, describe, extract, fetch, fetch-list, ignorelist,
# install, package, package-loop, readmes, realinstall, reinstall, tags
#
+# search:
+# Search for ports using either 'make search key=<keyword>'
+# or 'make search name=<keyword>'.
.MAIN: all
@@ -235,3 +238,21 @@ README.html:
OSVERSION="${OSVERSION:S/"/"'"'"/g:S/\$/\$\$/g:S/\\/\\\\/g}" \
PORTOBJFORMAT="${PORTOBJFORMAT:S/"/"'"'"/g:S/\$/\$\$/g:S/\\/\\\\/g}"
.endif
+
+# Ports may be symlinked to somewhere else. Convert the directory path
+# back into one that lives within the ports collection.
+PORTSACTUALDIR!=perl -e '($$subdir = "${.CURDIR}") =~ s!.*/([^/]+)!$$1/!; \
+ print "${PORTSACTUALDIR}/"; print $$subdir unless "${PORTSTOP}";'
+search: ${PORTSDIR}/INDEX
+.if !defined(key) && !defined(name)
+ @echo "The search target requires a keyword parameter or name parameter,"
+ @echo "e.g.: \"make search key=somekeyword\""
+ @echo "or \"make search name=somekeyword\""
+.else
+.if defined(key)
+ @grep ${PORTSACTUALDIR} ${PORTSDIR}/INDEX | grep -i "${key}" | awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9); }'
+.endif
+.if defined(name)
+ @grep ${PORTSACTUALDIR} ${PORTSDIR}/INDEX | grep -i "^[^|]*${name}[^|]*|" | awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9); }'
+.endif
+.endif