aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.python.mk
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-06-08 22:30:55 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-06-08 22:30:55 +0000
commit81100672d4de2795c4284cf568383d48955cbdcb (patch)
tree47e3d403298c2fd50b0ec056f62df5c31925decb /Mk/bsd.python.mk
parent6d138c2d46f8ea88c939a76298099dbcf07491af (diff)
downloadports-81100672d4de2795c4284cf568383d48955cbdcb.tar.gz
ports-81100672d4de2795c4284cf568383d48955cbdcb.zip
- Update lang/python26 and make Python 2.6.2 to the default Python version
Tested by: 3 pointyhat runs Thanks to: pav, gahr, lwhsu, mva, amdmi3
Notes
Notes: svn path=/head/; revision=235453
Diffstat (limited to 'Mk/bsd.python.mk')
-rw-r--r--Mk/bsd.python.mk16
1 files changed, 8 insertions, 8 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index 046ccf3a64d6..a48cba2a8fe4 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -83,9 +83,9 @@ Python_Include_MAINTAINER= python@FreeBSD.org
#
# PYTHON_DEFAULT_VERSION
# - Version of the default python binary in your ${PATH}, in
-# the format "python2.5". Set this in your /etc/make.conf
+# the format "python2.6". Set this in your /etc/make.conf
# in case you want to use an older version as a default.
-# default: python2.5
+# default: python2.6
#
# PYTHON_WRKSRC - The ${WRKSRC} for your python version. Needed for
# extensions like Tkinter, py-gdbm and py-expat, which
@@ -213,8 +213,8 @@ Python_Include_MAINTAINER= python@FreeBSD.org
# specific version of zope.
#
-_PYTHON_PORTBRANCH= 2.5
-_PYTHON_ALLBRANCHES= 2.5 2.6 2.4 2.3 3.0 # preferred first
+_PYTHON_PORTBRANCH= 2.6
+_PYTHON_ALLBRANCHES= 2.6 2.5 2.4 2.3 3.0 # preferred first
_ZOPE_PORTBRANCH= 2.7
_ZOPE_ALLBRANCHES= 2.7 2.8 2.9 2.10 3.2
@@ -379,9 +379,9 @@ PYTHON_VER= 3.0
# Python-2.6
.elif ${PYTHON_VERSION} == "python2.6"
-PYTHON_PORTVERSION?=2.6.1
+PYTHON_PORTVERSION?=2.6.2
PYTHON_PORTSDIR= ${PORTSDIR}/lang/python26
-PYTHON_REL= 261
+PYTHON_REL= 262
PYTHON_SUFFIX= 26
PYTHON_VER= 2.6
@@ -425,8 +425,8 @@ check-makevars::
@${ECHO} "Legal values are:"
@${ECHO} " python2.3"
@${ECHO} " python2.4"
- @${ECHO} " python2.5 (default)"
- @${ECHO} " python2.6"
+ @${ECHO} " python2.5"
+ @${ECHO} " python2.6 (default)"
@${ECHO} " python3.0"
@${FALSE}
.endif