aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.qt.mk
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-02-08 20:23:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-02-08 20:23:45 +0000
commitef1b3d107105075700da0844ac072acae2de7726 (patch)
tree14d3f35f7d5dc26e8e8feed96c01af49bd9e4d3d /Mk/bsd.qt.mk
parenta71e0ff08b3f1acf82cd96524c18b3a653ed1954 (diff)
downloadports-ef1b3d107105075700da0844ac072acae2de7726.tar.gz
ports-ef1b3d107105075700da0844ac072acae2de7726.zip
The KDE FreeBSD team is proud to announce the release of KDE 4.2.0
for FreeBSD. The official KDE 4.2.0 (Codename: "The Answer") release notes can be found at: http://kde.org/announcements/4.2/index.php. New supported languages include Arabic, Icelandic, Basque, Hebrew, Romanian, Tajik and several Indian languages (Bengali India, Gujarati, Kannada, Maithili, Marathi) indicating a rise in popularity in this part of Asia. New ports for KDE 4.2.0: arabic/kde4-l10n Arabic hebrew/kde4-l10n Hebrew misc/kde4-l10n-bn_IN Bengali (India) misc/kde4-l10n-eu Basque misc/kde4-l10n-gu Gujarati misc/kde4-l10n-is Icelandic misc/kde4-l10n-kn Kannada misc/kde4-l10n-mai Maithili misc/kde4-l10n-mr Marathi misc/kde4-l10n-ro Romanian misc/kde4-l10n-tg Tajik math/eigen2 Lightweight library for vector and matrix math graphics/kipi-plugins-kde4 KDE4 kipi graphics plugins sysutils/policykit-kde PolicyKit manager for KDE Unfortunately FreeBSD 6.4 support is dropped. We'd like to say thanks for feedback and help to: Matt Tosto, Kris Moore, stickibit, David Johnson, Markus Brueffer, David Naylor, Thomas Schlesinger, Warren Liddell, Thomas Abthorpe, Diego Depaoli, Mats Andreassen, portmgr for exp-run and repocopies.
Notes
Notes: svn path=/head/; revision=227819
Diffstat (limited to 'Mk/bsd.qt.mk')
-rw-r--r--Mk/bsd.qt.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/Mk/bsd.qt.mk b/Mk/bsd.qt.mk
index 9b55b13b9425..a4494200acf0 100644
--- a/Mk/bsd.qt.mk
+++ b/Mk/bsd.qt.mk
@@ -93,7 +93,7 @@ QT4_VERSION?= 4.4.3
_QT_COMPONENTS_ALL= accessible assistant assistant-adp assistantclient \
clucene codecs-cn codecs-jp codecs-kr codecs-tw corelib \
dbus designer doc help help-tools gui iconengines imageformats \
- inputmethods linguist makeqpf moc network opengl \
+ inputmethods linguist l10n makeqpf moc network opengl \
pixeltool porting phonon phonon-gst qdbusviewer \
qmake qt3support qtconfig qtestlib qvfb rcc script \
sql svg uic uic3 webkit xml xmlpatterns xmlpatterns-tool
@@ -119,6 +119,7 @@ iconengines_DEPENDS= graphics/qt4-iconengines
imageformats_DEPENDS= graphics/qt4-imageformats
inputmethods_DEPENDS= x11/qt4-inputmethods
linguist_DEPENDS= devel/qt4-linguist
+l10n_DEPENDS= misc/qt4-l10n
makeqpf_DEPENDS= devel/qt4-makeqpf
moc_DEPENDS= devel/qt4-moc
network_DEPENDS= net/qt4-network
@@ -165,6 +166,7 @@ iconengines_build_DEPENDS= ${iconengines_DEPENDS}
imageformats_build_DEPENDS= ${imageformats_DEPENDS}
inputmethods_build_DEPENDS= ${inputmethods_DEPENDS}
linguist_build_DEPENDS= ${linguist_DEPENDS}
+l10n_build_DEPENDS= ${l10n_DEPENDS}
makeqpf_build_DEPENDS= ${makeqpf_DEPENDS}
moc_build_DEPENDS= ${moc_DEPENDS}
network_build_DEPENDS= ${network_DEPENDS}
@@ -211,6 +213,7 @@ iconengines_run_DEPENDS= ${iconengines_DEPENDS}
imageformats_run_DEPENDS= ${imageformats_DEPENDS}
inputmethods_run_DEPENDS= ${inputmethods_DEPENDS}
linguist_run_DEPENDS= ${linguist_DEPENDS}
+l10n_run_DEPENDS= ${l10n_DEPENDS}
makeqpf_run_DEPENDS= ${makeqpf_DEPENDS}
moc_run_DEPENDS= ${moc_DEPENDS}
network_run_DEPENDS= ${network_DEPENDS}
@@ -262,9 +265,6 @@ RUN_DEPENDS+= ${${ext}_QT4_PREFIX}${${ext}_NAME}>=${${ext}_QT4_VERSION}:${PORTSD
IGNORE= cannot install: unknown Qt4 component -- ${ext}
.endif
.endfor
-.else
-BUILD_DEPENDS+= qt4>=${QT4_VERSION}:${PORTSDIR}/devel/qt4
-RUN_DEPENDS+= qt4>=${QT4_VERSION}:${PORTSDIR}/devel/qt4
.endif
.endif