aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.sanity.mk
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-09-19 09:49:52 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-09-19 09:49:52 +0000
commitc8209f84b4ca26ff7fd774b864408375dcac320c (patch)
treec4559c1a0e4f6c9d0100ce186a8e4e8dc55266df /Mk/bsd.sanity.mk
parent16026f1d0db6371512bf1303f7e9e00d8abe6bd5 (diff)
downloadports-c8209f84b4ca26ff7fd774b864408375dcac320c.tar.gz
ports-c8209f84b4ca26ff7fd774b864408375dcac320c.zip
- Implement USES+=tcl and USES+=tk
- Use bsd.default-versions.mk to specify the default Tcl/Tk version (8.6) - Add warnings about the now deprecated use of USE_TCL, USE_TK, ... Notes: * USES+=tcl and USES+=tk take the following optional arguments - either a version in the form of XY or XY+, or 'wrapper' to depend on lang/tcl-wrapper or x11-toolkits/tk-wrapper - either 'build' (bring in build depend) or 'run' (bring in run depend) * it is an error to specify both 'tcl' and 'tk' in USES. * The functionality currently implemented via INVALID_TCL_VER and INVALID_TK_VER is not yet available. Approved by: bapt (portmgr)
Notes
Notes: svn path=/head/; revision=327607
Diffstat (limited to 'Mk/bsd.sanity.mk')
-rw-r--r--Mk/bsd.sanity.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/Mk/bsd.sanity.mk b/Mk/bsd.sanity.mk
index 4723850b0bb9..43fbfa909fba 100644
--- a/Mk/bsd.sanity.mk
+++ b/Mk/bsd.sanity.mk
@@ -91,6 +91,11 @@ DEV_WARNING+= "USE_GNOME=gnomehack is deprecated, please use USES=pathfix"
DEV_WARNING+= "Please use the new format for LIB_DEPENDS, see handbook for details"
.endif
+.if defined(USE_TCL) || defined(USE_TCL_BUILD) || defined(USE_TCL_RUN) || defined(USE_TCL_WRAPPER) || \
+ defined(USE_TK) || defined(USE_TK_BUILD) || defined(USE_TK_RUN) || defined(USE_TK_WRAPPER)
+DEV_WARNING+= "USE_TCL and USE_TK are deprecated, please use USES=tcl or USES=tk"
+.endif
+
.if defined(_PREMKINCLUDED)
DEV_ERROR+= "you cannot include bsd.port[.pre].mk twice"
.endif