aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.tcl.mk
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-02-05 14:03:40 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-02-05 14:03:40 +0000
commit0dcb6347ed871e8239d873f648d5bc9db8a67453 (patch)
tree287ef6271e1b2edebf228bbea323e9e92be7ad81 /Mk/bsd.tcl.mk
parent008cf2697233d3aaf1a3b5b8444abffc76252ac0 (diff)
downloadports-0dcb6347ed871e8239d873f648d5bc9db8a67453.tar.gz
ports-0dcb6347ed871e8239d873f648d5bc9db8a67453.zip
- Support Tcl/Tk 8.5 in USE_TCL/USE_TK
PR: ports/108510 Submitted by: Martin Matuska <martin@matuska.org>
Notes
Notes: svn path=/head/; revision=184268
Diffstat (limited to 'Mk/bsd.tcl.mk')
-rw-r--r--Mk/bsd.tcl.mk9
1 files changed, 5 insertions, 4 deletions
diff --git a/Mk/bsd.tcl.mk b/Mk/bsd.tcl.mk
index c65ff3835d2b..21a370b0c52a 100644
--- a/Mk/bsd.tcl.mk
+++ b/Mk/bsd.tcl.mk
@@ -13,14 +13,15 @@ Tcl_Include_MAINTAINER= ports@FreeBSD.org
# different TCL versions the version can be specified directly.
# If version is not specified (USE_TCL=yes) then the latest
# version is used (8.4 currently).
-# Available values are: 84, 84-thread, 83, 82, 81 and 80.
+# Available values are: 85, 85-thread, 84, 84-thread, 83, 82,
+# 81 and 80.
# USE_TCL_BUILD - Build time dependency on tcl. Same semantics as USE_TCL.
#
# USE_TK - Depend on tk to run. In case of incompatible APIs of different
# TK versions the version can be specified directly. If version
# is not specified (USE_TK=yes) then the latest version is
# used (8.4 currently).
-# Available values are: 84, 83, 82, 81 and 80.
+# Available values are: 85, 84, 83, 82, 81 and 80.
# USE_TK_BUILD - Build time dependency on tk. Same semantics as USE_TK.
##
# TCL_LIBDIR - Path where tcl libraries can be found
@@ -48,7 +49,7 @@ Tcl_Include_MAINTAINER= ports@FreeBSD.org
.if defined(USE_TCL) || defined(USE_TCL_BUILD)
-_TCL_VERSIONS= 84 84-thread 83 82 81 80
+_TCL_VERSIONS= 85 85-thread 84 84-thread 83 82 81 80
.if defined(USE_TCL)
_RUN= yes
@@ -93,7 +94,7 @@ IGNORE= Unknown TCL version specified: ${USE_TCL}
.if defined(USE_TK) || defined(USE_TK_BUILD)
-_TK_VERSIONS= 84 83 82 81 80
+_TK_VERSIONS= 85 84 83 82 81 80
.if defined(USE_TK)
_TK_RUN= yes