aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.tcl.mk
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2009-02-23 14:46:37 +0000
committerMartin Matuska <mm@FreeBSD.org>2009-02-23 14:46:37 +0000
commit24bf28eff1f36a61373baf68b02d29b708cb2434 (patch)
tree7cdf37f7acdf4bb5edf2c07abd044ae8b9ca0731 /Mk/bsd.tcl.mk
parent356df709ff408556534cc0e28f8939457ad065bd (diff)
downloadports-24bf28eff1f36a61373baf68b02d29b708cb2434.tar.gz
ports-24bf28eff1f36a61373baf68b02d29b708cb2434.zip
- Change default Tcl/Tk version to 8.5
- Bump PORTVERSION of ports affected Tested by: pointyhat (pav)
Notes
Notes: svn path=/head/; revision=228909
Diffstat (limited to 'Mk/bsd.tcl.mk')
-rw-r--r--Mk/bsd.tcl.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/Mk/bsd.tcl.mk b/Mk/bsd.tcl.mk
index 0da49cbd689a..ae631b4073e7 100644
--- a/Mk/bsd.tcl.mk
+++ b/Mk/bsd.tcl.mk
@@ -13,7 +13,7 @@ Tcl_Include_MAINTAINER= mm@FreeBSD.org
# via the port or by the user via defined variable try to find the highest
# stable installed version.
# Available values: yes 86+ 85+ 84+ 83+ 82+ 80+ 85 84 83 82 80
-# NOTE: - default value 84 is used in case of USE_TCL=yes
+# NOTE: - default value 85 is used in case of USE_TCL=yes
#
# USE_TCL_BUILD - Add buildtime dependency on Tcl (tclsh).
# Available values: see USE_TCL
@@ -28,7 +28,7 @@ Tcl_Include_MAINTAINER= mm@FreeBSD.org
# a specific tclsh version may use this.
# The tclsh wrapper script installs into ${LOCALBASE}/bin/tclsh
# NOTE: - USE_TCL_WRAPPER and USE_TCL can be used together
-# - ports using the wrapper should support default Tcl (8.4)
+# - ports using the wrapper should support default Tcl (8.5)
##
# INVALID_TCL_VER - This variable contains a list of Tcl versions not supported by the port.
# This setting is effective only when USE_TCL is set to a range (e.g. 83+)
@@ -53,7 +53,7 @@ Tcl_Include_MAINTAINER= mm@FreeBSD.org
# stable installed version.
# Avaliable values: yes 86+ 85+ 84+ 83+ 82+ 80+ 85 84 83 82 80
# NOTE: - overrides USE_TCL
-# - default value 84 is used in case of USE_TK=yes
+# - default value 85 is used in case of USE_TK=yes
#
# USE_TK_BUILD - Add buildtime dependency on Tk (wish).
# Available values: see USE_TK
@@ -68,7 +68,7 @@ Tcl_Include_MAINTAINER= mm@FreeBSD.org
# a specific wish version may use this.
# The wish wrapper script installs into ${LOCALBASE}/bin/wish
# NOTE: - USE_TK_WRAPPER and USE_TK can be used together.
-# - ports using the wrapper should support default Tk (8.4)
+# - ports using the wrapper should support default Tk (8.5)
##
# INVALID_TK_VER - This variable contains a list of Tk versions not supported by the port
# This setting is effective only when USE_TK is set to a range (e.g. 83+)
@@ -190,7 +190,7 @@ INVALID_TCL_VER:= ${INVALID_TK_VER}
#
. if defined(USE_TCL)
-_TCL_DEFAULT_VERSION= 84
+_TCL_DEFAULT_VERSION= 85
_TCL_VERSIONS= 86 85 84 83 82 80
_TCL_THREADS_VERSIONS= 86 85 84
_TCL_RANGE_VERSIONS= 86+ 85+ 84+ 83+ 82+ 80+