aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorMark Murray <markm@FreeBSD.org>2002-03-16 22:47:00 +0000
committerMark Murray <markm@FreeBSD.org>2002-03-16 22:47:00 +0000
commit05e08061c2f4e8b5573aa87c7ad3b188e0ef90be (patch)
treee6fc91c53fe9f1b4a2fc554e5e71cbb52280ef08 /Mk
parent74864ec7d7a7f9c28ba58b8d16f01463a50d5f2d (diff)
downloadports-05e08061c2f4e8b5573aa87c7ad3b188e0ef90be.tar.gz
ports-05e08061c2f4e8b5573aa87c7ad3b188e0ef90be.zip
Take Perl 5.6.1 into account. Allow for slow updaters who prefer to
stay with an older CURRENT and perl 5.6.0.
Notes
Notes: svn path=/head/; revision=56227
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 6577bf60af58..049ebbc3fb22 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -968,6 +968,11 @@ BUILD_DEPENDS+= bison:${PORTSDIR}/devel/bison
.endif
.endif
+.if ${OSVERSION} >= 500032
+PERL_VERSION?= 5.6.1
+PERL_VER?= 5.6.1
+PERL_ARCH?= mach
+.else
.if ${OSVERSION} >= 500007
PERL_VERSION?= 5.6.0
PERL_VER?= 5.6.0
@@ -981,6 +986,7 @@ PERL_VERSION?= 5.00502
PERL_VER?= 5.005
PERL_ARCH?= ${ARCH}-freebsd
.endif
+.endif
PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
PERL_VER=${PERL_VER} \
PERL_ARCH=${PERL_ARCH}