aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2017-06-17 23:26:58 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2017-06-17 23:26:58 +0000
commitec65ac0994cbfa7aab876460446f4c8bd2e9a96b (patch)
tree432be3612e6d0e3a32a8caafcc2a4fde9fe725f3 /Mk
parentdc886afb8c695f72df0910e731e4e1521f8ebba8 (diff)
downloadports-ec65ac0994cbfa7aab876460446f4c8bd2e9a96b.tar.gz
ports-ec65ac0994cbfa7aab876460446f4c8bd2e9a96b.zip
Specifying an invalid PYTHON_VERSION against its USES should be IGNORED.
The port's own USES may note that is only supports certain versions. If it is attempted to build an unsupported version there's no reason to even try. Rather than giving a WARNING, actually mark it IGNORE. Currently this should only impact devel/py3-enum34 which does not support the default python3 version of 3.6. With hat: portmgr
Notes
Notes: svn path=/head/; revision=443792
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/python.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index 09e924ae82a7..3ab8ab7de356 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -354,7 +354,7 @@ _PYTHON_VERSION_NONSUPPORTED= ${_PYTHON_VERSION_MAXIMUM} at most
.if defined(_PYTHON_VERSION_NONSUPPORTED)
.if defined(PYTHON_VERSION) || defined(PYTHON_CMD)
_PV:= ${_PYTHON_VERSION} # preserve the specified python version
-WARNING+= "needs Python ${_PYTHON_VERSION_NONSUPPORTED}. But a port depending on this one specified ${_PV}"
+IGNORE= needs Python ${_PYTHON_VERSION_NONSUPPORTED}, but ${_PV} was specified
.endif # defined(PYTHON_VERSION) || defined(PYTHON_CMD)
.undef _PYTHON_VERSION
.for ver in ${PYTHON2_DEFAULT} ${PYTHON3_DEFAULT} ${_PYTHON_VERSIONS}