aboutsummaryrefslogtreecommitdiff
path: root/Tools/scripts
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2003-02-21 00:48:19 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2003-02-21 00:48:19 +0000
commit307e2a0837d596ca40a26bf92851032dec2f5003 (patch)
treea2469ca9a07c886b78611d7101ccfc876accd483 /Tools/scripts
parentf803dc6806755d9d9237720f3882b006b96bd9c2 (diff)
downloadports-307e2a0837d596ca40a26bf92851032dec2f5003.tar.gz
ports-307e2a0837d596ca40a26bf92851032dec2f5003.zip
- pkg-comment is no longer mandatory;
- ignore patchfiles ending with `,v' or '.orig'.
Notes
Notes: svn path=/head/; revision=75996
Diffstat (limited to 'Tools/scripts')
-rwxr-xr-xTools/scripts/patchtool.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/Tools/scripts/patchtool.py b/Tools/scripts/patchtool.py
index f9008af92cd2..de9a5ed99ac7 100755
--- a/Tools/scripts/patchtool.py
+++ b/Tools/scripts/patchtool.py
@@ -60,7 +60,7 @@ class Vars:
# Check if the supplied patch refers to a port's directory.
#
def isportdir(path, soft = False):
- REQ_FILES = ('Makefile', 'pkg-comment', 'pkg-descr', 'pkg-plist', \
+ REQ_FILES = ('Makefile', 'pkg-descr', 'pkg-plist', \
'distinfo')
if not os.path.isdir(path) and soft != True:
raise IOError(errno.ENOENT, path)
@@ -542,6 +542,10 @@ def generate(args, automatic, force, ignoremtime):
patches = PatchesCollection()
for filepath in args:
+ for suf in Vars.RCSDIFF_SUFX, Vars.DIFF_SUFX:
+ if filepath.endswith(suf):
+ filepath = filepath[:-len(suf)]
+ break
if not os.path.isfile(filepath):
raise IOError(errno.ENOENT, filepath)
# Not reached #