aboutsummaryrefslogtreecommitdiff
path: root/Tools
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-18 16:03:40 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-18 16:03:40 +0000
commitf10048320ec90b81584123701d7ffae664b4f961 (patch)
tree1fe2ed977abeea80c67ffa772b41483d5d71cbdb /Tools
parentc74922e73fdd8f739827698443815598cc583cc5 (diff)
downloadports-f10048320ec90b81584123701d7ffae664b4f961.tar.gz
ports-f10048320ec90b81584123701d7ffae664b4f961.zip
Fix if PORTREVISION is not already there.
Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=372726
Diffstat (limited to 'Tools')
-rwxr-xr-xTools/scripts/bump-revision.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tools/scripts/bump-revision.sh b/Tools/scripts/bump-revision.sh
index ed18d2bcbf45..e16fa39393f4 100755
--- a/Tools/scripts/bump-revision.sh
+++ b/Tools/scripts/bump-revision.sh
@@ -64,7 +64,7 @@ do
|| printc "$1: FAILED TO BUMP PORTREVISION" red
;;
1)
- awk '/^PORTVERSION\??=\t/{print;print "PORTREVISION=\t1";next}' "$1/Makefile" > $tempfile \
+ awk '/^(PORT|DIST)VERSION\??=\t/{print;print "PORTREVISION=\t1";next} {print}' "$1/Makefile" > $tempfile \
&& { cat $tempfile > "$1/Makefile" ;printc "$1: PORTREVISION not found, adding PORTREVISION=1" "green" ; } \
|| printc "$1: FAILED TO BUMP PORTREVISION" red
;;