aboutsummaryrefslogtreecommitdiff
path: root/Tools
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-12-28 05:45:30 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-12-28 05:45:30 +0000
commit01e42e5b2df5987b0aad849b20e94e50cf88b2aa (patch)
tree98633353fa94dc7e681d31ffc9a158a236b3f610 /Tools
parent0ebddec26a37eb4b9caebbb2591d803e619231e0 (diff)
downloadports-01e42e5b2df5987b0aad849b20e94e50cf88b2aa.tar.gz
ports-01e42e5b2df5987b0aad849b20e94e50cf88b2aa.zip
* It does in fact make sense to specify -incremental and -noindex at the
same time, assuming that the admin has already built the INDEX and INDEX.old in advance. * Adapt to new method of calculating build concurrency, by summing the value of ${maxjobs} listed in every portbuild.${machine} * Support 5-exp builds
Notes
Notes: svn path=/head/; revision=125319
Diffstat (limited to 'Tools')
-rwxr-xr-xTools/portbuild/scripts/dopackages14
1 files changed, 7 insertions, 7 deletions
diff --git a/Tools/portbuild/scripts/dopackages b/Tools/portbuild/scripts/dopackages
index 2b3776bd9ead..481376a026fe 100755
--- a/Tools/portbuild/scripts/dopackages
+++ b/Tools/portbuild/scripts/dopackages
@@ -255,16 +255,11 @@ else
skipstart=0
fi
-if [ "$incremental" = 1 -a "$noindex" = 1 ]; then
- echo "-incremental and -noindex cannot both be used"
- errorexit 1
-fi
-
# mandatory arguments
branch=$1
date=$2
-if [ "x$branch" != x4 -a "x$branch" != x4-exp -a "x$branch" != x5 -a "x$branch" != x6 ]; then
+if [ "x$branch" != x4 -a "x$branch" != x4-exp -a "x$branch" != x5 -a "x$branch" != x5-exp -a "x$branch" != x6 ]; then
usage
fi
@@ -477,7 +472,12 @@ if [ "$nobuild" = 0 ]; then
cp duds.orig duds
fi
- count=$(awk '{sum+=$2}END{print sum+NR/2}' ${pb}/${arch}/mlist | sed -e 's/\..*$//')
+ count=0
+ for i in `cat ${pb}/${arch}/mlist`; do
+ . ${pb}/${arch}/portbuild.conf
+ test -f ${pb}/${arch}/portbuild.${i} && . ${pb}/${arch}/portbuild.${i}
+ count=$((${count}+${maxjobs}))
+ done
cd ${pb}/${arch}/${branch}/packages/All
ln -sf ../../Makefile .