aboutsummaryrefslogtreecommitdiff
path: root/Tools
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2002-02-25 08:26:10 +0000
committerKris Kennaway <kris@FreeBSD.org>2002-02-25 08:26:10 +0000
commit7e42e1b8ed799a04e6ffeb0a6ee4b9261d5046ef (patch)
treeea7654f6e0532ae6399d2ea0b0e60f325a55a194 /Tools
parent7d3860493ca58dd900ed012d2771004d234a9aad (diff)
downloadports-7e42e1b8ed799a04e6ffeb0a6ee4b9261d5046ef.tar.gz
ports-7e42e1b8ed799a04e6ffeb0a6ee4b9261d5046ef.zip
Garbage collect these old configuration directories, since we don't
support 2.2.x/3.x package builds any more.
Notes
Notes: svn path=/head/; revision=55222
Diffstat (limited to 'Tools')
-rw-r--r--Tools/portbuild/2.2/bindist/README20
-rw-r--r--Tools/portbuild/2.2/bindist/delete7
-rw-r--r--Tools/portbuild/2.2/bindist/dirlist8
-rwxr-xr-xTools/portbuild/2.2/bindist/files/usr/bin/uname67
-rw-r--r--Tools/portbuild/2.2/mkbindist30
-rw-r--r--Tools/portbuild/3/bindist/README24
-rw-r--r--Tools/portbuild/3/bindist/delete65
-rw-r--r--Tools/portbuild/3/bindist/dirlist9
-rwxr-xr-xTools/portbuild/3/bindist/files/usr/bin/uname67
-rw-r--r--Tools/portbuild/3/mkbindist.conf6
10 files changed, 0 insertions, 303 deletions
diff --git a/Tools/portbuild/2.2/bindist/README b/Tools/portbuild/2.2/bindist/README
deleted file mode 100644
index 896dd4b4bcfe..000000000000
--- a/Tools/portbuild/2.2/bindist/README
+++ /dev/null
@@ -1,20 +0,0 @@
-(1) Copy the following files to under the "files" subdirectory:
-
- Copy the following files from a running 2.2 system:
-
- /dev/{kmem,lkm,mem,null,stderr,stdin,stdout,tty,zero}
- /etc/resolv.conf
-
- Copy the following files from a very recent 2.2 system:
-
- /usr/sbin/pkg_{add,create,delete,info}
-
- Copy the following files from a very recent 2.2 system or source tree:
-
- /usr/share/info/dir
- /usr/share/mk/bsd.port*.mk
- /usr/share/mk/sys.mk
-
-(2) Run "sh mkbindist". Note the first time you should set "ftp=1".
-
-(3) Copy "tarballs/bindist.tar" to the same directory in all the build machines.
diff --git a/Tools/portbuild/2.2/bindist/delete b/Tools/portbuild/2.2/bindist/delete
deleted file mode 100644
index 3c6a2b0b6692..000000000000
--- a/Tools/portbuild/2.2/bindist/delete
+++ /dev/null
@@ -1,7 +0,0 @@
-usr/share/calendar
-usr/share/examples
-usr/share/locale
-usr/share/nls
-usr/share/zoneinfo
-usr/sbin/sysctl
-dev
diff --git a/Tools/portbuild/2.2/bindist/dirlist b/Tools/portbuild/2.2/bindist/dirlist
deleted file mode 100644
index d9d7ef8d14be..000000000000
--- a/Tools/portbuild/2.2/bindist/dirlist
+++ /dev/null
@@ -1,8 +0,0 @@
-tmp/depends
-tmp/distfiles
-tmp/packages
-usr/X11R6
-usr/local
-usr/opt/doc
-usr/opt/www
-usr/ports
diff --git a/Tools/portbuild/2.2/bindist/files/usr/bin/uname b/Tools/portbuild/2.2/bindist/files/usr/bin/uname
deleted file mode 100755
index 7f1608f3c9f4..000000000000
--- a/Tools/portbuild/2.2/bindist/files/usr/bin/uname
+++ /dev/null
@@ -1,67 +0,0 @@
-#!/bin/sh
-
-# "sed -e 's/\(.\)/ -\1/g'" can be used to convert "abc" to "-a -b -c"
-
-a=0
-m=0
-n=0
-r=0
-s=0
-v=0
-
-if [ $# = 0 ]; then
- s=1
-else
- set $(printf "%s\n" "$*" | sed -e 's/-//g' -e 's/\([a-z]\)/ \1/g')
- while [ $# -gt 0 ]; do
- eval $1=1
- shift
- done
-fi
-
-if [ "$a" = 1 ]; then
- m=1
- n=1
- r=1
- s=1
- v=1
-fi
-
-printed=0
-
-if [ "$s" = 1 ]; then
- echo -n "FreeBSD"
- printed=1
-fi
-
-printsp () {
- if [ $1 = 1 ]; then
- echo -n " "
- fi
-}
-
-if [ "$n" = 1 ]; then
- printsp $printed
- echo -n $(hostname)
- printed=1
-fi
-
-if [ "$r" = 1 ]; then
- printsp $printed
- echo -n "2.2.8-STABLE"
- printed=1
-fi
-
-if [ "$v" = 1 ]; then
- printsp $printed
- echo -n "FreeBSD 2.2.8-STABLE #0: Sun Dec 13 03:47:56 PST 1998 asami@bento.freebsd.org:/usr/src/sys/compile/BENTO"
- printed=1
-fi
-
-if [ "$m" = 1 ]; then
- printsp $printed
- echo -n "i386"
- printed=1
-fi
-
-echo
diff --git a/Tools/portbuild/2.2/mkbindist b/Tools/portbuild/2.2/mkbindist
deleted file mode 100644
index 70d849a058fc..000000000000
--- a/Tools/portbuild/2.2/mkbindist
+++ /dev/null
@@ -1,30 +0,0 @@
-#!/bin/sh
-ftp=0
-here=$(pwd)
-tmpdir=${here}/tmp
-rm -rf ${tmpdir}
-mkdir -p ${tmpdir}
-if [ "${ftp}" != 0 ]; then
- cd bindist/ftp
- /usr/bin/ftp -a 'ftp://ftp.freebsd.org/pub/FreeBSD/2.2.8-RELEASE/bin/bin.??'
- /usr/bin/ftp -a 'ftp://ftp.freebsd.org/pub/FreeBSD/2.2.8-RELEASE/dict/dict.??'
- /usr/bin/ftp -a 'ftp://ftp.freebsd.org/pub/FreeBSD/2.2.8-RELEASE/des/des.??'
- #ssh -n ftp.freebsd.org cat 'w/2.2.8-RELEASE/bin/bin.??' | tar -xzpf -
- cd ${here}
-fi
-cd ${tmpdir}
-cat ${here}/bindist/ftp/bin.?? | tar --unlink -xzpf -
-cat ${here}/bindist/ftp/dict.?? | tar --unlink -xzpf -
-cat ${here}/bindist/ftp/des.?? | tar --unlink -xzpf -
-rm -rf $(cat ${here}/bindist/delete)
-mkdir -p $(cat ${here}/bindist/dirlist)
-tar -C ${here}/bindist/files -cf - . | tar -xpf -
-echo "HAVE_MOTIF=t" >> etc/make.conf
-echo "MOTIF_STATIC=t" >> etc/make.conf
-mv kernel.GENERIC kernel
-chroot $(pwd) /sbin/ldconfig /usr/lib
-mkdir -p ${here}/tarballs
-tar cf ${here}/tarballs/bindist.tar.new .
-mv -f ${here}/tarballs/bindist.tar.new ${here}/tarballs/bindist.tar
-cd ${here}
-rm -rf ${tmpdir}
diff --git a/Tools/portbuild/3/bindist/README b/Tools/portbuild/3/bindist/README
deleted file mode 100644
index 034e60fcff69..000000000000
--- a/Tools/portbuild/3/bindist/README
+++ /dev/null
@@ -1,24 +0,0 @@
-(1) Copy the following files to under the "files" subdirectory:
-
- Copy the following files from a running 3-stable system:
-
- /dev/{bpf0,kmem,lkm,mem,null,stderr,stdin,stdout,tty,zero}
- /dev/fd/[0-9]
- /etc/resolv.conf
-
- Copy the following files from a running 3-stable system or a
- 2.2-stable system. In the latter case, it will be in /usr/lib.
-
- /usr/lib/aout/c++rt0.o
-
- Copy the following files from a very recent 3-stable system:
-
- /usr/libexec/ld-elf.so.1
-
- Copy the following files from a very recent 3-stable system or source tree:
-
- /usr/share/info/dir
-
-(2) Run "sh mkbindist". Note the first time you should set "ftp=1".
-
-(3) Copy "tarballs/bindist.tar" to the same directory in all the build machines.
diff --git a/Tools/portbuild/3/bindist/delete b/Tools/portbuild/3/bindist/delete
deleted file mode 100644
index f24b0e5888bd..000000000000
--- a/Tools/portbuild/3/bindist/delete
+++ /dev/null
@@ -1,65 +0,0 @@
-compat
-dev
-modules
-tmp
-usr/games/adventure
-usr/games/arithmetic
-usr/games/atc
-usr/games/backgammon
-usr/games/battlestar
-usr/games/bcd
-usr/games/bs
-usr/games/caesar
-usr/games/canfield
-usr/games/cfscores
-usr/games/cribbage
-usr/games/dm
-usr/games/factor
-usr/games/fish
-usr/games/fortune
-usr/games/grdc
-usr/games/hack
-usr/games/hangman
-usr/games/hide
-usr/games/larn
-usr/games/mille
-usr/games/morse
-usr/games/number
-usr/games/phantasia
-usr/games/piano
-usr/games/pig
-usr/games/pom
-usr/games/ppt
-usr/games/primes
-usr/games/quiz
-usr/games/rain
-usr/games/random
-usr/games/robots
-usr/games/rogue
-usr/games/rot13
-usr/games/sail
-usr/games/snake
-usr/games/snscore
-usr/games/teachgammon
-usr/games/trek
-usr/games/unstr
-usr/games/wargames
-usr/games/worm
-usr/games/worms
-usr/games/wump
-usr/lib/aout/lib*_p.a
-usr/lib/lib*_p.a
-usr/sbin/sysctl
-usr/share/calendar
-usr/share/doc
-usr/share/examples
-usr/share/games
-usr/share/info/*.info.gz
-usr/share/isdn
-usr/share/locale
-usr/share/man
-usr/share/nls
-usr/share/perl/man
-usr/share/zoneinfo
-var/games
-var/run
diff --git a/Tools/portbuild/3/bindist/dirlist b/Tools/portbuild/3/bindist/dirlist
deleted file mode 100644
index d6b2cbef8f64..000000000000
--- a/Tools/portbuild/3/bindist/dirlist
+++ /dev/null
@@ -1,9 +0,0 @@
-tmp/depends
-tmp/distfiles
-tmp/packages
-usr/X11R6
-usr/local
-usr/opt/doc
-usr/opt/www
-usr/ports
-usr/src
diff --git a/Tools/portbuild/3/bindist/files/usr/bin/uname b/Tools/portbuild/3/bindist/files/usr/bin/uname
deleted file mode 100755
index 17c66aa47bc8..000000000000
--- a/Tools/portbuild/3/bindist/files/usr/bin/uname
+++ /dev/null
@@ -1,67 +0,0 @@
-#!/bin/sh
-
-# "sed -e 's/\(.\)/ -\1/g'" can be used to convert "abc" to "-a -b -c"
-
-a=0
-m=0
-n=0
-r=0
-s=0
-v=0
-
-if [ $# = 0 ]; then
- s=1
-else
- set $(printf "%s\n" "$*" | sed -e 's/-//g' -e 's/\([a-z]\)/ \1/g')
- while [ $# -gt 0 ]; do
- eval $1=1
- shift
- done
-fi
-
-if [ "$a" = 1 ]; then
- m=1
- n=1
- r=1
- s=1
- v=1
-fi
-
-printed=0
-
-if [ "$s" = 1 ]; then
- echo -n "FreeBSD"
- printed=1
-fi
-
-printsp () {
- if [ $1 = 1 ]; then
- echo -n " "
- fi
-}
-
-if [ "$n" = 1 ]; then
- printsp $printed
- echo -n $(hostname)
- printed=1
-fi
-
-if [ "$r" = 1 ]; then
- printsp $printed
- echo -n "3.1-STABLE"
- printed=1
-fi
-
-if [ "$v" = 1 ]; then
- printsp $printed
- echo -n "FreeBSD 3.1-STABLE #0: Sun Dec 13 03:47:56 PST 1998 asami@bento.freebsd.org:/usr/src/sys/compile/BENTO"
- printed=1
-fi
-
-if [ "$m" = 1 ]; then
- printsp $printed
- echo -n "i386"
- printed=1
-fi
-
-echo
diff --git a/Tools/portbuild/3/mkbindist.conf b/Tools/portbuild/3/mkbindist.conf
deleted file mode 100644
index 879294a2b826..000000000000
--- a/Tools/portbuild/3/mkbindist.conf
+++ /dev/null
@@ -1,6 +0,0 @@
-rel=3-LATEST
-ftpserver=current.jp.freebsd.org
-ftpdists="bin/bin dict/dict des/des games/games compat22/compat22"
-kernel=CLUSTER
-ftp=1
-useworld=0