aboutsummaryrefslogtreecommitdiff
path: root/Tools
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2010-12-16 07:32:22 +0000
committerMark Linimon <linimon@FreeBSD.org>2010-12-16 07:32:22 +0000
commit2935ba5feefbed91b3094b0f0bfd508f62652b47 (patch)
treeb1087eff79932a35a422ebae0af31e732595182f /Tools
parent0fcf58760e48a99a068fd559c6d980a5f4f44a68 (diff)
downloadports-2935ba5feefbed91b3094b0f0bfd508f62652b47.tar.gz
ports-2935ba5feefbed91b3094b0f0bfd508f62652b47.zip
Make sure that PKGSUFFIX and LOCALBASE are really defined. (Things work
_very_ badly if they aren't.) Also, track the refactoring of buildenv so that the proper src tree bits are picked up.
Notes
Notes: svn path=/head/; revision=266403
Diffstat (limited to 'Tools')
-rwxr-xr-xTools/portbuild/scripts/portbuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/Tools/portbuild/scripts/portbuild b/Tools/portbuild/scripts/portbuild
index 24896a065ce5..d2fc71d09a36 100755
--- a/Tools/portbuild/scripts/portbuild
+++ b/Tools/portbuild/scripts/portbuild
@@ -119,14 +119,12 @@ RD=$5
builddir=${pb}/${arch}/${branch}/builds/${buildid}
-# has to be here to affect the setup of OSVERSION and BRANCH in buildenv.client
-export SRC_BASE=${CLIENT_SRCBASE}
-buildenv.client ${pb} ${arch} ${branch} ${builddir}
+buildenv.common
# Want to use the /etc/make.conf in the chroot
unset __MAKE_CONF
-pkgname=$(basename $6 ${CLIENT_PKGSUFFIX})
+pkgname=$(basename $6 ${PKGSUFFIX})
dirname=$7
shift 2
@@ -136,8 +134,9 @@ echo $dirname
# set overrides for bsd.port.mk variables
export WRKDIRPREFIX=${CLIENT_WRKDIRPREFIX}
export DISTDIR=${CLIENT_DISTDIR}
-export LOCALBASE=${CLIENT_LOCALBASE}
+export LOCALBASE=${LOCALBASE}
export PACKAGES=${CLIENT_PACKAGES_LOCATION}
+export SRC_BASE=${CLIENT_SRCBASE}
# to catch missing dependencies
#export DEPENDS_TARGET=/usr/bin/true
@@ -226,7 +225,10 @@ ln -sf ../a/ports ${chroot}/usr/ports
mkdir -p ${chroot}/usr/src
-mount_fs ${builddir}/src ${chroot}/usr/src ${CLIENT_NFS_MASTER}
+mount_fs ${builddir}/src ${chroot}${CLIENT_SRCBASE} ${CLIENT_NFS_MASTER}
+
+# set overrides for uname
+buildenv.client ${chroot}${CLIENT_SRCBASE}
mount -t devfs foo ${chroot}/dev
umount -f ${chroot}/compat/linux/proc > /dev/null 2>&1