aboutsummaryrefslogtreecommitdiff
path: root/accessibility/at-spi2-atk
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
commit7887c684adab042fed1bfcba2e91589ecd17c4a8 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /accessibility/at-spi2-atk
parent85544f2c01be814e0af1ebee1076012e7ed60bb0 (diff)
downloadports-7887c684adab042fed1bfcba2e91589ecd17c4a8.tar.gz
ports-7887c684adab042fed1bfcba2e91589ecd17c4a8.zip
* Update the glib to 2.34.3 and gtk20 to 2.24.17 and gtk30 to 3.6.4 which
are the latest stable releases. * Update vala to the newest stable release 0.18.1, also update a few ports in the gtk/gnome stack. * The c++ bindings ports for glib, atk, gconf, etc, have now USE_GNOME toggles. * Remove pkg-config run depends from glib20 and freetype2. This doesn't eliminate pkg-config run dependency completely, a second phase is needed and is planned. * Support for .:run. and .:build. for USE_GNOME components was added. Currently only libxml2 and libxslt support this mechanism. * Updates of the telepathy stack and empathy. * Trim makefile headers, convert ports to new options, trim off library versions for some ports. * Fix other ports so they build with the new glib version. Thanks to miwi and crees for helping out with some exp-runs. Approved by: portmgr (miwi & bapt) Obtained from: gnome team repo
Notes
Notes: svn path=/head/; revision=313633
Diffstat (limited to 'accessibility/at-spi2-atk')
-rw-r--r--accessibility/at-spi2-atk/Makefile36
-rw-r--r--accessibility/at-spi2-atk/distinfo4
-rw-r--r--accessibility/at-spi2-atk/files/patch-atk-adaptor_accessible-cache.c11
-rw-r--r--accessibility/at-spi2-atk/pkg-plist77
4 files changed, 45 insertions, 83 deletions
diff --git a/accessibility/at-spi2-atk/Makefile b/accessibility/at-spi2-atk/Makefile
index fb67fdb8750b..607125e93a4e 100644
--- a/accessibility/at-spi2-atk/Makefile
+++ b/accessibility/at-spi2-atk/Makefile
@@ -1,34 +1,34 @@
-# New ports collection makefile for: at-spi
-# Date Created: 12 April 2002
-# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
-#
+# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/accessibility/at-spi2-atk/Makefile,v 1.16 2010/11/16 11:53:13 kwm Exp $
-#
+# $MCom: ports/accessibility/at-spi2-atk/Makefile,v 1.38 2012/12/16 22:36:25 kwm Exp $
PORTNAME= at-spi2-atk
-PORTVERSION= 0.4.1
-PORTREVISION= 1
+PORTVERSION= 2.6.2
CATEGORIES= accessibility x11-toolkits
MASTER_SITES= GNOME
-DIST_SUBDIR= gnome2
+DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Assisted Technology Provider module for GTK+
-LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
-RUN_DEPENDS= ${LOCALBASE}/libexec/at-spi2-registryd:${PORTSDIR}/accessibility/at-spi2-core
+LICENSE= LGPL21
-LICENSE= LGPL21
-LICENSE_FILE= ${WRKSRC}/COPYING
-USE_BZIP2= yes
-USE_GETTEXT= yes
+BUILD_DEPENDS= at-spi2-core>=2.1.4:${PORTSDIR}/accessibility/at-spi2-core
+LIB_DEPENDS= dbus-1:${PORTSDIR}/devel/dbus
+RUN_DEPENDS= at-spi2-core>=2.1.4:${PORTSDIR}/accessibility/at-spi2-core
+
+CONFLICTS= at-spi-1.[0-9]*
+PORTSCOUT= limitw:1,even
+
+USE_XZ= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack gnomehier intlhack gconf2 libxml2
+USE_GNOME= gnomehack gnomehier intlhack glib20 atk
+USE_PKGCONFIG= build
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-static
+USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-GCONF_SCHEMAS= at-spi2.schemas
+CONFIGURE_ARGS= --enable-p2p
+GLIB_SCHEMAS= org.a11y.atspi.gschema.xml
.include <bsd.port.mk>
diff --git a/accessibility/at-spi2-atk/distinfo b/accessibility/at-spi2-atk/distinfo
index 21d9b152adc4..e325fa4f0063 100644
--- a/accessibility/at-spi2-atk/distinfo
+++ b/accessibility/at-spi2-atk/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome2/at-spi2-atk-0.4.1.tar.bz2) = ad885b257f9e12bc1cfb0f21bd1075c00bdedca3f66d01b57401ecb12c9f411c
-SIZE (gnome2/at-spi2-atk-0.4.1.tar.bz2) = 337286
+SHA256 (gnome3/at-spi2-atk-2.6.2.tar.xz) = 496c8432e8ab82735145f9af5d45209e9b708bf3c94e527ee091d08641a9bcfa
+SIZE (gnome3/at-spi2-atk-2.6.2.tar.xz) = 274748
diff --git a/accessibility/at-spi2-atk/files/patch-atk-adaptor_accessible-cache.c b/accessibility/at-spi2-atk/files/patch-atk-adaptor_accessible-cache.c
new file mode 100644
index 000000000000..2ccb400fb7b9
--- /dev/null
+++ b/accessibility/at-spi2-atk/files/patch-atk-adaptor_accessible-cache.c
@@ -0,0 +1,11 @@
+--- atk-adaptor/accessible-cache.c.orig 2012-11-21 23:46:32.000000000 +0000
++++ atk-adaptor/accessible-cache.c 2012-11-21 23:47:06.000000000 +0000
+@@ -362,7 +362,7 @@
+ if (!child)
+ {
+ g_static_rec_mutex_unlock (&cache_mutex);
+- return;
++ return FALSE;
+ }
+
+ g_object_ref (child);
diff --git a/accessibility/at-spi2-atk/pkg-plist b/accessibility/at-spi2-atk/pkg-plist
index ef93366a36d6..1085e7997bb5 100644
--- a/accessibility/at-spi2-atk/pkg-plist
+++ b/accessibility/at-spi2-atk/pkg-plist
@@ -1,63 +1,14 @@
-lib/gtk-2.0/modules/at-spi-dbus/modules/libatk-bridge.a
-lib/gtk-2.0/modules/at-spi-dbus/modules/libatk-bridge.la
-lib/gtk-2.0/modules/at-spi-dbus/modules/libatk-bridge.so
-lib/gtk-3.0/modules/at-spi-dbus/modules/libatk-bridge.a
-lib/gtk-3.0/modules/at-spi-dbus/modules/libatk-bridge.la
-lib/gtk-3.0/modules/at-spi-dbus/modules/libatk-bridge.so
-share/gnome/autostart/atk-bridge.desktop
-share/locale/ar/LC_MESSAGES/at-spi2-atk.mo
-share/locale/ast/LC_MESSAGES/at-spi2-atk.mo
-share/locale/bg/LC_MESSAGES/at-spi2-atk.mo
-share/locale/bn/LC_MESSAGES/at-spi2-atk.mo
-share/locale/ca/LC_MESSAGES/at-spi2-atk.mo
-share/locale/cs/LC_MESSAGES/at-spi2-atk.mo
-share/locale/cy/LC_MESSAGES/at-spi2-atk.mo
-share/locale/de/LC_MESSAGES/at-spi2-atk.mo
-share/locale/el/LC_MESSAGES/at-spi2-atk.mo
-share/locale/en@shaw/LC_MESSAGES/at-spi2-atk.mo
-share/locale/en_GB/LC_MESSAGES/at-spi2-atk.mo
-share/locale/es/LC_MESSAGES/at-spi2-atk.mo
-share/locale/et/LC_MESSAGES/at-spi2-atk.mo
-share/locale/eu/LC_MESSAGES/at-spi2-atk.mo
-share/locale/fi/LC_MESSAGES/at-spi2-atk.mo
-share/locale/fr/LC_MESSAGES/at-spi2-atk.mo
-share/locale/gl/LC_MESSAGES/at-spi2-atk.mo
-share/locale/he/LC_MESSAGES/at-spi2-atk.mo
-share/locale/hu/LC_MESSAGES/at-spi2-atk.mo
-share/locale/it/LC_MESSAGES/at-spi2-atk.mo
-share/locale/ko/LC_MESSAGES/at-spi2-atk.mo
-share/locale/lt/LC_MESSAGES/at-spi2-atk.mo
-share/locale/nb/LC_MESSAGES/at-spi2-atk.mo
-share/locale/nl/LC_MESSAGES/at-spi2-atk.mo
-share/locale/nn/LC_MESSAGES/at-spi2-atk.mo
-share/locale/pl/LC_MESSAGES/at-spi2-atk.mo
-share/locale/pt/LC_MESSAGES/at-spi2-atk.mo
-share/locale/pt_BR/LC_MESSAGES/at-spi2-atk.mo
-share/locale/ro/LC_MESSAGES/at-spi2-atk.mo
-share/locale/ru/LC_MESSAGES/at-spi2-atk.mo
-share/locale/sk/LC_MESSAGES/at-spi2-atk.mo
-share/locale/sl/LC_MESSAGES/at-spi2-atk.mo
-share/locale/sr/LC_MESSAGES/at-spi2-atk.mo
-share/locale/sr@latin/LC_MESSAGES/at-spi2-atk.mo
-share/locale/sv/LC_MESSAGES/at-spi2-atk.mo
-share/locale/ta/LC_MESSAGES/at-spi2-atk.mo
-share/locale/th/LC_MESSAGES/at-spi2-atk.mo
-share/locale/uk/LC_MESSAGES/at-spi2-atk.mo
-share/locale/vi/LC_MESSAGES/at-spi2-atk.mo
-share/locale/zh_CN/LC_MESSAGES/at-spi2-atk.mo
-share/locale/zh_HK/LC_MESSAGES/at-spi2-atk.mo
-share/locale/zh_TW/LC_MESSAGES/at-spi2-atk.mo
-@dirrm lib/gtk-2.0/modules/at-spi-dbus/modules
-@dirrm lib/gtk-2.0/modules/at-spi-dbus
-@dirrm lib/gtk-3.0/modules/at-spi-dbus/modules
-@dirrm lib/gtk-3.0/modules/at-spi-dbus
-@dirrmtry lib/gtk-3.0/modules
-@dirrmtry lib/gtk-3.0
-@dirrmtry share/locale/zh_HK/LC_MESSAGES
-@dirrmtry share/locale/zh_HK
-@dirrmtry share/locale/sr@latin/LC_MESSAGES
-@dirrmtry share/locale/sr@latin
-@dirrmtry share/locale/en@shaw/LC_MESSAGES
-@dirrmtry share/locale/en@shaw
-@dirrmtry share/locale/ast/LC_MESSAGES
-@dirrmtry share/locale/ast
+include/at-spi2-atk/2.0/atk-bridge.h
+lib/libatk-bridge-2.0.la
+lib/libatk-bridge-2.0.so
+lib/libatk-bridge-2.0.so.0
+lib/gnome-settings-daemon-3.0/gtk-modules/at-spi2-atk.desktop
+lib/gtk-2.0/modules/libatk-bridge.la
+lib/gtk-2.0/modules/libatk-bridge.so
+libdata/pkgconfig/atk-bridge-2.0.pc
+@dirrmtry lib/gtk-2.0/modules
+@dirrmtry lib/gtk-2.0
+@dirrmtry lib/gnome-settings-daemon-3.0/gtk-modules
+@dirrmtry lib/gnome-settings-daemon-3.0
+@dirrm include/at-spi2-atk/2.0
+@dirrm include/at-spi2-atk