aboutsummaryrefslogtreecommitdiff
path: root/accessibility/at-spi2-core
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
commit7887c684adab042fed1bfcba2e91589ecd17c4a8 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /accessibility/at-spi2-core
parent85544f2c01be814e0af1ebee1076012e7ed60bb0 (diff)
downloadports-7887c684adab042fed1bfcba2e91589ecd17c4a8.tar.gz
ports-7887c684adab042fed1bfcba2e91589ecd17c4a8.zip
* Update the glib to 2.34.3 and gtk20 to 2.24.17 and gtk30 to 3.6.4 which
are the latest stable releases. * Update vala to the newest stable release 0.18.1, also update a few ports in the gtk/gnome stack. * The c++ bindings ports for glib, atk, gconf, etc, have now USE_GNOME toggles. * Remove pkg-config run depends from glib20 and freetype2. This doesn't eliminate pkg-config run dependency completely, a second phase is needed and is planned. * Support for .:run. and .:build. for USE_GNOME components was added. Currently only libxml2 and libxslt support this mechanism. * Updates of the telepathy stack and empathy. * Trim makefile headers, convert ports to new options, trim off library versions for some ports. * Fix other ports so they build with the new glib version. Thanks to miwi and crees for helping out with some exp-runs. Approved by: portmgr (miwi & bapt) Obtained from: gnome team repo
Notes
Notes: svn path=/head/; revision=313633
Diffstat (limited to 'accessibility/at-spi2-core')
-rw-r--r--accessibility/at-spi2-core/Makefile23
-rw-r--r--accessibility/at-spi2-core/distinfo4
-rw-r--r--accessibility/at-spi2-core/files/patch-atspi_Makefile.in10
-rw-r--r--accessibility/at-spi2-core/files/patch-registryd_registry.c42
-rw-r--r--accessibility/at-spi2-core/pkg-plist167
5 files changed, 192 insertions, 54 deletions
diff --git a/accessibility/at-spi2-core/Makefile b/accessibility/at-spi2-core/Makefile
index 4e11ffcf028e..d58997e9082b 100644
--- a/accessibility/at-spi2-core/Makefile
+++ b/accessibility/at-spi2-core/Makefile
@@ -1,28 +1,33 @@
# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/accessibility/at-spi2-core/Makefile,v 1.17 2010/11/16 11:48:22 kwm Exp $
+# $MCom: ports/accessibility/at-spi2-core/Makefile,v 1.41 2012/12/16 22:36:25 kwm Exp $
PORTNAME= at-spi2-core
-PORTVERSION= 0.4.1
+PORTVERSION= 2.6.3
CATEGORIES= accessibility x11-toolkits
MASTER_SITES= GNOME
-DIST_SUBDIR= gnome2
+DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Assistive Technology Service Provider Interface
LICENSE= LGPL21
-LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib
+BUILD_DEPENDS= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
+LIB_DEPENDS= dbus-1:${PORTSDIR}/devel/dbus
-USE_BZIP2= yes
+PORTSCOUT= limitw:1,even
+
+USE_XZ= yes
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack gnomehier intlhack
-USE_XORG= x11 xi xtst
+USE_GNOME= gnomehack gnomehier glib20 intlhack
+USE_PKGCONFIG= build
+USE_XORG= x11 xi xtst xext
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-static
-
+CONFIGURE_ARGS= --enable-static \
+ --disable-xevie
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/accessibility/at-spi2-core/distinfo b/accessibility/at-spi2-core/distinfo
index 310cdb76efb3..6304e38a067c 100644
--- a/accessibility/at-spi2-core/distinfo
+++ b/accessibility/at-spi2-core/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome2/at-spi2-core-0.4.1.tar.bz2) = e3f10134851691b4c0878c2bdb778e21ded01e140b7a930d1958513c775765f9
-SIZE (gnome2/at-spi2-core-0.4.1.tar.bz2) = 277204
+SHA256 (gnome3/at-spi2-core-2.6.3.tar.xz) = fc4487ae46e847cfd057b329b852cf99923772ecd2ddc29f29670c9f2b15d0ea
+SIZE (gnome3/at-spi2-core-2.6.3.tar.xz) = 445084
diff --git a/accessibility/at-spi2-core/files/patch-atspi_Makefile.in b/accessibility/at-spi2-core/files/patch-atspi_Makefile.in
new file mode 100644
index 000000000000..e6d6cbeb0b18
--- /dev/null
+++ b/accessibility/at-spi2-core/files/patch-atspi_Makefile.in
@@ -0,0 +1,10 @@
+--- atspi/Makefile.in.orig 2011-01-24 00:11:24.000000000 +0000
++++ atspi/Makefile.in 2011-01-24 00:13:25.000000000 +0000
+@@ -897,6 +897,7 @@
+ @HAVE_INTROSPECTION_TRUE@ --nsversion=2.0 \
+ @HAVE_INTROSPECTION_TRUE@ -I$(top_builddir) \
+ @HAVE_INTROSPECTION_TRUE@ -I$(top_srcdir) \
++@HAVE_INTROSPECTION_TRUE@ $(CPPFLAGS) \
+ @HAVE_INTROSPECTION_TRUE@ --include=GLib-2.0 \
+ @HAVE_INTROSPECTION_TRUE@ --include=GObject-2.0 \
+ @HAVE_INTROSPECTION_TRUE@ --libtool="$(top_builddir)/libtool" \
diff --git a/accessibility/at-spi2-core/files/patch-registryd_registry.c b/accessibility/at-spi2-core/files/patch-registryd_registry.c
deleted file mode 100644
index 678eea097faf..000000000000
--- a/accessibility/at-spi2-core/files/patch-registryd_registry.c
+++ /dev/null
@@ -1,42 +0,0 @@
---- registryd/registry.c.orig 2011-06-20 23:41:30.000000000 +0200
-+++ registryd/registry.c 2011-06-20 23:57:26.000000000 +0200
-@@ -348,7 +348,7 @@
- const char *member = dbus_message_get_member (message);
-
- if (type != DBUS_MESSAGE_TYPE_SIGNAL)
-- return;
-+ return DBUS_HANDLER_RESULT_NOT_YET_HANDLED;
-
- if (!g_strcmp0(iface, DBUS_INTERFACE_DBUS) &&
- !g_strcmp0(member, "NameOwnerChanged"))
-@@ -806,18 +806,18 @@
-
- if (!dbus_message_get_args (message, NULL, DBUS_TYPE_STRING, &orig_name,
- DBUS_TYPE_INVALID))
-- return;
-+ return NULL;
-
- name = ensure_proper_format (orig_name);
-
- evdata = (event_data *) g_malloc (sizeof (*evdata));
- if (!evdata)
-- return;
-+ return NULL;
- data = g_strsplit (name, ":", 3);
- if (!data)
- {
- g_free (evdata);
-- return;
-+ return NULL;
- }
- if (!data [0])
- data [1] = NULL;
-@@ -856,7 +856,7 @@
-
- if (!dbus_message_get_args (message, NULL, DBUS_TYPE_STRING, &orig_name,
- DBUS_TYPE_INVALID))
-- return;
-+ return NULL;
- name = ensure_proper_format (orig_name);
-
- remove_events (registry, sender, name);
diff --git a/accessibility/at-spi2-core/pkg-plist b/accessibility/at-spi2-core/pkg-plist
index 55de074ee261..09efc89e6cae 100644
--- a/accessibility/at-spi2-core/pkg-plist
+++ b/accessibility/at-spi2-core/pkg-plist
@@ -1,6 +1,171 @@
-bin/at-spi-dbus-bus
etc/at-spi2/accessibility.conf
etc/xdg/autostart/at-spi-dbus-bus.desktop
+include/at-spi-2.0/atspi/atspi.h
+include/at-spi-2.0/atspi/atspi-accessible.h
+include/at-spi-2.0/atspi/atspi-action.h
+include/at-spi-2.0/atspi/atspi-application.h
+include/at-spi-2.0/atspi/atspi-collection.h
+include/at-spi-2.0/atspi/atspi-component.h
+include/at-spi-2.0/atspi/atspi-constants.h
+include/at-spi-2.0/atspi/atspi-device-listener.h
+include/at-spi-2.0/atspi/atspi-device-listener-private.h
+include/at-spi-2.0/atspi/atspi-document.h
+include/at-spi-2.0/atspi/atspi-editabletext.h
+include/at-spi-2.0/atspi/atspi-event-listener.h
+include/at-spi-2.0/atspi/atspi-event-listener-private.h
+include/at-spi-2.0/atspi/atspi-gmain.c
+include/at-spi-2.0/atspi/atspi-gmain.h
+include/at-spi-2.0/atspi/atspi-hyperlink.h
+include/at-spi-2.0/atspi/atspi-hypertext.h
+include/at-spi-2.0/atspi/atspi-image.h
+include/at-spi-2.0/atspi/atspi-misc.h
+include/at-spi-2.0/atspi/atspi-matchrule.h
+include/at-spi-2.0/atspi/atspi-object.h
+include/at-spi-2.0/atspi/atspi-private.h
+include/at-spi-2.0/atspi/atspi-registry.h
+include/at-spi-2.0/atspi/atspi-relation.h
+include/at-spi-2.0/atspi/atspi-selection.h
+include/at-spi-2.0/atspi/atspi-stateset.h
+include/at-spi-2.0/atspi/atspi-table.h
+include/at-spi-2.0/atspi/atspi-text.h
+include/at-spi-2.0/atspi/atspi-types.h
+include/at-spi-2.0/atspi/atspi-value.h
+lib/girepository-1.0/Atspi-2.0.typelib
+lib/libatspi.a
+lib/libatspi.la
+lib/libatspi.so
+lib/libatspi.so.0
+libdata/pkgconfig/atspi-2.pc
+libexec/at-spi-bus-launcher
libexec/at-spi2-registryd
+share/dbus-1/services/org.a11y.Bus.service
share/dbus-1/services/org.a11y.atspi.Registry.service
+share/gir-1.0/Atspi-2.0.gir
+share/gtk-doc/html/libatspi/AtspiAccessible.html
+share/gtk-doc/html/libatspi/AtspiDeviceListener.html
+share/gtk-doc/html/libatspi/AtspiEventListener.html
+share/gtk-doc/html/libatspi/AtspiHyperlink.html
+share/gtk-doc/html/libatspi/AtspiMatchRule.html
+share/gtk-doc/html/libatspi/AtspiObject.html
+share/gtk-doc/html/libatspi/AtspiRelation.html
+share/gtk-doc/html/libatspi/AtspiStateSet.html
+share/gtk-doc/html/libatspi/annotation-glossary.html
+share/gtk-doc/html/libatspi/api-index-full.html
+share/gtk-doc/html/libatspi/ch01.html
+share/gtk-doc/html/libatspi/home.png
+share/gtk-doc/html/libatspi/index.html
+share/gtk-doc/html/libatspi/index.sgml
+share/gtk-doc/html/libatspi/left.png
+share/gtk-doc/html/libatspi/libatspi-AtspiApplication.html
+share/gtk-doc/html/libatspi/libatspi-atspi-action.html
+share/gtk-doc/html/libatspi/libatspi-atspi-collection.html
+share/gtk-doc/html/libatspi/libatspi-atspi-component.html
+share/gtk-doc/html/libatspi/libatspi-atspi-constants.html
+share/gtk-doc/html/libatspi/libatspi-atspi-document.html
+share/gtk-doc/html/libatspi/libatspi-atspi-editabletext.html
+share/gtk-doc/html/libatspi/libatspi-atspi-hypertext.html
+share/gtk-doc/html/libatspi/libatspi-atspi-image.html
+share/gtk-doc/html/libatspi/libatspi-atspi-listener-private.html
+share/gtk-doc/html/libatspi/libatspi-atspi-misc-private.html
+share/gtk-doc/html/libatspi/libatspi-atspi-misc.html
+share/gtk-doc/html/libatspi/libatspi-atspi-registry.html
+share/gtk-doc/html/libatspi/libatspi-atspi-selection.html
+share/gtk-doc/html/libatspi/libatspi-atspi-table.html
+share/gtk-doc/html/libatspi/libatspi-atspi-text.html
+share/gtk-doc/html/libatspi/libatspi-atspi-types.html
+share/gtk-doc/html/libatspi/libatspi-atspi-value.html
+share/gtk-doc/html/libatspi/libatspi.devhelp2
+share/gtk-doc/html/libatspi/object-tree.html
+share/gtk-doc/html/libatspi/right.png
+share/gtk-doc/html/libatspi/style.css
+share/gtk-doc/html/libatspi/up.png
+share/locale/an/LC_MESSAGES/at-spi2-core.mo
+share/locale/as/LC_MESSAGES/at-spi2-core.mo
+share/locale/ast/LC_MESSAGES/at-spi2-core.mo
+share/locale/be/LC_MESSAGES/at-spi2-core.mo
+share/locale/bg/LC_MESSAGES/at-spi2-core.mo
+share/locale/bn_IN/LC_MESSAGES/at-spi2-core.mo
+share/locale/ca/LC_MESSAGES/at-spi2-core.mo
+share/locale/ca@valencia/LC_MESSAGES/at-spi2-core.mo
+share/locale/cs/LC_MESSAGES/at-spi2-core.mo
+share/locale/da/LC_MESSAGES/at-spi2-core.mo
+share/locale/de/LC_MESSAGES/at-spi2-core.mo
+share/locale/el/LC_MESSAGES/at-spi2-core.mo
+share/locale/en_CA/LC_MESSAGES/at-spi2-core.mo
+share/locale/en_GB/LC_MESSAGES/at-spi2-core.mo
+share/locale/eo/LC_MESSAGES/at-spi2-core.mo
+share/locale/es/LC_MESSAGES/at-spi2-core.mo
+share/locale/et/LC_MESSAGES/at-spi2-core.mo
+share/locale/eu/LC_MESSAGES/at-spi2-core.mo
+share/locale/fa/LC_MESSAGES/at-spi2-core.mo
+share/locale/fi/LC_MESSAGES/at-spi2-core.mo
+share/locale/fr/LC_MESSAGES/at-spi2-core.mo
+share/locale/gl/LC_MESSAGES/at-spi2-core.mo
+share/locale/gu/LC_MESSAGES/at-spi2-core.mo
+share/locale/he/LC_MESSAGES/at-spi2-core.mo
+share/locale/hi/LC_MESSAGES/at-spi2-core.mo
+share/locale/hu/LC_MESSAGES/at-spi2-core.mo
+share/locale/id/LC_MESSAGES/at-spi2-core.mo
+share/locale/it/LC_MESSAGES/at-spi2-core.mo
+share/locale/ja/LC_MESSAGES/at-spi2-core.mo
+share/locale/km/LC_MESSAGES/at-spi2-core.mo
+share/locale/kn/LC_MESSAGES/at-spi2-core.mo
+share/locale/ko/LC_MESSAGES/at-spi2-core.mo
+share/locale/lt/LC_MESSAGES/at-spi2-core.mo
+share/locale/lv/LC_MESSAGES/at-spi2-core.mo
+share/locale/ml/LC_MESSAGES/at-spi2-core.mo
+share/locale/mr/LC_MESSAGES/at-spi2-core.mo
+share/locale/ms/LC_MESSAGES/at-spi2-core.mo
+share/locale/nb/LC_MESSAGES/at-spi2-core.mo
+share/locale/nl/LC_MESSAGES/at-spi2-core.mo
+share/locale/or/LC_MESSAGES/at-spi2-core.mo
+share/locale/pa/LC_MESSAGES/at-spi2-core.mo
+share/locale/pl/LC_MESSAGES/at-spi2-core.mo
+share/locale/pt/LC_MESSAGES/at-spi2-core.mo
+share/locale/pt_BR/LC_MESSAGES/at-spi2-core.mo
+share/locale/ro/LC_MESSAGES/at-spi2-core.mo
+share/locale/ru/LC_MESSAGES/at-spi2-core.mo
+share/locale/sk/LC_MESSAGES/at-spi2-core.mo
+share/locale/sl/LC_MESSAGES/at-spi2-core.mo
+share/locale/sq/LC_MESSAGES/at-spi2-core.mo
+share/locale/sr/LC_MESSAGES/at-spi2-core.mo
+share/locale/sr@latin/LC_MESSAGES/at-spi2-core.mo
+share/locale/sv/LC_MESSAGES/at-spi2-core.mo
+share/locale/ta/LC_MESSAGES/at-spi2-core.mo
+share/locale/te/LC_MESSAGES/at-spi2-core.mo
+share/locale/tr/LC_MESSAGES/at-spi2-core.mo
+share/locale/ug/LC_MESSAGES/at-spi2-core.mo
+share/locale/uk/LC_MESSAGES/at-spi2-core.mo
+share/locale/uz@cyrillic/LC_MESSAGES/at-spi2-core.mo
+share/locale/vi/LC_MESSAGES/at-spi2-core.mo
+share/locale/zh_CN/LC_MESSAGES/at-spi2-core.mo
+share/locale/zh_HK/LC_MESSAGES/at-spi2-core.mo
+share/locale/zh_TW/LC_MESSAGES/at-spi2-core.mo
+@dirrmtry share/locale/uz@cyrillic/LC_MESSAGES
+@dirrmtry share/locale/uz@cyrillic
+@dirrmtry share/locale/ug/LC_MESSAGES
+@dirrmtry share/locale/ug
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/km/LC_MESSAGES
+@dirrmtry share/locale/km
+@dirrmtry share/locale/ca@valencia/LC_MESSAGES
+@dirrmtry share/locale/ca@valencia
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast
+@dirrmtry share/locale/as/LC_MESSAGES
+@dirrmtry share/locale/as
+@dirrmtry share/locale/an/LC_MESSAGES
+@dirrmtry share/locale/an
+@dirrm share/gtk-doc/html/libatspi
+@dirrmtry share/gtk-doc/html
+@dirrmtry share/gtk-doc
+@dirrm include/at-spi-2.0/atspi
+@dirrm include/at-spi-2.0
@dirrm etc/at-spi2