aboutsummaryrefslogtreecommitdiff
path: root/accessibility/gnomespeech/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-18 07:01:13 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-18 07:01:13 +0000
commitb992c3888cd5be32b10bb9a4fca83b6cd55d59da (patch)
tree28e7f81c2b940b36ec73c0b3fc864ff970da31d8 /accessibility/gnomespeech/Makefile
parent7bb32ba6ae92c2d032e32d14da1040ecbdbfeb49 (diff)
downloadports-b992c3888cd5be32b10bb9a4fca83b6cd55d59da.tar.gz
ports-b992c3888cd5be32b10bb9a4fca83b6cd55d59da.zip
Add gnomespeech, a library that facilitates text-to-speech for the GNOME
desktop.
Notes
Notes: svn path=/head/; revision=89033
Diffstat (limited to 'accessibility/gnomespeech/Makefile')
-rw-r--r--accessibility/gnomespeech/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/accessibility/gnomespeech/Makefile b/accessibility/gnomespeech/Makefile
new file mode 100644
index 000000000000..c1ccecaaf3e8
--- /dev/null
+++ b/accessibility/gnomespeech/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: gnomespeech
+# Date created: 11 May 2003
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomespeech
+PORTVERSION= 0.2.7
+CATEGORIES= audio gnome accessibility
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/gnome-speech/0.2
+DISTNAME= gnome-speech-${PORTVERSION}
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GNOME text-to-speech API
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack libbonobo
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --enable-static
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/festival)
+WITH_FESTIVAL= yes
+.endif
+
+.if defined(WITH_FESTIVAL)
+RUN_DEPENDS= festival:${PORTSDIR}/audio/festival
+.endif
+
+.include <bsd.port.post.mk>