aboutsummaryrefslogtreecommitdiff
path: root/accessibility/orca
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /accessibility/orca
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
downloadports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.gz
ports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Notes
Notes: svn path=/head/; revision=455210
Diffstat (limited to 'accessibility/orca')
-rw-r--r--accessibility/orca/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/accessibility/orca/Makefile b/accessibility/orca/Makefile
index d817d3a7a600..eadbc07578d5 100644
--- a/accessibility/orca/Makefile
+++ b/accessibility/orca/Makefile
@@ -10,16 +10,16 @@ DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Scriptable screen reader
-BUILD_DEPENDS= py3?-dbus>=0:devel/py3-dbus \
- py3?-xdg>=0:devel/py3-xdg \
- py3?-cairo>=0:graphics/py3-cairo \
+BUILD_DEPENDS= py3?-dbus>=0:devel/py-dbus@${PY_FLAVOR} \
+ py3?-xdg>=0:devel/py-xdg@${PY_FLAVOR} \
+ py3?-cairo>=0:graphics/py-cairo@${PY_FLAVOR} \
itstool:textproc/itstool
LIB_DEPENDS= libatspi.so:accessibility/at-spi2-core
-RUN_DEPENDS= py3?-dbus>=0:devel/py3-dbus \
- py3?-speech-dispatcher>=0:accessibility/py3-speech-dispatcher \
- py3?-atspi>=0:accessibility/py3-atspi \
- py3?-xdg>=0:devel/py3-xdg \
- py3?-cairo>=0:graphics/py3-cairo
+RUN_DEPENDS= py3?-dbus>=0:devel/py-dbus@${PY_FLAVOR} \
+ py3?-speech-dispatcher>=0:accessibility/py-speech-dispatcher@${PY_FLAVOR} \
+ py3?-atspi>=0:accessibility/py-atspi@${PY_FLAVOR} \
+ py3?-xdg>=0:devel/py-xdg@${PY_FLAVOR} \
+ py3?-cairo>=0:graphics/py-cairo@${PY_FLAVOR}
# conflict with py*-json-py because orca uses the json from python itself
# and py*-json-py shadows this.
@@ -27,7 +27,7 @@ CONFLICTS= py*-json-py-[0-9]*
PORTSCOUT= limitw:1,even
NO_ARCH= yes
-USES= gettext gmake gnome pathfix pkgconfig python:3 tar:xz
+USES= gettext gmake gnome pathfix pkgconfig python:3.4+ tar:xz
USE_GNOME= gtk30 py3gobject3 intlhack
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes