aboutsummaryrefslogtreecommitdiff
path: root/accessibility/py-papi/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2007-09-15 18:44:49 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2007-09-15 18:44:49 +0000
commite89de43ae0339d2b07b4fa192de503424121afc3 (patch)
treeed758de8cb3369bb1339f5189d2faed616f2c213 /accessibility/py-papi/Makefile
parentf04bd485c3eea5cb00ef2863a36c1d5707e2cc8b (diff)
downloadports-e89de43ae0339d2b07b4fa192de503424121afc3.tar.gz
ports-e89de43ae0339d2b07b4fa192de503424121afc3.zip
- Update to 0.0.5
- DOCSDIR safety - respecting EXAMPLESDIR PR: ports/115006 Submitted by: Marcus von Appen <mva@sysfault.org> (maintainer)
Notes
Notes: svn path=/head/; revision=199529
Diffstat (limited to 'accessibility/py-papi/Makefile')
-rw-r--r--accessibility/py-papi/Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/accessibility/py-papi/Makefile b/accessibility/py-papi/Makefile
index f049c2370257..18b0135ef2b6 100644
--- a/accessibility/py-papi/Makefile
+++ b/accessibility/py-papi/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= papi
-PORTVERSION= 0.0.4
+PORTVERSION= 0.0.5
CATEGORIES= accessibility devel python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ocemp
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= papi-${PORTVERSION}
MAINTAINER= mva@sysfault.org
COMMENT= ATK accessibility wrapper for python
@@ -21,9 +20,22 @@ USE_GCC= 3.4+
USE_PYTHON= yes
USE_PYDISTUTILS=yes
+PORTDOCS= manual.html
+PORTEXAMPLES= atkaction.py atkapplication.py
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/papi.so
+
post-patch:
-.if defined(NOPORTDOCS)
${REINPLACE_CMD} -i "" -e 's|: docfiles|: []|g' ${WRKSRC}/setup.py
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -d ${DOCSDIR}/
+ @cd ${WRKSRC}/doc && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${INSTALL} -d ${EXAMPLESDIR}/
+ @cd ${WRKSRC}/doc/examples && \
+ ${INSTALL_DATA} ${PORTEXAMPLES} ${EXAMPLESDIR}/
.endif
.include <bsd.port.mk>