aboutsummaryrefslogtreecommitdiff
path: root/accessibility/yasr
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2008-02-16 17:23:44 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2008-02-16 17:23:44 +0000
commit43804a60ba7f288f4e58b462414aad63c0ff26c7 (patch)
treea94453c4fde35e1167102eedb84f88dfe5118735 /accessibility/yasr
parenteb384d41a1ba18d2579bc52776f2420aa6cb76f5 (diff)
downloadports-43804a60ba7f288f4e58b462414aad63c0ff26c7.tar.gz
ports-43804a60ba7f288f4e58b462414aad63c0ff26c7.zip
YASR ("Yet Another Screen Reader") is an attempt at a lightweight,
portable screen reader. It works by opening a shell in a pty and intercepting all user input/output, maintaining a window of what should be on the screen by looking at the codes and text sent to the screen. It thus uses no Linuxisms such as /dev/vcsa0 and does not necessarily need to be setuid root (the only requirement being that the user be able to access the tts device). WWW: http://yasr.sourceforge.net/ Ported by David K. Gerry <David.K.Gerry@GMail.com> PR: ports/119789 Submitted by: David K. Gerry
Notes
Notes: svn path=/head/; revision=207359
Diffstat (limited to 'accessibility/yasr')
-rw-r--r--accessibility/yasr/Makefile48
-rw-r--r--accessibility/yasr/distinfo3
-rw-r--r--accessibility/yasr/files/pkg-message.in26
-rw-r--r--accessibility/yasr/pkg-descr11
4 files changed, 88 insertions, 0 deletions
diff --git a/accessibility/yasr/Makefile b/accessibility/yasr/Makefile
new file mode 100644
index 000000000000..1924c8d813a7
--- /dev/null
+++ b/accessibility/yasr/Makefile
@@ -0,0 +1,48 @@
+# Ports collection makefile for: yasr
+# Date created: Wed Jan 14 2004
+# Whom: David K. Gerry
+#
+# $FreeBSD$
+#
+
+PORTNAME= yasr
+PORTVERSION= 0.6.7
+CATEGORIES= accessibility
+MASTER_SITES= SF
+
+MAINTAINER= David.K.Gerry@GMail.com
+COMMENT= A general-purpose console screen reader
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+MAN1= yasr.1
+PORTDOCS= AUTHORS BUGS CREDITS ChangeLog NEWS README TODO
+SUB_FILES= pkg-message
+
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+.if !defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --enable-nls
+PLIST_SUB+= NLS=""
+USE_GETTEXT= yes
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+PLIST_FILES= bin/yasr \
+ %%DATADIR%%/yasr.conf
+PLIST_DIRS= %%DATADIR%%
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/bin/bash|/bin/csh|' ${WRKSRC}/yasr.conf
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+ @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
+
+.include <bsd.port.mk>
diff --git a/accessibility/yasr/distinfo b/accessibility/yasr/distinfo
new file mode 100644
index 000000000000..5b64261450e8
--- /dev/null
+++ b/accessibility/yasr/distinfo
@@ -0,0 +1,3 @@
+MD5 (yasr-0.6.7.tar.gz) = c7c6191f1d7413317924e580809817dc
+SHA256 (yasr-0.6.7.tar.gz) = dee640ae4a4c813f8248816f9457788737f4b90e38fe9e1a857f4eaf42dec159
+SIZE (yasr-0.6.7.tar.gz) = 201786
diff --git a/accessibility/yasr/files/pkg-message.in b/accessibility/yasr/files/pkg-message.in
new file mode 100644
index 000000000000..d7bea2bfb949
--- /dev/null
+++ b/accessibility/yasr/files/pkg-message.in
@@ -0,0 +1,26 @@
+==============================================================================
+
+Yasr requires a text-to-speech engine to work. FreeBSD offers two: Festival
+and FLite (Festival Lite). Edit the system configuration file
+%%DATADIR%%/yasr.conf
+or user configuration file ~/.yasr.conf and set "synthesizer" and
+"synthesizer port".
+
+NOTE: To use FLite requires the Emacspeak speech server eflite to be
+installed.
+
+EXAMPLES:
+
+Festival
+ synthesizer=festival
+ sythesizer port=|%%LOCALBASE%%/bin/festival
+Festival running as a server
+ synthesizer=festival
+ synthesizer port=127.0.0.1:1314
+FLite
+ synthesizer=Emacspeak server
+ synthesizer port=|%%LOCALBASE%%/bin/eflite
+
+See man page for more information.
+
+==============================================================================
diff --git a/accessibility/yasr/pkg-descr b/accessibility/yasr/pkg-descr
new file mode 100644
index 000000000000..c4fec745a0e6
--- /dev/null
+++ b/accessibility/yasr/pkg-descr
@@ -0,0 +1,11 @@
+YASR ("Yet Another Screen Reader") is an attempt at a lightweight,
+portable screen reader. It works by opening a shell in a pty and
+intercepting all user input/output, maintaining a window of what
+should be on the screen by looking at the codes and text sent to the
+screen. It thus uses no Linuxisms such as /dev/vcsa0 and does not
+necessarily need to be setuid root (the only requirement being that
+the user be able to access the tts device).
+
+WWW: http://yasr.sourceforge.net/
+
+Ported by David K. Gerry <David.K.Gerry@GMail.com>