aboutsummaryrefslogtreecommitdiff
path: root/accessibility
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-10-29 17:05:50 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-10-29 17:05:50 +0000
commit86a87d94deeff108abeb4ee1ef47bbaf3297d6e6 (patch)
tree5cd403e620f727ad5e2f7c0bfa122a124e085d34 /accessibility
parent575fd60ec85f55e084270850b084bab844ed4798 (diff)
downloadports-86a87d94deeff108abeb4ee1ef47bbaf3297d6e6.tar.gz
ports-86a87d94deeff108abeb4ee1ef47bbaf3297d6e6.zip
Restrict python to -2.7
Submitted by: mva@
Notes
Notes: svn path=/head/; revision=331973
Diffstat (limited to 'accessibility')
-rw-r--r--accessibility/accerciser/Makefile4
-rw-r--r--accessibility/accerciser/pkg-plist1
-rw-r--r--accessibility/at-spi/Makefile2
-rw-r--r--accessibility/orca/Makefile2
-rw-r--r--accessibility/py-atspi/Makefile2
-rw-r--r--accessibility/speech-dispatcher/Makefile2
6 files changed, 6 insertions, 7 deletions
diff --git a/accessibility/accerciser/Makefile b/accessibility/accerciser/Makefile
index 602bdad75426..c4ef6ae0ae98 100644
--- a/accessibility/accerciser/Makefile
+++ b/accessibility/accerciser/Makefile
@@ -12,10 +12,9 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Interactive Python accessibility explorer for GNOME
-NO_STAGE= yes
USE_BZIP2= yes
USE_GNOME= pygnomedesktop atspi intlhack
-USE_PYTHON= yes
+USE_PYTHON= -2.7
USES= display:configure gettext gmake pkgconfig
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
@@ -24,6 +23,5 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
GCONF_SCHEMAS= accerciser.schemas
-MAN1= accerciser.1
.include <bsd.port.mk>
diff --git a/accessibility/accerciser/pkg-plist b/accessibility/accerciser/pkg-plist
index b4e45b7e06c1..f34ddbfc8b02 100644
--- a/accessibility/accerciser/pkg-plist
+++ b/accessibility/accerciser/pkg-plist
@@ -56,6 +56,7 @@ bin/accerciser
%%PYTHON_SITELIBDIR%%/accerciser/ui_manager.py
%%PYTHON_SITELIBDIR%%/accerciser/ui_manager.pyc
%%PYTHON_SITELIBDIR%%/accerciser/ui_manager.pyo
+man/man1/accerciser.1.gz
%%DATADIR%%/pixmaps/hicolor/22x22/acceleratorlabel.png
%%DATADIR%%/pixmaps/hicolor/22x22/alert.png
%%DATADIR%%/pixmaps/hicolor/22x22/animation.png
diff --git a/accessibility/at-spi/Makefile b/accessibility/at-spi/Makefile
index 6ace5e878b37..1e7b9dcdea9a 100644
--- a/accessibility/at-spi/Makefile
+++ b/accessibility/at-spi/Makefile
@@ -22,7 +22,7 @@ NO_STAGE= yes
USES= gmake gettext pkgconfig
USE_GNOME= gnomehack gnomehier intlhack gtk20 gconf2 libbonobo
USE_XORG= x11 xtst
-USE_PYTHON= yes
+USE_PYTHON= -2.7
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-static
diff --git a/accessibility/orca/Makefile b/accessibility/orca/Makefile
index a7b6ef35e82a..1fc8fae5d14c 100644
--- a/accessibility/orca/Makefile
+++ b/accessibility/orca/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_dbus_bindings.so:${PORTSDIR}/devel/py-dbus \
NO_STAGE= yes
USE_BZIP2= yes
USES= gmake gettext pkgconfig
-USE_PYTHON= yes
+USE_PYTHON= -2.7
USE_GNOME= gnomeprefix gnomehack libgnomeui gnomespeech pygnome2 \
pygnomedesktop
INSTALLS_ICONS= yes
diff --git a/accessibility/py-atspi/Makefile b/accessibility/py-atspi/Makefile
index 0bb36cd2f2e9..3fb26df2323a 100644
--- a/accessibility/py-atspi/Makefile
+++ b/accessibility/py-atspi/Makefile
@@ -23,7 +23,7 @@ USE_XZ= yes
USES= gettext gmake pathfix pkgconfig
USE_GNOME= gnomehier intlhack pygobject3
GNU_CONFIGURE= yes
-USE_PYTHON= yes
+USE_PYTHON= -2.7
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/accessibility/speech-dispatcher/Makefile b/accessibility/speech-dispatcher/Makefile
index 6d6149c37890..8f9b50a5c550 100644
--- a/accessibility/speech-dispatcher/Makefile
+++ b/accessibility/speech-dispatcher/Makefile
@@ -104,7 +104,7 @@ CONFIGURE_ARGS+=--without-pulse
.endif
.if ${PORT_OPTIONS:MPYTHON}
-USE_PYTHON= 2.5+
+USE_PYTHON= -2.7
CONFIGURE_ARGS+=--enable-python
PLIST_SUB+= PYTHON=""
.else