aboutsummaryrefslogtreecommitdiff
path: root/accessibility
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2003-04-15 02:23:37 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2003-04-15 02:23:37 +0000
commitc6b1eba40f00db178caa57c2bfa45b2519f83f36 (patch)
tree0d0282b3b1134ad8470cdb52524d24d1bfcbdeae /accessibility
parent043f1e3f6a97edf92574ef21dac8ff41d9801a31 (diff)
downloadports-c6b1eba40f00db178caa57c2bfa45b2519f83f36.tar.gz
ports-c6b1eba40f00db178caa57c2bfa45b2519f83f36.zip
The GNOME On-Screen Keyboard (GOK) is an accessability interface
that gives you control of your system without needing a keyboard. The GOK makes available a hierarchical button system that enables keyboardless entry of common accelerators, and contains a clickable keyboard that sports suggested autocompletion of many common words, and even some commands. The GOK will provide an alternative interface to common commands and functions within applications that utilize the AT SPI. The GOK is is designed to be usable by many alternative input methods, i.e. not a common keyboard and mouse combination.
Notes
Notes: svn path=/head/; revision=78996
Diffstat (limited to 'accessibility')
-rw-r--r--accessibility/gok/Makefile32
-rw-r--r--accessibility/gok/distinfo1
-rw-r--r--accessibility/gok/pkg-descr13
-rw-r--r--accessibility/gok/pkg-plist120
4 files changed, 166 insertions, 0 deletions
diff --git a/accessibility/gok/Makefile b/accessibility/gok/Makefile
new file mode 100644
index 000000000000..50dfaf2d7425
--- /dev/null
+++ b/accessibility/gok/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gok
+# Date created: 12 April 2003
+# Whom: Adam Weinberger <adamw@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gok
+PORTVERSION= 0.7.0
+CATEGORIES= sysutils gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.7
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GNOME On-Screen Keyboard (GOK)
+
+USE_X_PREFIX= yes
+USE_GNOME= gnomehack gnomeprefix libgnomeui atspi libwnck atk
+USE_REINPLACE= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|' \
+ ${WRKSRC}/gok/word-complete.c
+
+.include <bsd.port.mk>
diff --git a/accessibility/gok/distinfo b/accessibility/gok/distinfo
new file mode 100644
index 000000000000..7dee85632c07
--- /dev/null
+++ b/accessibility/gok/distinfo
@@ -0,0 +1 @@
+MD5 (gnome2/gok-0.7.0.tar.gz) = 628786adb05a12143ffc575ac5a5abec
diff --git a/accessibility/gok/pkg-descr b/accessibility/gok/pkg-descr
new file mode 100644
index 000000000000..1eb9874537ea
--- /dev/null
+++ b/accessibility/gok/pkg-descr
@@ -0,0 +1,13 @@
+The GNOME On-Screen Keyboard (GOK) is an accessability interface
+that gives you control of your system without needing a keyboard.
+The GOK makes available a hierarchical button system that enables
+keyboardless entry of common accelerators, and contains a
+clickable keyboard that sports suggested autocompletion of many
+common words, and even some commands. The GOK will provide an
+alternative interface to common commands and functions within
+applications that utilize the AT SPI.
+
+The GOK is is designed to be usable by many alternative input
+methods, i.e. not a common keyboard and mouse combination.
+
+WWW: http://www.gok.ca
diff --git a/accessibility/gok/pkg-plist b/accessibility/gok/pkg-plist
new file mode 100644
index 000000000000..dc17a92e4d3c
--- /dev/null
+++ b/accessibility/gok/pkg-plist
@@ -0,0 +1,120 @@
+bin/gok
+etc/gconf/schemas/gok.schemas
+etc/gconf/gconf.xml.defaults/apps/gok/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gok/layout/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gok/actions/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gok/actions/switch1/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gok/actions/switch2/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gok/actions/switch3/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gok/actions/switch4/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gok/actions/switch5/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gok/actions/mousebutton1/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gok/actions/mousebutton2/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gok/actions/mousebutton3/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gok/actions/mousebutton4/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gok/actions/mousebutton5/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gok/actions/mousepointer/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gok/actions/dwell/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gok/feedbacks/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gok/feedbacks/none/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gok/feedbacks/key_flashing/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gok/feedbacks/goksound1/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gok/feedbacks/goksound2/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gok/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gok/layout/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gok/actions/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gok/actions/switch1/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gok/actions/switch2/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gok/actions/switch3/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gok/actions/switch4/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gok/actions/switch5/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gok/actions/mousebutton1/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gok/actions/mousebutton2/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gok/actions/mousebutton3/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gok/actions/mousebutton4/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gok/actions/mousebutton5/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gok/actions/mousepointer/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gok/actions/dwell/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gok/feedbacks/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gok/feedbacks/none/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gok/feedbacks/key_flashing/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gok/feedbacks/goksound1/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gok/feedbacks/goksound2/%gconf.xml
+libdata/pkgconfig/gok-1.0.pc
+share/locale/am/LC_MESSAGES/gok.mo
+share/locale/ca/LC_MESSAGES/gok.mo
+share/locale/cs/LC_MESSAGES/gok.mo
+share/locale/de/LC_MESSAGES/gok.mo
+share/locale/es/LC_MESSAGES/gok.mo
+share/locale/fr/LC_MESSAGES/gok.mo
+share/locale/nl/LC_MESSAGES/gok.mo
+share/locale/no/LC_MESSAGES/gok.mo
+share/locale/pt/LC_MESSAGES/gok.mo
+share/locale/pt_BR/LC_MESSAGES/gok.mo
+share/locale/sv/LC_MESSAGES/gok.mo
+share/locale/uk/LC_MESSAGES/gok.mo
+share/locale/vi/LC_MESSAGES/gok.mo
+share/gnome/help/gok/C/gok.xml
+share/gnome/omf/gok/gok-C.omf
+@exec scrollkeeper-install -q %D/share/gnome/omf/gok/gok-C.omf
+share/gnome/gok/main.kbd
+share/gnome/gok/qwerty.kbd
+share/gnome/gok/alphabet.kbd
+share/gnome/gok/manage.kbd
+share/gnome/gok/launcher.kbd
+share/gnome/gok/move-resize.kbd
+share/gnome/gok/direct-selection.xam
+share/gnome/gok/dwell-selection.xam
+share/gnome/gok/automatic-scanning.xam
+share/gnome/gok/inverse-scanning.xam
+share/gnome/gok/dictionary.txt
+share/gnome/gok/gok.rc
+share/gnome/gok/goksound1.wav
+share/gnome/gok/goksound2.wav
+share/gnome/gok/Keyboard.kbd
+@dirrm share/gnome/gok
+@dirrm share/gnome/omf/gok
+@dirrm share/gnome/help/gok/C/figures
+@dirrm share/gnome/help/gok/C
+@dirrm share/gnome/help/gok
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gok/feedbacks/goksound1
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gok/feedbacks/goksound2
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gok/feedbacks/key_flashing
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gok/feedbacks/none
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gok/feedbacks
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gok/actions/dwell
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gok/actions/mousepointer
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gok/actions/mousebutton5
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gok/actions/mousebutton4
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gok/actions/mousebutton3
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gok/actions/mousebutton2
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gok/actions/mousebutton1
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gok/actions/switch5
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gok/actions/switch4
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gok/actions/switch3
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gok/actions/switch2
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gok/actions/switch1
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gok/actions
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gok/layout
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gok
+@dirrm etc/gconf/gconf.xml.defaults/apps/gok/feedbacks/goksound1
+@dirrm etc/gconf/gconf.xml.defaults/apps/gok/feedbacks/goksound2
+@dirrm etc/gconf/gconf.xml.defaults/apps/gok/feedbacks/key_flashing
+@dirrm etc/gconf/gconf.xml.defaults/apps/gok/feedbacks/none
+@dirrm etc/gconf/gconf.xml.defaults/apps/gok/feedbacks
+@dirrm etc/gconf/gconf.xml.defaults/apps/gok/actions/dwell
+@dirrm etc/gconf/gconf.xml.defaults/apps/gok/actions/mousepointer
+@dirrm etc/gconf/gconf.xml.defaults/apps/gok/actions/mousebutton5
+@dirrm etc/gconf/gconf.xml.defaults/apps/gok/actions/mousebutton4
+@dirrm etc/gconf/gconf.xml.defaults/apps/gok/actions/mousebutton3
+@dirrm etc/gconf/gconf.xml.defaults/apps/gok/actions/mousebutton2
+@dirrm etc/gconf/gconf.xml.defaults/apps/gok/actions/mousebutton1
+@dirrm etc/gconf/gconf.xml.defaults/apps/gok/actions/switch5
+@dirrm etc/gconf/gconf.xml.defaults/apps/gok/actions/switch4
+@dirrm etc/gconf/gconf.xml.defaults/apps/gok/actions/switch3
+@dirrm etc/gconf/gconf.xml.defaults/apps/gok/actions/switch2
+@dirrm etc/gconf/gconf.xml.defaults/apps/gok/actions/switch1
+@dirrm etc/gconf/gconf.xml.defaults/apps/gok/actions
+@dirrm etc/gconf/gconf.xml.defaults/apps/gok/layout
+@dirrm etc/gconf/gconf.xml.defaults/apps/gok
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gok/gok-C.omf