aboutsummaryrefslogtreecommitdiff
path: root/arabic
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-24 23:33:38 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-24 23:33:38 +0000
commit7a8709c112c4079fe65b1444a1aa2483a1b2862e (patch)
tree6513052c312b8fe085dc322b368790e5ad50492b /arabic
parent978d929cecb02ac32eaaef586e725fc58c6041de (diff)
downloadports-7a8709c112c4079fe65b1444a1aa2483a1b2862e.tar.gz
ports-7a8709c112c4079fe65b1444a1aa2483a1b2862e.zip
- Fix crash in search and replace
- Fix crash on exit when permissions on configuration file were changed PR: ports/67126 Submitted by: Samy Al Bahra <samy@kerneled.org> (maintainer)
Notes
Notes: svn path=/head/; revision=109909
Diffstat (limited to 'arabic')
-rw-r--r--arabic/katoob/Makefile2
-rw-r--r--arabic/katoob/files/patch-src-conf.c10
-rw-r--r--arabic/katoob/files/patch-src-search.c14
3 files changed, 25 insertions, 1 deletions
diff --git a/arabic/katoob/Makefile b/arabic/katoob/Makefile
index fd73696089d1..fe62785d6a57 100644
--- a/arabic/katoob/Makefile
+++ b/arabic/katoob/Makefile
@@ -7,7 +7,7 @@
PORTNAME= katoob
PORTVERSION= 0.3.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= arabic
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= arabeyes
diff --git a/arabic/katoob/files/patch-src-conf.c b/arabic/katoob/files/patch-src-conf.c
new file mode 100644
index 000000000000..26604b1e6965
--- /dev/null
+++ b/arabic/katoob/files/patch-src-conf.c
@@ -0,0 +1,10 @@
+--- src/conf.c Tue Aug 26 07:54:35 2003
++++ src/conf.c.patch Mon May 24 16:57:43 2004
+@@ -798,6 +798,7 @@
+ if (!fp)
+ {
+ g_warning ("Can't open the printing configuration file.");
++ return;
+ }
+
+ fprintf (fp, "font_family = %s\n", encode_font (PConf->font_family));
diff --git a/arabic/katoob/files/patch-src-search.c b/arabic/katoob/files/patch-src-search.c
new file mode 100644
index 000000000000..b9f3b63c7639
--- /dev/null
+++ b/arabic/katoob/files/patch-src-search.c
@@ -0,0 +1,14 @@
+--- src/search.c Tue Aug 26 07:54:37 2003
++++ src/search.c.patch Mon May 24 17:07:16 2004
+@@ -266,9 +266,8 @@
+ tmp = katoob_document_get_last_replaced (doc);
+ if ((tmp) && (replace))
+ {
+- gtk_entry_set_text (GTK_ENTRY (entry2), g_strdup (tmp));
+- g_free (tmp);
+- tmp = NULL;
++ gtk_entry_set_text (GTK_ENTRY (entry2), tmp);
++ tmp = NULL;
+ }
+ }
+