aboutsummaryrefslogtreecommitdiff
path: root/archivers/deutex
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2005-12-20 15:55:30 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2005-12-20 15:55:30 +0000
commitda6d7dd385808d23db46284f69657b8d62062387 (patch)
tree32ba4834e368c1989dba6a7c5979a5d3d816a183 /archivers/deutex
parentc458b72e33218bd9f01e571a27adcaa8364de78a (diff)
downloadports-da6d7dd385808d23db46284f69657b8d62062387.tar.gz
ports-da6d7dd385808d23db46284f69657b8d62062387.zip
Add deutex 4.4.0, an advanced WAD composer for games like Doom, Heretic,
Notes
Notes: svn path=/head/; revision=151656
Diffstat (limited to 'archivers/deutex')
-rw-r--r--archivers/deutex/Makefile38
-rw-r--r--archivers/deutex/distinfo3
-rw-r--r--archivers/deutex/pkg-descr11
3 files changed, 52 insertions, 0 deletions
diff --git a/archivers/deutex/Makefile b/archivers/deutex/Makefile
new file mode 100644
index 000000000000..10f0c6e7f452
--- /dev/null
+++ b/archivers/deutex/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: DeuTex
+# Date created: 20 Dec 2005
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= deutex
+PORTVERSION= 4.4.0
+CATEGORIES= archivers games
+MASTER_SITES= http://www.teaser.fr/~amajorel/deutex/ \
+ http://freebsd.nsu.ru/distfiles/
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= WAD file composer for Doom, Heretic, Hexen, and Strife
+
+USE_REINPLACE= yes
+
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
+
+PLIST_FILES= bin/deusf bin/deutex
+PORTDOCS= MANUAL TODO
+
+MAN6= ${PORTNAME}.6
+
+post-extract:
+ @${REINPLACE_CMD} -e 's,malloc\.h,stdlib\.h,' ${WRKSRC}/src/tools.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/deusf ${WRKSRC}/deutex ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN6} ${MANPREFIX}/man/man6
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/TODO ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/dtexman6.txt ${DOCSDIR}/MANUAL
+.endif
+
+.include <bsd.port.mk>
diff --git a/archivers/deutex/distinfo b/archivers/deutex/distinfo
new file mode 100644
index 000000000000..8bee8f59dbe4
--- /dev/null
+++ b/archivers/deutex/distinfo
@@ -0,0 +1,3 @@
+MD5 (deutex-4.4.0.tar.gz) = 4c4ea0ff9eae76165a3756b756d71a16
+SHA256 (deutex-4.4.0.tar.gz) = e87ff2984c6555f30408ee7aa4e6461aac6f1d3d0a1e21b4e12a797a057ba3b7
+SIZE (deutex-4.4.0.tar.gz) = 215945
diff --git a/archivers/deutex/pkg-descr b/archivers/deutex/pkg-descr
new file mode 100644
index 000000000000..447c0ba69544
--- /dev/null
+++ b/archivers/deutex/pkg-descr
@@ -0,0 +1,11 @@
+DeuTex is a WAD composer for Doom, Heretic, Hexen and Strife. It can be used
+to extract the lumps of a WAD and save them as individual files. Conversely,
+it can also build a WAD from separate files. When extracting a lump to a
+file, it does not just copy the raw data, it converts it to an appropriate
+format (such as PPM for graphics, Sun audio for samples, etc.). Conversely,
+when it reads files for inclusion in PWADs, it does the necessary
+conversions (for example, from PPM to Doom picture format). In addition,
+DeuTex has functions such as merging WADs, etc. If you're doing any WAD
+hacking beyond level editing, DeuTex is a must.
+
+WWW: http://www.teaser.fr/~amajorel/deutex/