aboutsummaryrefslogtreecommitdiff
path: root/archivers/epkg
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-26 16:19:08 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-26 16:19:08 +0000
commit05a8c388b5d6e8767ffaf43e89176b9919e8a775 (patch)
treecb9b5828f92b731e1baa7de6be2103c4652d486e /archivers/epkg
parent4aa4b34b01437a651aba0f7ea88525730b2b41f1 (diff)
downloadports-05a8c388b5d6e8767ffaf43e89176b9919e8a775.tar.gz
ports-05a8c388b5d6e8767ffaf43e89176b9919e8a775.zip
Support stage
Notes
Notes: svn path=/head/; revision=337546
Diffstat (limited to 'archivers/epkg')
-rw-r--r--archivers/epkg/Makefile57
-rw-r--r--archivers/epkg/pkg-plist41
2 files changed, 46 insertions, 52 deletions
diff --git a/archivers/epkg/Makefile b/archivers/epkg/Makefile
index 4a3e586ba2da..85db6a4ce464 100644
--- a/archivers/epkg/Makefile
+++ b/archivers/epkg/Makefile
@@ -14,63 +14,16 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libfget.a:${PORTSDIR}/ftp/fget
LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
libexpat.so:${PORTSDIR}/textproc/expat2
-NO_STAGE= yes
HAS_CONFIGURE= YES
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --disable-encap --disable-epkg-install --without-libtar \
--with-libfget \
--prefix=${PREFIX}
+INSTALL_TARGET= install-recurse
-MAN1= epkg.1 \
- mkencap.1
-MAN3= encap20_platform_name.3 \
- encap_check.3 \
- encap_check_prereqs.3 \
- encap_check_source.3 \
- encap_check_target.3 \
- encap_close.3 \
- encap_find_versions.3 \
- encap_hash_add.3 \
- encap_hash_del.3 \
- encap_hash_free.3 \
- encap_hash_getkey.3 \
- encap_hash_new.3 \
- encap_hash_next.3 \
- encap_hash_prev.3 \
- encap_hash_search.3 \
- encap_install.3 \
- encap_list_add.3 \
- encap_list_add_str.3 \
- encap_list_del.3 \
- encap_list_dup.3 \
- encap_list_free.3 \
- encap_list_merge.3 \
- encap_list_new.3 \
- encap_list_next.3 \
- encap_list_prev.3 \
- encap_list_search.3 \
- encap_open.3 \
- encap_pkgspec_join.3 \
- encap_pkgspec_parse.3 \
- encap_platform_compat.3 \
- encap_platform_name.3 \
- encap_platform_split.3 \
- encap_remove.3 \
- encap_vercmp.3 \
- encapinfo_free.3 \
- encapinfo_init.3 \
- encapinfo_parse_directive.3 \
- encapinfo_write.3
-MAN5= encap_profile.5
+post-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc
+ @${CP} ${WRKSRC}/mkencap/mkencap_environment ${STAGEDIR}${PREFIX}/etc/mkencap_environment.sample
-.include <bsd.port.pre.mk>
-
-do-install:
- @(cd ${BUILD_WRKSRC}; ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} install-recurse)
-
- -@${MKDIR} ${PREFIX}/etc
- @${CP} ${WRKSRC}/mkencap/mkencap_environment ${PREFIX}/etc/mkencap_environment.sample
- ${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/archivers/epkg/pkg-plist b/archivers/epkg/pkg-plist
index 2a86c938144c..fca31bbd3773 100644
--- a/archivers/epkg/pkg-plist
+++ b/archivers/epkg/pkg-plist
@@ -5,6 +5,47 @@ etc/mkencap_environment.sample
include/encap.h
include/encap_listhash.h
lib/libencap.a
+man/man1/epkg.1.gz
+man/man1/mkencap.1.gz
+man/man3/encap20_platform_name.3.gz
+man/man3/encap_check.3.gz
+man/man3/encap_check_prereqs.3.gz
+man/man3/encap_check_source.3.gz
+man/man3/encap_check_target.3.gz
+man/man3/encap_close.3.gz
+man/man3/encap_find_versions.3.gz
+man/man3/encap_hash_add.3.gz
+man/man3/encap_hash_del.3.gz
+man/man3/encap_hash_free.3.gz
+man/man3/encap_hash_getkey.3.gz
+man/man3/encap_hash_new.3.gz
+man/man3/encap_hash_next.3.gz
+man/man3/encap_hash_prev.3.gz
+man/man3/encap_hash_search.3.gz
+man/man3/encap_install.3.gz
+man/man3/encap_list_add.3.gz
+man/man3/encap_list_add_str.3.gz
+man/man3/encap_list_del.3.gz
+man/man3/encap_list_dup.3.gz
+man/man3/encap_list_free.3.gz
+man/man3/encap_list_merge.3.gz
+man/man3/encap_list_new.3.gz
+man/man3/encap_list_next.3.gz
+man/man3/encap_list_prev.3.gz
+man/man3/encap_list_search.3.gz
+man/man3/encap_open.3.gz
+man/man3/encap_pkgspec_join.3.gz
+man/man3/encap_pkgspec_parse.3.gz
+man/man3/encap_platform_compat.3.gz
+man/man3/encap_platform_name.3.gz
+man/man3/encap_platform_split.3.gz
+man/man3/encap_remove.3.gz
+man/man3/encap_vercmp.3.gz
+man/man3/encapinfo_free.3.gz
+man/man3/encapinfo_init.3.gz
+man/man3/encapinfo_parse_directive.3.gz
+man/man3/encapinfo_write.3.gz
+man/man5/encap_profile.5.gz
share/doc/encap/encap2.0-specification.txt
share/doc/encap/encap2.1-specification.txt
share/doc/encap/encap_profile.dtd