aboutsummaryrefslogtreecommitdiff
path: root/archivers/file-roller/Makefile
diff options
context:
space:
mode:
authorAlexander Logvinov <avl@FreeBSD.org>2009-07-01 07:26:13 +0000
committerAlexander Logvinov <avl@FreeBSD.org>2009-07-01 07:26:13 +0000
commitd3d0f1c05b02770f4faf0e8b2ee2d7f499c640ad (patch)
treed3c72d1c54cc9b4b7890cb9e5a97247ab3ea5218 /archivers/file-roller/Makefile
parent1bcedecd7ced5fd0df44072aae03787c9e6981c0 (diff)
downloadports-d3d0f1c05b02770f4faf0e8b2ee2d7f499c640ad.tar.gz
ports-d3d0f1c05b02770f4faf0e8b2ee2d7f499c640ad.zip
Update to 2.26.3.
Reviewed by: mezz (GNOME team) Approved by: tabthorpe (mentor)
Notes
Notes: svn path=/head/; revision=236843
Diffstat (limited to 'archivers/file-roller/Makefile')
-rw-r--r--archivers/file-roller/Makefile24
1 files changed, 17 insertions, 7 deletions
diff --git a/archivers/file-roller/Makefile b/archivers/file-roller/Makefile
index b9663d86d520..4ca6b12fcb38 100644
--- a/archivers/file-roller/Makefile
+++ b/archivers/file-roller/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= file-roller
-PORTVERSION= 2.26.2
+PORTVERSION= 2.26.3
PORTEPOCH= 1
CATEGORIES= archivers gnome
MASTER_SITES= GNOME
@@ -16,6 +16,8 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= An archive manager for zip files, tar, etc
+OPTIONS= NAUTILUS "Enable Nautilus extension" on
+
RUN_DEPENDS= ${LOCALBASE}/bin/gtar:${PORTSDIR}/archivers/gtar
USE_LDCONFIG= yes
@@ -24,27 +26,35 @@ USE_GETTEXT= yes
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix intlhack gnomehack desktopfileutils nautilus2 \
- gnomedocutils
+USE_GNOME= gnomeprefix intlhack gnomehack desktopfileutils gnomedocutils
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+PORTDOCS= AUTHORS NEWS README TODO ChangeLog
GCONF_SCHEMAS= file-roller.schemas
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_NAUTILUS)
+USE_GNOME+= nautilus2
+PLIST_SUB+= NAUTILUS=""
+.else
+PLIST_SUB+= NAUTILUS="@comment "
+CONFIGURE_ARGS+= --disable-nautilus-actions
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
${WRKSRC}/src/fr-command-tar.c
- @${FIND} ${WRKSRC} -name "fr-command-*.c" | ${XARGS} ${REINPLACE_CMD} \
- -e 's|atoll|fr_atoll|g'
post-install:
@-update-desktop-database
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
-.for f in AUTHORS NEWS README TODO
+.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>