aboutsummaryrefslogtreecommitdiff
path: root/archivers/libarchive
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2005-03-14 17:23:59 +0000
committerGreg Lewis <glewis@FreeBSD.org>2005-03-14 17:23:59 +0000
commiteb708cfdb760207b160605b68c80a96df0b21827 (patch)
tree3d59be3c666d17ee0a3e1ef9f2068f10b3231c42 /archivers/libarchive
parentc72247e05c969c6b59c4bb5f6cc39e2ca6b9dd63 (diff)
downloadports-eb708cfdb760207b160605b68c80a96df0b21827.tar.gz
ports-eb708cfdb760207b160605b68c80a96df0b21827.zip
. Update to 1.02.014.
Notes
Notes: svn path=/head/; revision=131219
Diffstat (limited to 'archivers/libarchive')
-rw-r--r--archivers/libarchive/Makefile2
-rw-r--r--archivers/libarchive/distinfo4
-rw-r--r--archivers/libarchive/files/patch-archive_read_extract.c19
3 files changed, 22 insertions, 3 deletions
diff --git a/archivers/libarchive/Makefile b/archivers/libarchive/Makefile
index 5a0fdd5c6a8f..af66df43c82b 100644
--- a/archivers/libarchive/Makefile
+++ b/archivers/libarchive/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= libarchive
-PORTVERSION= 1.02.010
+PORTVERSION= 1.02.014
PORTEPOCH= 1
CATEGORIES= archivers
MASTER_SITES= http://people.freebsd.org/~kientzle/libarchive/src/
diff --git a/archivers/libarchive/distinfo b/archivers/libarchive/distinfo
index 9e603ebf4d24..251d528be423 100644
--- a/archivers/libarchive/distinfo
+++ b/archivers/libarchive/distinfo
@@ -1,2 +1,2 @@
-MD5 (libarchive-1.02.010.tar.gz) = ae7877daf89dec8268c515f9846fa369
-SIZE (libarchive-1.02.010.tar.gz) = 197500
+MD5 (libarchive-1.02.014.tar.gz) = 4de0006f9a3a6a4e4ad54bf8e6e9c88b
+SIZE (libarchive-1.02.014.tar.gz) = 198411
diff --git a/archivers/libarchive/files/patch-archive_read_extract.c b/archivers/libarchive/files/patch-archive_read_extract.c
new file mode 100644
index 000000000000..1187e7c1ba4e
--- /dev/null
+++ b/archivers/libarchive/files/patch-archive_read_extract.c
@@ -0,0 +1,19 @@
+$FreeBSD$
+
+--- archive_read_extract.c.orig Mon Mar 14 10:12:52 2005
++++ archive_read_extract.c Mon Mar 14 10:13:03 2005
+@@ -188,12 +188,13 @@
+ * and move to a suitable intermediate dir.
+ */
+ if (strlen(archive_entry_pathname(entry)) > PATH_MAX) {
++ char *intdir, *tail;
++
+ /*
+ * Yes, the copy here is necessary because we edit
+ * the pathname in-place to create intermediate dirnames.
+ */
+ original_filename = strdup(archive_entry_pathname(entry));
+- char *intdir, *tail;
+
+ restore_pwd = open(".", O_RDONLY);
+ /*