aboutsummaryrefslogtreecommitdiff
path: root/archivers/lzma/Makefile
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2014-06-01 07:59:15 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2014-06-01 07:59:15 +0000
commit73969bbf7997cd2e8f7c0690cd27430068ffdc5d (patch)
tree4d307b471693ec4b275c79f06f7f888397796316 /archivers/lzma/Makefile
parent060db7b1f8a1baebf5e7d6b33843990a6fe38a41 (diff)
downloadports-73969bbf7997cd2e8f7c0690cd27430068ffdc5d.tar.gz
ports-73969bbf7997cd2e8f7c0690cd27430068ffdc5d.zip
- fix sanity in CAT archivers
- USE_BZIP2 -> USES=tar:bzip2 - LICENSE=BSD -> BSD[n]CLAUSE
Notes
Notes: svn path=/head/; revision=356058
Diffstat (limited to 'archivers/lzma/Makefile')
-rw-r--r--archivers/lzma/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/archivers/lzma/Makefile b/archivers/lzma/Makefile
index 4533d3ab9644..7dbc3c1a1db8 100644
--- a/archivers/lzma/Makefile
+++ b/archivers/lzma/Makefile
@@ -12,8 +12,7 @@ COMMENT= High-ratio LZMA compressor
CONFLICTS= lzmautils-[0-9]* xz-[0-9]*
-USES= gmake dos2unix
-USE_BZIP2= yes
+USES= tar:bzip2 gmake dos2unix
NO_WRKSUBDIR= yes
BUILD_WRKSRC= ${WRKSRC}/CPP/7zip/Bundles/LzmaCon
MAKEFILE= makefile.gcc
@@ -40,9 +39,9 @@ post-patch:
${BUILD_WRKSRC}/${MAKEFILE}
do-install:
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
- @${INSTALL} -d ${STAGEDIR}${DOCSDIR}/
- cd ${WRKSRC}/&&${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ @${INSTALL} -d ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/&&${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
regression-test: build
${BUILD_WRKSRC}/${PORTNAME} b