aboutsummaryrefslogtreecommitdiff
path: root/archivers/lzma
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-07 19:11:16 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-07 19:11:16 +0000
commit3a6cbec0cb652f861fd2c00099cd590d604e616e (patch)
treee5264c60b671fd1eaf95eb7d836b8606ee8cdef9 /archivers/lzma
parent6eb3b12cef5cdcdb622954f4d8854672cb5d914f (diff)
downloadports-3a6cbec0cb652f861fd2c00099cd590d604e616e.tar.gz
ports-3a6cbec0cb652f861fd2c00099cd590d604e616e.zip
Simple command line version of compression program using LZMA compression
method. This program is taken from LZMA SDK. 7-zip uses the same compression method, but creates 7Z archives instead of pure LZMA data stream. LZMA can compress and decompress data streams using standard input/output. Compression ratio is about 25-30% better than bzip2 and decompression speed is about two times faster. This makes LZMA good bzip2 replacement for use in software distribution. WWW: http://www.7-zip.org/sdk.html PR: ports/80554 Submitted by: Radim Kolar <hsn@netmag.cz>
Notes
Notes: svn path=/head/; revision=134792
Diffstat (limited to 'archivers/lzma')
-rw-r--r--archivers/lzma/Makefile45
-rw-r--r--archivers/lzma/distinfo2
-rw-r--r--archivers/lzma/pkg-descr10
3 files changed, 57 insertions, 0 deletions
diff --git a/archivers/lzma/Makefile b/archivers/lzma/Makefile
new file mode 100644
index 000000000000..c181551a773b
--- /dev/null
+++ b/archivers/lzma/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: lzma
+# Date created: 25 Apr 2005
+# Whom: Radim Kolar
+#
+# $FreeBSD$
+#
+
+PORTNAME= lzma
+PORTVERSION= 4.0.6
+CATEGORIES= archivers
+MASTER_SITES= http://www.7-zip.org/dl/
+DISTNAME= lzma${PORTVERSION:S/.//g}
+
+MAINTAINER= jylefort@FreeBSD.org
+COMMENT= Command line lzma archiver
+
+USE_GCC= 3.4+
+USE_ZIP= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+NO_WRKSUBDIR= yes
+
+BUILD_WRKSRC= ${WRKSRC}/SRC/7zip/Compress/LZMA_Alone
+MAKEFILE= makefile
+PLIST_FILES= bin/lzma
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *.txt
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|^CXX = .*||; \
+ s|^CFLAGS =|CFLAGS +=|' \
+ ${BUILD_WRKSRC}/${MAKEFILE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/lzma ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${RM} -f ${WRKSRC}/LGPL.txt
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/archivers/lzma/distinfo b/archivers/lzma/distinfo
new file mode 100644
index 000000000000..7ea0f1eb1338
--- /dev/null
+++ b/archivers/lzma/distinfo
@@ -0,0 +1,2 @@
+MD5 (lzma406.zip) = a09378411cba5f786b5c49c9c58496df
+SIZE (lzma406.zip) = 185934
diff --git a/archivers/lzma/pkg-descr b/archivers/lzma/pkg-descr
new file mode 100644
index 000000000000..6089e1945f7a
--- /dev/null
+++ b/archivers/lzma/pkg-descr
@@ -0,0 +1,10 @@
+Simple command line version of compression program using LZMA compression
+method. This program is taken from LZMA SDK. 7-zip uses the same compression
+method, but creates 7Z archives instead of pure LZMA data stream. LZMA can
+compress and decompress data streams using standard input/output.
+
+Compression ratio is about 25-30% better than bzip2 and decompression speed
+is about two times faster. This makes LZMA good bzip2 replacement for
+use in software distribution.
+
+WWW: http://www.7-zip.org/sdk.html