aboutsummaryrefslogtreecommitdiff
path: root/archivers/macutils
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1997-06-04 03:46:57 +0000
committerSatoshi Asami <asami@FreeBSD.org>1997-06-04 03:46:57 +0000
commite54351ade41a70183ce881e06c6bc0dc1b0f9e5c (patch)
tree6a751853a34e2b8f589d4b8999537c5eaa9fcaa0 /archivers/macutils
parentdd6ce5a3f3f6b22912f206cb796536c738789fa8 (diff)
downloadports-e54351ade41a70183ce881e06c6bc0dc1b0f9e5c.tar.gz
ports-e54351ade41a70183ce881e06c6bc0dc1b0f9e5c.zip
A set of utilities to play with Macintosh format files.
PR: 3626 Submitted by: Joel Sutton <sutton@aardvark.apana.org.au>
Notes
Notes: svn path=/head/; revision=6734
Diffstat (limited to 'archivers/macutils')
-rw-r--r--archivers/macutils/Makefile58
-rw-r--r--archivers/macutils/distinfo1
-rw-r--r--archivers/macutils/files/patch-aa31
-rw-r--r--archivers/macutils/pkg-comment1
-rw-r--r--archivers/macutils/pkg-descr21
-rw-r--r--archivers/macutils/pkg-plist25
6 files changed, 137 insertions, 0 deletions
diff --git a/archivers/macutils/Makefile b/archivers/macutils/Makefile
new file mode 100644
index 000000000000..db5677308ed9
--- /dev/null
+++ b/archivers/macutils/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: macutils
+# Version required: 2.0b3
+# Date created: 14th April 1997
+# Whom: Joel Sutton <sutton@aardvark.apana.org.au>
+# FreeBSD Version: 2.1.5-RELEASE
+#
+# $Id$
+#
+
+DISTNAME= macutils_2.0b3.orig
+PKGNAME= macutils-2.0b3
+CATEGORIES= emulators
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= distributions/debian/bo/source/otherosfs
+
+MAINTAINER= sutton@aardvark.apana.org.au
+
+WRKSRC= ${WRKDIR}/macutils-2.0b3.orig
+MAKEFILE= makefile
+
+MANDIR= ${PREFIX}/man/man
+BINDIR= ${PREFIX}/bin
+DOCDIR= ${PREFIX}/share/doc/macutils
+DOCFILES= README.crc README.hexbin README.macput README.unpit \
+ README.zoom README.crc.orig README.macget README.scan \
+ README.unsit ../README
+
+# The distribution has a naff install target which doesn't install man
+# pages so here is a decent one.
+#
+do-install:
+ @${ECHO_MSG} "===> Installing binaries..."
+ ${INSTALL_PROGRAM} ${WRKSRC}/macunpack/macunpack ${BINDIR}/
+ ${INSTALL_PROGRAM} ${WRKSRC}/hexbin/hexbin ${BINDIR}/
+ ${INSTALL_PROGRAM} ${WRKSRC}/mixed/macsave ${BINDIR}/
+ ${INSTALL_PROGRAM} ${WRKSRC}/mixed/macstream ${BINDIR}/
+ ${INSTALL_PROGRAM} ${WRKSRC}/binhex/binhex ${BINDIR}/
+ ${INSTALL_PROGRAM} ${WRKSRC}/comm/tomac ${BINDIR}/
+ ${INSTALL_PROGRAM} ${WRKSRC}/comm/frommac ${BINDIR}/
+ @${ECHO_MSG} "===> Installing man pages..."
+ ${INSTALL_MAN} ${WRKSRC}/man/macunpack.1 ${MANDIR}1/
+ ${INSTALL_MAN} ${WRKSRC}/man/hexbin.1 ${MANDIR}1/
+ ${INSTALL_MAN} ${WRKSRC}/man/macsave.1 ${MANDIR}1/
+ ${INSTALL_MAN} ${WRKSRC}/man/macstream.1 ${MANDIR}1/
+ ${INSTALL_MAN} ${WRKSRC}/man/binhex.1 ${MANDIR}1/
+ ${INSTALL_MAN} ${WRKSRC}/man/tomac.1 ${MANDIR}1/
+ ${INSTALL_MAN} ${WRKSRC}/man/frommac.1 ${MANDIR}1/
+ ${INSTALL_MAN} ${WRKSRC}/man/macutil.1 ${MANDIR}1/
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing supplementary documents..."
+ -${MKDIR} ${DOCDIR}/
+ for file in ${DOCFILES} ; do \
+ ${INSTALL_DATA} ${WRKSRC}/doc/$$file ${DOCDIR}/ ;\
+ done
+.endif
+
+.include <bsd.port.mk>
+
diff --git a/archivers/macutils/distinfo b/archivers/macutils/distinfo
new file mode 100644
index 000000000000..50953b34fdf6
--- /dev/null
+++ b/archivers/macutils/distinfo
@@ -0,0 +1 @@
+MD5 (macutils_2.0b3.orig.tar.gz) = ee12e1c8d40567766d0733aa31f6f4bc
diff --git a/archivers/macutils/files/patch-aa b/archivers/macutils/files/patch-aa
new file mode 100644
index 000000000000..01b90af47cac
--- /dev/null
+++ b/archivers/macutils/files/patch-aa
@@ -0,0 +1,31 @@
+*** makefile.orig Mon Apr 14 16:15:21 1997
+--- makefile Mon Apr 14 16:34:14 1997
+***************
+*** 1,5 ****
+! SHELL = /bin/sh
+! BINDIR = /ufs/dik/tmpbin
+ # Use the following flags on the CF macro definition as needed.
+ #
+ # -DBSD if you are on a BSD system
+--- 1,4 ----
+! SHELL = /bin/sh
+ # Use the following flags on the CF macro definition as needed.
+ #
+ # -DBSD if you are on a BSD system
+***************
+*** 24,30 ****
+ #
+ # -DAPPLEDOUBLE if you want to be able to use an AppleDouble file system
+ #
+! CF = -DBSD -DTYPES_H -DDIRENT_H -DTERMIOS_H -DNODOT -DAPPLEDOUBLE
+
+ all:
+ (cd crc; make CF='$(CF)')
+--- 23,29 ----
+ #
+ # -DAPPLEDOUBLE if you want to be able to use an AppleDouble file system
+ #
+! CF = -DBSD -DTYPES_H -DDIRENT_H -DTERMIOS_H -DAUFSPLUS
+
+ all:
+ (cd crc; make CF='$(CF)')
diff --git a/archivers/macutils/pkg-comment b/archivers/macutils/pkg-comment
new file mode 100644
index 000000000000..b14052b20f9f
--- /dev/null
+++ b/archivers/macutils/pkg-comment
@@ -0,0 +1 @@
+Utilities for Apple Macintosh files.
diff --git a/archivers/macutils/pkg-descr b/archivers/macutils/pkg-descr
new file mode 100644
index 000000000000..9af6c3b29e05
--- /dev/null
+++ b/archivers/macutils/pkg-descr
@@ -0,0 +1,21 @@
+The macutils collection can handle a number of different Macintosh
+file formats including Binhex, MacBinary, AppleSingle and
+AppleDouble. There is also support for the Columbia Apple-talk
+Package.
+
+This package contains the following utilities:
+ macunpack
+ hexbin
+ macsave
+ macstream
+ binhex
+ tomac
+ frommac
+
+Check out the man pages and /usr/local/share/doc/macutils (or
+equivalent on your system) for more information.
+
+Share and enjoy,
+
+Joel...
+sutton@aardvark.apana.org.au
diff --git a/archivers/macutils/pkg-plist b/archivers/macutils/pkg-plist
new file mode 100644
index 000000000000..d2c9620ab8c5
--- /dev/null
+++ b/archivers/macutils/pkg-plist
@@ -0,0 +1,25 @@
+bin/macunpack
+bin/hexbin
+bin/macsave
+bin/macstream
+bin/binhex
+bin/tomac
+bin/frommac
+man/man1/macunpack.1
+man/man1/hexbin.1
+man/man1/macsave.1
+man/man1/macstream.1
+man/man1/binhex.1
+man/man1/tomac.1
+man/man1/frommac.1
+man/man1/macutil.1
+share/doc/macutils/README
+share/doc/macutils/README.crc
+share/doc/macutils/README.crc.orig
+share/doc/macutils/README.hexbin
+share/doc/macutils/README.macget
+share/doc/macutils/README.macput
+share/doc/macutils/README.scan
+share/doc/macutils/README.unpit
+share/doc/macutils/README.unsit
+share/doc/macutils/README.zoom