aboutsummaryrefslogtreecommitdiff
path: root/archivers/p5-IO-Zlib
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2005-02-13 03:37:26 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2005-02-13 03:37:26 +0000
commit1e04edb8d9da56b4d428d2d40b151b37ea043c60 (patch)
tree8905622bbcca60a5c8c42600a67225503d9b6837 /archivers/p5-IO-Zlib
parentece7c26384c976c121cf9ec1154e75efec949237 (diff)
downloadports-1e04edb8d9da56b4d428d2d40b151b37ea043c60.tar.gz
ports-1e04edb8d9da56b4d428d2d40b151b37ea043c60.zip
Add a patch to work around on 4-stable (perl-5.00503's Fcntl.pm does
not export SEEK_SET symbol). Doing "make test" on 4-stable will fail because perl-5.005 does not support EOF method in TIE HANDLE. Submitted by: lth
Notes
Notes: svn path=/head/; revision=128666
Diffstat (limited to 'archivers/p5-IO-Zlib')
-rw-r--r--archivers/p5-IO-Zlib/Makefile1
-rw-r--r--archivers/p5-IO-Zlib/files/patch-Zlib.pm11
2 files changed, 12 insertions, 0 deletions
diff --git a/archivers/p5-IO-Zlib/Makefile b/archivers/p5-IO-Zlib/Makefile
index 5c0bdf2d497b..9e5e7cf377c6 100644
--- a/archivers/p5-IO-Zlib/Makefile
+++ b/archivers/p5-IO-Zlib/Makefile
@@ -7,6 +7,7 @@
PORTNAME= IO-Zlib
PORTVERSION= 1.04
+PORTREVISION= 1
CATEGORIES= archivers perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= ../../authors/id/T/TO/TOMHUGHES
diff --git a/archivers/p5-IO-Zlib/files/patch-Zlib.pm b/archivers/p5-IO-Zlib/files/patch-Zlib.pm
new file mode 100644
index 000000000000..0fa9323ccb77
--- /dev/null
+++ b/archivers/p5-IO-Zlib/files/patch-Zlib.pm
@@ -0,0 +1,11 @@
+--- Zlib.pm.orig Sun Feb 13 00:43:08 2005
++++ Zlib.pm Sun Feb 13 00:43:30 2005
+@@ -297,7 +297,7 @@
+ use vars qw($VERSION $AUTOLOAD @ISA);
+
+ use Carp;
+-use Fcntl qw(SEEK_SET);
++use constant SEEK_SET => 0;
+
+ my $has_Compress_Zlib;
+ my $aliased;