aboutsummaryrefslogtreecommitdiff
path: root/archivers/p7zip
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-08-11 18:07:36 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-08-11 18:07:36 +0000
commita0b4fb6047723252c01516580db8250d3b970dab (patch)
tree111174caff12dad7152835ec18a3e9b296b8e67e /archivers/p7zip
parent830d958b882af4e502ccca38977c6bab01ff3ff7 (diff)
downloadports-a0b4fb6047723252c01516580db8250d3b970dab.tar.gz
ports-a0b4fb6047723252c01516580db8250d3b970dab.zip
file archiver with highest compression ratio
PR: ports/69248 Submitted by: Juergen Lock <nox@jelal.kn-bremen.de>
Notes
Notes: svn path=/head/; revision=115949
Diffstat (limited to 'archivers/p7zip')
-rw-r--r--archivers/p7zip/Makefile44
-rw-r--r--archivers/p7zip/distinfo2
-rw-r--r--archivers/p7zip/files/7z4
-rw-r--r--archivers/p7zip/files/patch-aa12
-rw-r--r--archivers/p7zip/files/patch-ab18
-rw-r--r--archivers/p7zip/files/patch-ac20
-rw-r--r--archivers/p7zip/files/patch-ba19
-rw-r--r--archivers/p7zip/pkg-descr14
-rw-r--r--archivers/p7zip/pkg-plist54
9 files changed, 187 insertions, 0 deletions
diff --git a/archivers/p7zip/Makefile b/archivers/p7zip/Makefile
new file mode 100644
index 000000000000..3a92e3e0afa2
--- /dev/null
+++ b/archivers/p7zip/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: p7zip
+# Date created: Sun Jul 18 15:07:26 CEST 2004
+# Whom: Juergen Lock <nox@jelal.kn-bremen.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= p7zip
+PORTVERSION= 0.90
+CATEGORIES= archivers
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= p7zip
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= nox@jelal.kn-bremen.de
+COMMENT= Command line versions of 7-zip
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+MAKEFILE= makefile
+MAKE_ARGS+= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} PTHREAD_LIBS=${PTHREAD_LIBS}
+ONLY_FOR_ARCHS= alpha amd64 i386 ia64
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500039
+BROKEN= Requires wchar functions (mbrtowc(3) etc.) for compilation
+.endif
+
+do-install:
+ ${MKDIR} ${PREFIX}/libexec/p7zip/Codecs
+ ${MKDIR} ${PREFIX}/libexec/p7zip/Formats
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/7z ${PREFIX}/libexec/p7zip
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/7za ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/bin/Codecs/* ${PREFIX}/libexec/p7zip/Codecs
+ ${INSTALL_DATA} ${WRKSRC}/bin/Formats/* ${PREFIX}/libexec/p7zip/Formats
+ ${INSTALL_SCRIPT} ${FILESDIR}/7z ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/doc/p7zip/commands
+ ${MKDIR} ${PREFIX}/share/doc/p7zip/switches
+ ${INSTALL_DATA} ${WRKSRC}/html/cmdline/*.htm ${PREFIX}/share/doc/p7zip
+ ${INSTALL_DATA} ${WRKSRC}/html/cmdline/commands/* ${PREFIX}/share/doc/p7zip/commands
+ ${INSTALL_DATA} ${WRKSRC}/html/cmdline/switches/* ${PREFIX}/share/doc/p7zip/switches
+
+.include <bsd.port.post.mk>
diff --git a/archivers/p7zip/distinfo b/archivers/p7zip/distinfo
new file mode 100644
index 000000000000..2ce404796344
--- /dev/null
+++ b/archivers/p7zip/distinfo
@@ -0,0 +1,2 @@
+MD5 (p7zip_0.90.tar.bz2) = 6600fd9711b5cebd52aac2ce4d9ba727
+SIZE (p7zip_0.90.tar.bz2) = 447371
diff --git a/archivers/p7zip/files/7z b/archivers/p7zip/files/7z
new file mode 100644
index 000000000000..2007b3339f54
--- /dev/null
+++ b/archivers/p7zip/files/7z
@@ -0,0 +1,4 @@
+#! /bin/sh
+PROG=$(dirname $(realpath $0))/../libexec/p7zip/7z
+
+$PROG "$@"
diff --git a/archivers/p7zip/files/patch-aa b/archivers/p7zip/files/patch-aa
new file mode 100644
index 000000000000..4f1cae45c679
--- /dev/null
+++ b/archivers/p7zip/files/patch-aa
@@ -0,0 +1,12 @@
+Index: myWindows/makefile
+@@ -1,8 +1,8 @@
+ PROG=all.so
+
+-LOCAL_FLAGS=-I. -I.. -I../include_windows
++LOCAL_FLAGS=-I. -I.. -I../include_windows ${PTHREAD_CFLAGS}
+
+-LOCAL_SHARED=-lpthread -lm
++LOCAL_SHARED=${PTHREAD_LIBS}
+
+ OBJS=myEvents.o myFiles.o myFindFile.o myDirectoryAndPath.o \
+ myLastError.o myModuleFileName.o my_itow.o \
diff --git a/archivers/p7zip/files/patch-ab b/archivers/p7zip/files/patch-ab
new file mode 100644
index 000000000000..e0453f5acc10
--- /dev/null
+++ b/archivers/p7zip/files/patch-ab
@@ -0,0 +1,18 @@
+Index: 7zip/UI/Console/makefile
+@@ -1,6 +1,6 @@
+ PROG=../../../bin/7z
+
+-LOCAL_FLAGS=
++LOCAL_FLAGS=${PTHREAD_CFLAGS}
+
+ OPERATING_SYSTEM=$(shell uname -o)
+
+@@ -8,7 +8,7 @@
+ # Cygwin does not support -ldl
+ LOCAL_LIBS=-lpthread
+ else
+-LOCAL_LIBS=-lpthread -ldl -lm
++LOCAL_LIBS=${PTHREAD_LIBS}
+ endif
+
+ MY_WINDOWS=$(MY_HOME)/myDirectoryAndPath.o \
diff --git a/archivers/p7zip/files/patch-ac b/archivers/p7zip/files/patch-ac
new file mode 100644
index 000000000000..c05d94603c29
--- /dev/null
+++ b/archivers/p7zip/files/patch-ac
@@ -0,0 +1,20 @@
+Index: 7zip/Bundles/Alone/makefile
+@@ -6,7 +6,8 @@
+ -DFORMAT_GZIP -DCOMPRESS_LZMA -DCOMPRESS_BCJ_X86 -DCOMPRESS_BCJ2 \
+ -DCOMPRESS_COPY -DCOMPRESS_MF_PAT -DCOMPRESS_MF_BT -DCOMPRESS_MF_HC \
+ -DCOMPRESS_MF_MT -DCOMPRESS_PPMD -DCOMPRESS_DEFLATE -DCOMPRESS_DEFLATE64 \
+--DCOMPRESS_IMPLODE -DCOMPRESS_BZIP2 -DCRYPTO_ZIP -DCRYPTO_7ZAES -DCRYPTO_AES
++-DCOMPRESS_IMPLODE -DCOMPRESS_BZIP2 -DCRYPTO_ZIP -DCRYPTO_7ZAES -DCRYPTO_AES \
++${PTHREAD_CFLAGS}
+
+ MY_WINDOWS=$(MY_HOME)/myEvents.o \
+ $(MY_HOME)/myFiles.o \
+@@ -21,7 +22,7 @@
+ $(MY_HOME)/wine_strings.o \
+ $(MY_HOME)/stuff_for_cygwin.o
+
+-LOCAL_SHARED=-lpthread -lm
++LOCAL_SHARED=${PTHREAD_LIBS}
+
+
+ OBJS=\
diff --git a/archivers/p7zip/files/patch-ba b/archivers/p7zip/files/patch-ba
new file mode 100644
index 000000000000..744f4115f861
--- /dev/null
+++ b/archivers/p7zip/files/patch-ba
@@ -0,0 +1,19 @@
+Index: Windows/Time.h
+@@ -41,7 +41,7 @@
+ fileTime.dwHighDateTime = DWORD(ll >> 32);
+ }
+
+-inline bool FileTimeToUnixTime(const FILETIME &fileTime, long &unixTime)
++inline bool FileTimeToUnixTime(const FILETIME &fileTime, time_t &unixTime)
+ {
+ UINT64 winTime = (((UINT64)fileTime.dwHighDateTime) << 32) + fileTime.dwLowDateTime;
+ if (winTime < kUnixTimeStartValue)
+@@ -49,7 +49,7 @@
+ winTime = (winTime - kUnixTimeStartValue) / kNumTimeQuantumsInSecond;
+ if (winTime >= 0xFFFFFFFF)
+ return false;
+- unixTime = (long)winTime;
++ unixTime = (time_t)winTime;
+ return true;
+ }
+
diff --git a/archivers/p7zip/pkg-descr b/archivers/p7zip/pkg-descr
new file mode 100644
index 000000000000..b25bb3ee98ee
--- /dev/null
+++ b/archivers/p7zip/pkg-descr
@@ -0,0 +1,14 @@
+p7zip is a port of 7z.exe and 7za.exe for Unix.
+
+7z and 7za are command line version of 7-zip, see http://www.7-zip.org/.
+
+7-Zip is a file archiver with highest compression ratio.
+
+Currently, p7zip (like 7-zip) supports only little-endian machine.
+
+7z uses shared libraries and supports more archive formats, otherwise
+7z and 7za work the same. They didn't come with a manpage, html
+commandline documentation will be installed in %%PREFIX%%/share/doc/p7zip/
+
+
+WWW: http://p7zip.sourceforge.net/
diff --git a/archivers/p7zip/pkg-plist b/archivers/p7zip/pkg-plist
new file mode 100644
index 000000000000..cda947a89174
--- /dev/null
+++ b/archivers/p7zip/pkg-plist
@@ -0,0 +1,54 @@
+bin/7z
+bin/7za
+libexec/p7zip/7z
+libexec/p7zip/Codecs/7zAES.dll
+libexec/p7zip/Codecs/BZip2.dll
+libexec/p7zip/Codecs/Copy.dll
+libexec/p7zip/Codecs/Implode.dll
+libexec/p7zip/Codecs/PPMD.dll
+libexec/p7zip/Codecs/AES.dll
+libexec/p7zip/Codecs/Branch.dll
+libexec/p7zip/Codecs/Deflate.dll
+libexec/p7zip/Codecs/LZMA.dll
+libexec/p7zip/Codecs/Swap.dll
+libexec/p7zip/Formats/7z.dll
+libexec/p7zip/Formats/Rar.dll
+libexec/p7zip/Formats/Tar.dll
+libexec/p7zip/Formats/Zip.dll
+libexec/p7zip/Formats/arj.dll
+libexec/p7zip/Formats/bz2.dll
+libexec/p7zip/Formats/cab.dll
+libexec/p7zip/Formats/cpio.dll
+libexec/p7zip/Formats/deb.dll
+libexec/p7zip/Formats/gz.dll
+libexec/p7zip/Formats/rpm.dll
+libexec/p7zip/Formats/split.dll
+%%PORTDOCS%%%%DOCSDIR%%/index.htm
+%%PORTDOCS%%%%DOCSDIR%%/syntax.htm
+%%PORTDOCS%%%%DOCSDIR%%/commands/add.htm
+%%PORTDOCS%%%%DOCSDIR%%/commands/delete.htm
+%%PORTDOCS%%%%DOCSDIR%%/commands/extract.htm
+%%PORTDOCS%%%%DOCSDIR%%/commands/extract_full.htm
+%%PORTDOCS%%%%DOCSDIR%%/commands/index.htm
+%%PORTDOCS%%%%DOCSDIR%%/commands/list.htm
+%%PORTDOCS%%%%DOCSDIR%%/commands/test.htm
+%%PORTDOCS%%%%DOCSDIR%%/commands/update.htm
+%%PORTDOCS%%%%DOCSDIR%%/switches/exclude.htm
+%%PORTDOCS%%%%DOCSDIR%%/switches/include.htm
+%%PORTDOCS%%%%DOCSDIR%%/switches/index.htm
+%%PORTDOCS%%%%DOCSDIR%%/switches/method.htm
+%%PORTDOCS%%%%DOCSDIR%%/switches/output_dir.htm
+%%PORTDOCS%%%%DOCSDIR%%/switches/overwrite.htm
+%%PORTDOCS%%%%DOCSDIR%%/switches/password.htm
+%%PORTDOCS%%%%DOCSDIR%%/switches/recurse.htm
+%%PORTDOCS%%%%DOCSDIR%%/switches/sfx.htm
+%%PORTDOCS%%%%DOCSDIR%%/switches/type.htm
+%%PORTDOCS%%%%DOCSDIR%%/switches/update.htm
+%%PORTDOCS%%%%DOCSDIR%%/switches/working_dir.htm
+%%PORTDOCS%%%%DOCSDIR%%/switches/yes.htm
+@dirrm libexec/p7zip/Formats
+@dirrm libexec/p7zip/Codecs
+@dirrm libexec/p7zip
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/commands
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/switches
+%%PORTDOCS%%@dirrm %%DOCSDIR%%