aboutsummaryrefslogtreecommitdiff
path: root/archivers/rpm
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2005-11-15 06:52:12 +0000
committerAde Lovett <ade@FreeBSD.org>2005-11-15 06:52:12 +0000
commit54a0b86543e9ffa811825f0afecea56e89aac2a5 (patch)
treef56fb969c6a70f5e63287a4f791d035ab1ef0ddc /archivers/rpm
parent1fccb46f1497a538f24ec00f14b7826570bc0a3a (diff)
downloadports-54a0b86543e9ffa811825f0afecea56e89aac2a5.tar.gz
ports-54a0b86543e9ffa811825f0afecea56e89aac2a5.zip
Mass-conversion to the USE_AUTOTOOLS New World Order. The code present
in bsd.autotools.mk essentially makes this a no-op given that all the old variables set a USE_AUTOTOOLS_COMPAT variable, which is parsed in exactly the same way as USE_AUTOTOOLS itself. Moreover, USE_AUTOTOOLS has already been extensively tested by the GNOME team -- all GNOME 2.12.x ports use it. Preliminary documentation can be found at: http://people.FreeBSD.org/~ade/autotools.txt which is in the process of being SGMLized before introduction into the Porters Handbook. Light blue touch-paper. Run.
Notes
Notes: svn path=/head/; revision=148323
Diffstat (limited to 'archivers/rpm')
-rw-r--r--archivers/rpm/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/archivers/rpm/Makefile b/archivers/rpm/Makefile
index 588127042b2f..1ff7f17f06e1 100644
--- a/archivers/rpm/Makefile
+++ b/archivers/rpm/Makefile
@@ -20,10 +20,8 @@ CONFLICTS= rpm-4.*
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_AUTOMAKE_VER=14
-USE_AUTOCONF_VER=213
+USE_AUTOTOOLS= automake:14 autoconf:213 libtool:13:inc
USE_REINPLACE= yes
-USE_INC_LIBTOOL_VER= 13
CONFIGURE_ARGS= --with-glob
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl -liconv"