aboutsummaryrefslogtreecommitdiff
path: root/archivers/ruby-bz2/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-12-06 17:17:38 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-12-06 17:17:38 +0000
commit185ceb675cf8b26e316a037b83225c000ff26f23 (patch)
tree529039d77da5b882444fb862a40d4fea197d5466 /archivers/ruby-bz2/Makefile
parent06b18b4580a6e989c99e4e95831869330142325e (diff)
downloadports-185ceb675cf8b26e316a037b83225c000ff26f23.tar.gz
ports-185ceb675cf8b26e316a037b83225c000ff26f23.zip
Introduce a knob RUBY_NO_RD_HTML and enable it by default on alpha. This
replaces the non-working NOPORTDOCS workaround and fixes build on the alpha, where rd2 coredumps. Tested on: the axp cluster Approved by: kris
Notes
Notes: svn path=/head/; revision=71402
Diffstat (limited to 'archivers/ruby-bz2/Makefile')
-rw-r--r--archivers/ruby-bz2/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/archivers/ruby-bz2/Makefile b/archivers/ruby-bz2/Makefile
index 90ef8fafc830..b943d4aa0bd7 100644
--- a/archivers/ruby-bz2/Makefile
+++ b/archivers/ruby-bz2/Makefile
@@ -17,25 +17,30 @@ MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
USE_RUBY_RDOC= yes
-USE_RUBY_RDTOOL= yes
INSTALL_TARGET= site-install
-DOCS= Changes README.en bz2.html bz2.rd \
+RUBY_RD_FILES= bz2.rd
+
+DOCS= Changes \
+ README.en \
+ ${RUBY_RD_FILES} \
+ ${RUBY_RD_HTML_FILES} \
docs/doc
post-build:
.if !defined(NOPORTDOCS)
- cd ${WRKSRC}; ${RUBY_RD2} bz2.rd > bz2.html
- cd ${WRKSRC}/docs; ${RUBY} b.rb bz2; rdoc bz2.rb
+ cd ${WRKSRC}/docs; ${RUBY} b.rb bz2; ${RUBY_RDOC} bz2.rb
.endif
-post-install:
+post-install: doc-install
+
+.include <bsd.port.mk>
+
+doc-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODDOCDIR}
.for f in ${DOCS}
${CP} -R ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
.endfor
.endif
-
-.include <bsd.port.mk>