aboutsummaryrefslogtreecommitdiff
path: root/archivers/squsq
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-07-14 12:17:12 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-07-14 12:17:12 +0000
commitf5c217d2244ad9951e0cb879eb93e1bb01a6760b (patch)
treeca210487c1689ca69d3755d2f68f452262f8da09 /archivers/squsq
parent8b469c256b5922808a5ece3cbaf2829ffe59a185 (diff)
downloadports-f5c217d2244ad9951e0cb879eb93e1bb01a6760b.tar.gz
ports-f5c217d2244ad9951e0cb879eb93e1bb01a6760b.zip
- Add port lang/squirrel
- Register conflicts with archivers/squsq Squirrel is a high level imperative/OO programming language, designed to be a powerful scripting tool that fits in the size, memory bandwidth, and real-time requirements of applications like games. However Squirrel offers a wide range of features like dynamic typing, delegation, classes & inheritance, higher order functions, generators, coroutines, tail recursion, exception handling, automatic memory management, weak references, etc. Squirrel is inspired by languages like Python, Javascript and especially Lua. The API is very similar and the table code is based on the Lua one. WWW: http://squirrel-lang.org/ Author: Alberto Demichelis <alberto@ademichelis.com>
Notes
Notes: svn path=/head/; revision=195571
Diffstat (limited to 'archivers/squsq')
-rw-r--r--archivers/squsq/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/archivers/squsq/Makefile b/archivers/squsq/Makefile
index 686f2ae8ffa2..1c2eae995411 100644
--- a/archivers/squsq/Makefile
+++ b/archivers/squsq/Makefile
@@ -8,19 +8,19 @@
PORTNAME= squsq
PORTVERSION= 3.3
CATEGORIES= archivers
-MASTER_SITES= ${MASTER_SITE_NETBSD} \
- http://freebsd.nsu.ru/distfiles/
+MASTER_SITES= NETBSD http://freebsd.nsu.ru/distfiles/
DISTNAME= t20-squsq-3.3
MAINTAINER= ports@FreeBSD.org
COMMENT= Compressor/decompressor for CP/M "Squeeze" compressed files
+CONFLICTS= squirrel-[0-9]*
WRKSRC= ${WRKDIR}/t20-squsq
MAKEFILE= ${FILESDIR}/Makefile
PLIST_FILES= bin/sq bin/usq
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/sq ${WRKSRC}/usq ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/sq ${WRKSRC}/usq ${PREFIX}/bin/
.include <bsd.port.mk>