aboutsummaryrefslogtreecommitdiff
path: root/archivers/star
diff options
context:
space:
mode:
authorcvs2svn <cvs2svn@FreeBSD.org>2002-08-10 04:35:28 +0000
committercvs2svn <cvs2svn@FreeBSD.org>2002-08-10 04:35:28 +0000
commitf124555536ce4b815ff160312c094545c36ec440 (patch)
tree702199d3b5e34c9ba151483313d8c26565451c75 /archivers/star
parent280725774faa4e3d91ff599cca3a1466c77d300e (diff)
downloadports-f124555536ce4b815ff160312c094545c36ec440.tar.gz
ports-f124555536ce4b815ff160312c094545c36ec440.zip
This commit was manufactured by cvs2svn to create tag 'RELEASE_4_6_2'.release/4.6.2
Notes
Notes: svn path=/head/; revision=64310 svn path=/tags/RELEASE_4_6_2/; revision=64312; tag=release/4.6.2
Diffstat (limited to 'archivers/star')
-rw-r--r--archivers/star/Makefile36
-rw-r--r--archivers/star/distinfo1
-rw-r--r--archivers/star/files/patch-aa39
-rw-r--r--archivers/star/files/patch-ab262
-rw-r--r--archivers/star/files/patch-ad22
-rw-r--r--archivers/star/pkg-comment1
-rw-r--r--archivers/star/pkg-descr20
-rw-r--r--archivers/star/pkg-plist3
8 files changed, 0 insertions, 384 deletions
diff --git a/archivers/star/Makefile b/archivers/star/Makefile
deleted file mode 100644
index dfbada203134..000000000000
--- a/archivers/star/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-# ex:ts=8
-# New ports collection makefile for: star
-# Date created: Thu May 1 20:28:44 CEST 1997
-# Whom: Andreas Klemm <andreas@klemm.gtn.com>
-#
-# $FreeBSD$
-#
-
-PORTNAME= star
-PORTVERSION= 1.3
-CATEGORIES= sysutils archivers
-MASTER_SITES= ftp://ftp.fokus.gmd.de/pub/unix/star/ \
- ${MASTER_SITE_SUNSITE}
-MASTER_SITE_SUBDIR= utils/compress
-
-MAINTAINER= obrien@FreeBSD.org
-
-USE_GMAKE= yes
-MAKE_ENV= MAKEPROG=gmake CCOM=${CC}
-MAN1= star.1
-MLINKS= star.1 ustar.1
-
-.if ${MACHINE_ARCH} != "i386" || ${CC} != "cc"
-post-extract:
- @${LN} -sf i386-freebsd-cc.rul \
- ${WRKSRC}/RULES/${MACHINE_ARCH}-freebsd-${CC}.rul
-.endif
-
-do-install:
- ${INSTALL_PROGRAM} \
- ${WRKSRC}/star/OBJ/${MACHINE_ARCH}-freebsd-${CC}/star \
- ${PREFIX}/bin
- cd ${PREFIX}/bin ; ${LN} -f star ustar
- ${INSTALL_MAN} ${WRKSRC}/star/star.1 ${PREFIX}/man/man1
-
-.include <bsd.port.mk>
diff --git a/archivers/star/distinfo b/archivers/star/distinfo
deleted file mode 100644
index e5640ae788c4..000000000000
--- a/archivers/star/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (star-1.3.tar.gz) = 692625a76ba5e52bd62312ebb6eff7ac
diff --git a/archivers/star/files/patch-aa b/archivers/star/files/patch-aa
deleted file mode 100644
index 4d8f6edd9207..000000000000
--- a/archivers/star/files/patch-aa
+++ /dev/null
@@ -1,39 +0,0 @@
---- RULES/i386-freebsd-cc.rul.orig Thu May 6 02:48:51 1999
-+++ RULES/i386-freebsd-cc.rul Thu May 6 02:50:11 1999
-@@ -24,7 +24,7 @@
- ###########################################################################
-
- CPPFLAGS= $(CPPOPTS) $(CPPOPTX)
--CFLAGS= $(COPTS) $(CWARNOPTS) $(COPTOPT) $(COPTX)
-+CFLAGS+= -static $(COPTS) $(CWARNOPTS) $(COPTX)
-
- CPPOPTS= -I. -I$(ARCHDIR) -I$(OINCSDIR) $(INCDIRS:%=-I%) $(OSDEFS)
- COPTS=
-@@ -47,7 +47,7 @@
-
- LIBS_PATH= -L$(OLIBSDIR)
-
--LDFLAGS= $(LDOPTS) $(LDOPTX)
-+LDFLAGS+= -static $(LDOPTS) $(LDOPTX)
- LDLIBS= $(LIBS) $(LIBX)
-
- #LDOPTS= $(LIBS_PATH) $(LDPATH) $(RUNPATH)
-@@ -57,14 +57,14 @@
-
- FLOAT_OPTIONS=
-
--CC= @echo " ==> COMPILING \"$@\""; gcc
--LDCC= @echo " ==> LINKING \"$@\""; gcc
--DYNLD= @echo " ==> LINKING dynamic library \"$@\""; gcc
-+CC= @echo " ==> COMPILING \"$@\""; ${CCOM}
-+LDCC= @echo " ==> LINKING \"$@\""; ${CCOM}
-+DYNLD= @echo " ==> LINKING dynamic library \"$@\""; ${CCOM}
- RANLIB= @echo " ==> RANDOMIZING ARCHIVE \"$@\""; ranlib
- ARFLAGS= cr
- LORDER= lorder
- TSORT= tsort
-
- RMDEP= :
--MKDEP= @echo " ==> MAKE DEPENDENCIES \"$@\""; $(RMDEP); gcc -M
-+MKDEP= @echo " ==> MAKE DEPENDENCIES \"$@\""; $(RMDEP); ${CCOM} -M
- MKDEP_OUT=
diff --git a/archivers/star/files/patch-ab b/archivers/star/files/patch-ab
deleted file mode 100644
index 0cdbbab9ece4..000000000000
--- a/archivers/star/files/patch-ab
+++ /dev/null
@@ -1,262 +0,0 @@
---- star/star.c.orig Fri Apr 27 19:29:55 2001
-+++ star/star.c Fri Apr 27 19:33:54 2001
-@@ -442,46 +442,48 @@ LOCAL void
- usage(ret)
- int ret;
- {
-- error("Usage:\tstar cmd [options] file1 ... filen\n");
-- error("Cmd:\n");
-- error("\t-c/-u/-r\tcreate/update/replace named files to tape\n");
-- error("\t-x/-t/-n\textract/list/trace named files from tape\n");
-- error("\t-diff\t\tdiff archive against file system (see -xhelp)\n");
-- error("Options:\n");
-- error("\t-help\t\tprint this help\n");
-- error("\t-xhelp\t\tprint extended help\n");
-- error("\tblocks=#,b=#\tset blocking factor to #x512 Bytes (default 20)\n");
-- error("\tfile=nm,f=nm\tuse 'nm' as tape instead of stdin/stdout\n");
-- error("\t-T\t\tuse $TAPE as tape instead of stdin/stdout\n");
-+ FILE *fp = ret ? stderr : stdout;
-+
-+ fprintf(fp, "Usage:\tstar cmd [options] file1 ... filen\n");
-+ fprintf(fp, "Cmd:\n");
-+ fprintf(fp, "\t-c/-u/-r\tcreate/update/replace named files to tape\n");
-+ fprintf(fp, "\t-x/-t/-n\textract/list/trace named files from tape\n");
-+ fprintf(fp, "\t-diff\t\tdiff archive against file system (see -xhelp)\n");
-+ fprintf(fp, "Options:\n");
-+ fprintf(fp, "\t-help\t\tprint this help\n");
-+ fprintf(fp, "\t-xhelp\t\tprint extended help\n");
-+ fprintf(fp, "\tblocks=#,b=#\tset blocking factor to #x512 Bytes (default 20)\n");
-+ fprintf(fp, "\tfile=nm,f=nm\tuse 'nm' as tape instead of stdin/stdout\n");
-+ fprintf(fp, "\t-T\t\tuse $TAPE as tape instead of stdin/stdout\n");
- #ifdef FIFO
-- error("\t-fifo/-no-fifo\tuse/don't use a fifo to optimize data flow from/to tape\n");
-+ fprintf(fp, "\t-fifo/-no-fifo\tuse/don't use a fifo to optimize data flow from/to tape\n");
- #if defined(USE_MMAP) && defined(USE_USGSHM)
-- error("\t-shm\t\tuse SysV shared memory for fifo\n");
-+ fprintf(fp, "\t-shm\t\tuse SysV shared memory for fifo\n");
- #endif
- #endif
-- error("\t-v\t\tbe verbose\n");
-- error("\t-tpath\t\tuse with -t to list path names only\n");
-- error("\tH=header\tgenerate 'header' type archive (see H=help)\n");
-- error("\tC=dir\t\tperform a chdir to 'dir' before storing next file\n");
-- error("\t-z\t\tpipe input/output through gzip, does not work on tapes\n");
-- error("\t-bz\t\tpipe input/output through bzip2, does not work on tapes\n");
-- error("\t-B\t\tperform multiple reads (needed on pipes)\n");
-- error("\t-i\t\tignore checksum errors\n");
-- error("\t-d\t\tdo not store/create directories\n");
-- error("\t-m\t\tdo not restore access and modification time\n");
-- error("\t-nochown\tdo not restore owner and group\n");
-- error("\t-a,-atime\treset access time after storing file\n");
-- error("\t-p\t\trestore filemodes of directories\n");
-- error("\t-l\t\tdo not print a message if not all links are dumped\n");
-- error("\t-L\t\tfollow symbolic links as if they were files\n");
-- error("\t-D\t\tdo not descend directories\n");
-- error("\t-M\t\tdo not descend mounting points\n");
-- error("\t-I,-w\t\tdo interactive creation/extraction/renaming\n");
-- error("\t-O\t\tbe compatible to old tar (except for checksum bug)\n");
-- error("\t-P\t\tlast record may be partial (useful on cartridge tapes)\n");
-- error("\t-S\t\tdo not store/create special files\n");
-- error("\t-F,-FF,-FFF,...\tdo not store/create SCCS/RCS, core and object files\n");
-- error("\t-U\t\trestore files unconditionally\n");
-+ fprintf(fp, "\t-v\t\tbe verbose\n");
-+ fprintf(fp, "\t-tpath\t\tuse with -t to list path names only\n");
-+ fprintf(fp, "\tH=header\tgenerate 'header' type archive (see H=help)\n");
-+ fprintf(fp, "\tC=dir\t\tperform a chdir to 'dir' before storing next file\n");
-+ fprintf(fp, "\t-z\t\tpipe input/output through gzip, does not work on tapes\n");
-+ fprintf(fp, "\t-bz\t\tpipe input/output through bzip2, does not work on tapes\n");
-+ fprintf(fp, "\t-B\t\tperform multiple reads (needed on pipes)\n");
-+ fprintf(fp, "\t-i\t\tignore checksum errors\n");
-+ fprintf(fp, "\t-d\t\tdo not store/create directories\n");
-+ fprintf(fp, "\t-m\t\tdo not restore access and modification time\n");
-+ fprintf(fp, "\t-nochown\tdo not restore owner and group\n");
-+ fprintf(fp, "\t-a,-atime\treset access time after storing file\n");
-+ fprintf(fp, "\t-p\t\trestore filemodes of directories\n");
-+ fprintf(fp, "\t-l\t\tdo not print a message if not all links are dumped\n");
-+ fprintf(fp, "\t-L\t\tfollow symbolic links as if they were files\n");
-+ fprintf(fp, "\t-D\t\tdo not descend directories\n");
-+ fprintf(fp, "\t-M\t\tdo not descend mounting points\n");
-+ fprintf(fp, "\t-I,-w\t\tdo interactive creation/extraction/renaming\n");
-+ fprintf(fp, "\t-O\t\tbe compatible to old tar (except for checksum bug)\n");
-+ fprintf(fp, "\t-P\t\tlast record may be partial (useful on cartridge tapes)\n");
-+ fprintf(fp, "\t-S\t\tdo not store/create special files\n");
-+ fprintf(fp, "\t-F,-FF,-FFF,...\tdo not store/create SCCS/RCS, core and object files\n");
-+ fprintf(fp, "\t-U\t\trestore files unconditionally\n");
- exit(ret);
- /* NOTREACHED */
- }
-@@ -490,56 +492,58 @@ LOCAL void
- xusage(ret)
- int ret;
- {
-- error("Usage:\tstar cmd [options] file1 ... filen\n");
-- error("Extended options:\n");
-- error("\tdiffopts=optlst\tcomma separated list of diffopts (see diffopts=help)\n");
-- error("\t-not,-V\t\tuse those files which do not match pattern\n");
-- error("\tVOLHDR=name\tuse name to generate a volume header\n");
-- error("\t-xdir\t\textract dir even if the current is never\n");
-- error("\t-keep-old-files,-k\tkeep existing files\n");
-- error("\t-refresh-old-files\trefresh existing files, don't create new files\n");
-- error("\t-/\t\tdon't strip leading '/'s from file names\n");
-- error("\tlist=name\tread filenames from named file\n");
-- error("\t-dodesc\t\tdo descend directories found in a list= file\n");
-- error("\tpattern=p,pat=p\tset matching pattern\n");
-- error("\tmaxsize=#\tdo not store file if it is bigger than # kBytes\n");
-- error("\tnewer=name\tstore only files which are newer than 'name'\n");
-- error("\t-ctime\t\tuse ctime for newer= option\n");
-- error("\tbs=#\t\tset (output) block size to #\n");
-+ FILE *fp = ret ? stderr : stdout;
-+
-+ fprintf(fp, "Usage:\tstar cmd [options] file1 ... filen\n");
-+ fprintf(fp, "Extended options:\n");
-+ fprintf(fp, "\tdiffopts=optlst\tcomma separated list of diffopts (see diffopts=help)\n");
-+ fprintf(fp, "\t-not,-V\t\tuse those files which do not match pattern\n");
-+ fprintf(fp, "\tVOLHDR=name\tuse name to generate a volume header\n");
-+ fprintf(fp, "\t-xdir\t\textract dir even if the current is never\n");
-+ fprintf(fp, "\t-keep-old-files,-k\tkeep existing files\n");
-+ fprintf(fp, "\t-refresh-old-files\trefresh existing files, don't create new files\n");
-+ fprintf(fp, "\t-/\t\tdon't strip leading '/'s from file names\n");
-+ fprintf(fp, "\tlist=name\tread filenames from named file\n");
-+ fprintf(fp, "\t-dodesc\t\tdo descend directories found in a list= file\n");
-+ fprintf(fp, "\tpattern=p,pat=p\tset matching pattern\n");
-+ fprintf(fp, "\tmaxsize=#\tdo not store file if it is bigger than # kBytes\n");
-+ fprintf(fp, "\tnewer=name\tstore only files which are newer than 'name'\n");
-+ fprintf(fp, "\t-ctime\t\tuse ctime for newer= option\n");
-+ fprintf(fp, "\tbs=#\t\tset (output) block size to #\n");
- #ifdef FIFO
-- error("\tfs=#\t\tset fifo size to #\n");
-+ fprintf(fp, "\tfs=#\t\tset fifo size to #\n");
- #endif
-- error("\ttsize=#\t\tset tape volume size to # 512 byte blocks\n");
-- error("\t-qic24\t\tset tape volume size to %d kBytes\n",
-+ fprintf(fp, "\ttsize=#\t\tset tape volume size to # 512 byte blocks\n");
-+ fprintf(fp, "\t-qic24\t\tset tape volume size to %d kBytes\n",
- TSIZE(QIC_24_TSIZE)/1024);
-- error("\t-qic120\t\tset tape volume size to %d kBytes\n",
-+ fprintf(fp, "\t-qic120\t\tset tape volume size to %d kBytes\n",
- TSIZE(QIC_120_TSIZE)/1024);
-- error("\t-qic150\t\tset tape volume size to %d kBytes\n",
-+ fprintf(fp, "\t-qic150\t\tset tape volume size to %d kBytes\n",
- TSIZE(QIC_150_TSIZE)/1024);
-- error("\t-qic250\t\tset tape volume size to %d kBytes\n",
-+ fprintf(fp, "\t-qic250\t\tset tape volume size to %d kBytes\n",
- TSIZE(QIC_250_TSIZE)/1024);
-- error("\t-nowarn\t\tdo not print warning messages\n");
-- error("\t-time\t\tprint timing info\n");
-- error("\t-no-statistics\tdo not print statistics\n");
-+ fprintf(fp, "\t-nowarn\t\tdo not print warning messages\n");
-+ fprintf(fp, "\t-time\t\tprint timing info\n");
-+ fprintf(fp, "\t-no-statistics\tdo not print statistics\n");
- #ifdef FIFO
-- error("\t-fifostats\tprint fifo statistics\n");
-+ fprintf(fp, "\t-fifostats\tprint fifo statistics\n");
- #endif
-- error("\t-numeric\tdon't use user/group name from tape\n");
-- error("\t-newest\t\tfind newest file on tape\n");
-- error("\t-newest-file\tfind newest regular file on tape\n");
-- error("\t-hpdev\t\tuse HP's non POSIX compliant method to store dev numbers\n");
-- error("\t-modebits\tinclude all 16 bits from stat.st_mode, this violates POSIX-1003.1\n");
-- error("\t-copylinks\tCopy hard and symlinks rather than linking\n");
-- error("\t-signed-checksum\tuse signed chars to calculate checksum\n");
-- error("\t-sparse\t\thandle file with holes effectively on store/create\n");
-- error("\t-force-hole\ttry to extract all files with holes\n");
-- error("\t-to-stdout\textract files to stdout\n");
-- error("\t-wready\t\twait for tape drive to become ready\n");
-- error("\t-force-remove\tforce to remove non writable files on extraction\n");
-- error("\t-ask-remove\task to remove non writable files on extraction\n");
-- error("\t-remove-first\tremove files before extraction\n");
-- error("\t-remove-recursive\tremove files recursive\n");
-- error("\t-onull,-nullout\tsimulate creating an achive to compute the size\n");
-+ fprintf(fp, "\t-numeric\tdon't use user/group name from tape\n");
-+ fprintf(fp, "\t-newest\t\tfind newest file on tape\n");
-+ fprintf(fp, "\t-newest-file\tfind newest regular file on tape\n");
-+ fprintf(fp, "\t-hpdev\t\tuse HP's non POSIX compliant method to store dev numbers\n");
-+ fprintf(fp, "\t-modebits\tinclude all 16 bits from stat.st_mode, this violates POSIX-1003.1\n");
-+ fprintf(fp, "\t-copylinks\tCopy hard and symlinks rather than linking\n");
-+ fprintf(fp, "\t-signed-checksum\tuse signed chars to calculate checksum\n");
-+ fprintf(fp, "\t-sparse\t\thandle file with holes effectively on store/create\n");
-+ fprintf(fp, "\t-force-hole\ttry to extract all files with holes\n");
-+ fprintf(fp, "\t-to-stdout\textract files to stdout\n");
-+ fprintf(fp, "\t-wready\t\twait for tape drive to become ready\n");
-+ fprintf(fp, "\t-force-remove\tforce to remove non writable files on extraction\n");
-+ fprintf(fp, "\t-ask-remove\task to remove non writable files on extraction\n");
-+ fprintf(fp, "\t-remove-first\tremove files before extraction\n");
-+ fprintf(fp, "\t-remove-recursive\tremove files recursive\n");
-+ fprintf(fp, "\t-onull,-nullout\tsimulate creating an achive to compute the size\n");
- exit(ret);
- /* NOTREACHED */
- }
-@@ -548,27 +552,29 @@ LOCAL void
- dusage(ret)
- int ret;
- {
-- error("Diff options:\n");
-- error("\tnot\t\tif this option is present, exclude listed options\n");
-- error("\tperm\t\tcompare file permissions\n");
-- error("\tmode\t\tcompare file permissions\n");
-- error("\ttype\t\tcompare file type\n");
-- error("\tnlink\t\tcompare linkcount (not supported)\n");
-- error("\tuid\t\tcompare owner of file\n");
-- error("\tgid\t\tcompare group of file\n");
-- error("\tuname\t\tcompare name of owner of file\n");
-- error("\tgname\t\tcompare name of group of file\n");
-- error("\tid\t\tcompare owner, group, ownername and groupname of file\n");
-- error("\tsize\t\tcompare file size\n");
-- error("\tdata\t\tcompare content of file\n");
-- error("\tcont\t\tcompare content of file\n");
-- error("\trdev\t\tcompare rdev of device node\n");
-- error("\thardlink\tcompare target of hardlink\n");
-- error("\tsymlink\t\tcompare target of symlink\n");
-- error("\tatime\t\tcompare access time of file (only star)\n");
-- error("\tmtime\t\tcompare modification time of file\n");
-- error("\tctime\t\tcompare creation time of file (only star)\n");
-- error("\ttimes\t\tcompare all times of file\n");
-+ FILE *fp = ret ? stderr : stdout;
-+
-+ fprintf(fp, "Diff options:\n");
-+ fprintf(fp, "\tnot\t\tif this option is present, exclude listed options\n");
-+ fprintf(fp, "\tperm\t\tcompare file permissions\n");
-+ fprintf(fp, "\tmode\t\tcompare file permissions\n");
-+ fprintf(fp, "\ttype\t\tcompare file type\n");
-+ fprintf(fp, "\tnlink\t\tcompare linkcount (not supported)\n");
-+ fprintf(fp, "\tuid\t\tcompare owner of file\n");
-+ fprintf(fp, "\tgid\t\tcompare group of file\n");
-+ fprintf(fp, "\tuname\t\tcompare name of owner of file\n");
-+ fprintf(fp, "\tgname\t\tcompare name of group of file\n");
-+ fprintf(fp, "\tid\t\tcompare owner, group, ownername and groupname of file\n");
-+ fprintf(fp, "\tsize\t\tcompare file size\n");
-+ fprintf(fp, "\tdata\t\tcompare content of file\n");
-+ fprintf(fp, "\tcont\t\tcompare content of file\n");
-+ fprintf(fp, "\trdev\t\tcompare rdev of device node\n");
-+ fprintf(fp, "\thardlink\tcompare target of hardlink\n");
-+ fprintf(fp, "\tsymlink\t\tcompare target of symlink\n");
-+ fprintf(fp, "\tatime\t\tcompare access time of file (only star)\n");
-+ fprintf(fp, "\tmtime\t\tcompare modification time of file\n");
-+ fprintf(fp, "\tctime\t\tcompare creation time of file (only star)\n");
-+ fprintf(fp, "\ttimes\t\tcompare all times of file\n");
- exit(ret);
- /* NOTREACHED */
- }
-@@ -577,13 +583,15 @@ LOCAL void
- husage(ret)
- int ret;
- {
-- error("Header types:\n");
-- error("\ttar\t\told tar format\n");
-- error("\tstar\t\tstar format\n");
-- error("\tgnutar\t\tgnu tar format\n");
-- error("\tustar\t\tstandard tar (ieee 1003.1) format\n");
-- error("\txstar\t\textended standard tar format\n");
-- error("\txustar\t\textended standard tar format without tar signature\n");
-+ FILE *fp = ret ? stderr : stdout;
-+
-+ fprintf(fp, "Header types:\n");
-+ fprintf(fp, "\ttar\t\told tar format\n");
-+ fprintf(fp, "\tstar\t\tstar format\n");
-+ fprintf(fp, "\tgnutar\t\tgnu tar format\n");
-+ fprintf(fp, "\tustar\t\tstandard tar (ieee 1003.1) format\n");
-+ fprintf(fp, "\txstar\t\textended standard tar format\n");
-+ fprintf(fp, "\txustar\t\textended standard tar format without tar signature\n");
- exit(ret);
- /* NOTREACHED */
- }
diff --git a/archivers/star/files/patch-ad b/archivers/star/files/patch-ad
deleted file mode 100644
index 8766cc3e8b36..000000000000
--- a/archivers/star/files/patch-ad
+++ /dev/null
@@ -1,22 +0,0 @@
---- star/star.1.orig Tue Jun 23 02:41:37 1998
-+++ star/star.1 Sat Oct 30 15:01:35 1999
-@@ -15,10 +15,18 @@
- .if n .ds s sz
- .TH STAR 1 "Release 1.1" "J\*org Schilling" "Schily\'s USER COMMANDS"
- .SH NAME
--star \- unique standard tape archiver
-+star, ustar \- unique standard tape archiver
- .SH SYNOPSIS
- .B
- star
-+.I command
-+[
-+.I options
-+]
-+.I file1 .\|.\|. filen
-+.br
-+.B
-+ustar
- .I command
- [
- .I options
diff --git a/archivers/star/pkg-comment b/archivers/star/pkg-comment
deleted file mode 100644
index b0332b514fb1..000000000000
--- a/archivers/star/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-Unique standard tape archiver with many enhancements
diff --git a/archivers/star/pkg-descr b/archivers/star/pkg-descr
deleted file mode 100644
index 2af715f36ddb..000000000000
--- a/archivers/star/pkg-descr
+++ /dev/null
@@ -1,20 +0,0 @@
-star is the fastest known implementation of a tar archiver. star
-development started 1982, development is still in progress. The
-current version is stable.
-
-Main advantages over other tar implementations:
- fifo - Keeps the tape streaming.
- pattern matcher - For a convenient user interface.
- sophisticated diff - User tailorable interface for comparing tar
- archives against file trees.
- no namelen limitation - Pathnames up to 1024 Bytes may be archived.
- deals with all 3 times - Stores/restores all 3 times of a file.
- does not clobber files - More recent copies on disk will not be
- clobbered from tape.
- automatic byte swap - star automatically detects swapped archives.
- automatic format detect - Automatically detects archive formats:
- old tar, gnu tar, ansi tar, star.
- fully ansi compatible - star is fully ANSI/Posix 1003.1 compatible.
-
-Author: Joerg Schilling <js@cs.tu-berlin.de>
-Please mail bugs and suggestions to him.
diff --git a/archivers/star/pkg-plist b/archivers/star/pkg-plist
deleted file mode 100644
index 7f1de4fd1f71..000000000000
--- a/archivers/star/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-@comment $FreeBSD$
-bin/star
-bin/ustar