aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-08-21 14:08:06 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-08-21 14:08:06 +0000
commitc9cf6c61132115ca4b6476190fe9576d06ee06db (patch)
treea29fe29c38d5df1895cfbe84019093fae61a6b42 /archivers
parentb100cd9f05b8e71f0cd2e142eafe47d54108a79c (diff)
downloadports-c9cf6c61132115ca4b6476190fe9576d06ee06db.tar.gz
ports-c9cf6c61132115ca4b6476190fe9576d06ee06db.zip
- Convert to new perl framework
Notes
Notes: svn path=/head/; revision=325134
Diffstat (limited to 'archivers')
-rw-r--r--archivers/p5-Archive-Extract-Libarchive/Makefile3
-rw-r--r--archivers/p5-Compress-Raw-Bzip2/Makefile3
-rw-r--r--archivers/p5-Compress-Raw-Lzma/Makefile3
-rw-r--r--archivers/p5-Compress-Raw-Zlib/Makefile3
-rw-r--r--archivers/p5-Compress-Snappy/Makefile3
-rw-r--r--archivers/p5-IO-Compress-Lzf/Makefile3
-rw-r--r--archivers/p5-IO-Compress-Lzma/Makefile3
-rw-r--r--archivers/p5-IO-Compress-Lzop/Makefile3
-rw-r--r--archivers/p5-IO-Compress/Makefile3
9 files changed, 18 insertions, 9 deletions
diff --git a/archivers/p5-Archive-Extract-Libarchive/Makefile b/archivers/p5-Archive-Extract-Libarchive/Makefile
index e539532594f0..3e629edce117 100644
--- a/archivers/p5-Archive-Extract-Libarchive/Makefile
+++ b/archivers/p5-Archive-Extract-Libarchive/Makefile
@@ -18,7 +18,8 @@ TEST_DEPENDS= p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp \
p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
p5-Test-Pod>=1.04:${PORTSDIR}/devel/p5-Test-Pod
-PERL_MODBUILD= yes
+USE_PERL5= modbuild
+USES= perl5
MAN3= Archive::Extract::Libarchive.3
diff --git a/archivers/p5-Compress-Raw-Bzip2/Makefile b/archivers/p5-Compress-Raw-Bzip2/Makefile
index e4ece2fc2e59..3d72ca36094b 100644
--- a/archivers/p5-Compress-Raw-Bzip2/Makefile
+++ b/archivers/p5-Compress-Raw-Bzip2/Makefile
@@ -16,7 +16,8 @@ LICENSE_COMB= dual
TEST_DEPENDS= p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Compress::Raw::Bzip2.3
diff --git a/archivers/p5-Compress-Raw-Lzma/Makefile b/archivers/p5-Compress-Raw-Lzma/Makefile
index bfaa1fc571bb..3a78e9b0531b 100644
--- a/archivers/p5-Compress-Raw-Lzma/Makefile
+++ b/archivers/p5-Compress-Raw-Lzma/Makefile
@@ -16,7 +16,8 @@ LICENSE_COMB= dual
TEST_DEPENDS= p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Compress::Raw::Lzma.3
diff --git a/archivers/p5-Compress-Raw-Zlib/Makefile b/archivers/p5-Compress-Raw-Zlib/Makefile
index 539a52ce7cc3..9a09f2304a86 100644
--- a/archivers/p5-Compress-Raw-Zlib/Makefile
+++ b/archivers/p5-Compress-Raw-Zlib/Makefile
@@ -16,7 +16,8 @@ LICENSE_COMB= dual
TEST_DEPENDS= p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Compress::Raw::Zlib.3
diff --git a/archivers/p5-Compress-Snappy/Makefile b/archivers/p5-Compress-Snappy/Makefile
index 5d72f28b724b..c8f6fe817988 100644
--- a/archivers/p5-Compress-Snappy/Makefile
+++ b/archivers/p5-Compress-Snappy/Makefile
@@ -15,7 +15,8 @@ LICENSE_COMB= dual
LIB_DEPENDS= snappy:${PORTSDIR}/archivers/snappy
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Compress::Snappy.3
diff --git a/archivers/p5-IO-Compress-Lzf/Makefile b/archivers/p5-IO-Compress-Lzf/Makefile
index 4faebd18d9ce..8ae175e3a909 100644
--- a/archivers/p5-IO-Compress-Lzf/Makefile
+++ b/archivers/p5-IO-Compress-Lzf/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-Compress-LZF>=0:${PORTSDIR}/archivers/p5-Compress-LZF \
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= IO::Compress::Lzf.3 IO::Uncompress::UnLzf.3
diff --git a/archivers/p5-IO-Compress-Lzma/Makefile b/archivers/p5-IO-Compress-Lzma/Makefile
index e211db3a90ed..426f4f4c7d7a 100644
--- a/archivers/p5-IO-Compress-Lzma/Makefile
+++ b/archivers/p5-IO-Compress-Lzma/Makefile
@@ -21,7 +21,8 @@ TEST_DEPENDS= p5-IO-String>=0:${PORTSDIR}/devel/p5-IO-String \
p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod \
p7zip>=0:${PORTSDIR}/archivers/p7zip
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= IO::Compress::Lzma.3 IO::Compress::Xz.3 \
IO::Uncompress::UnLzma.3 IO::Uncompress::UnXz.3
diff --git a/archivers/p5-IO-Compress-Lzop/Makefile b/archivers/p5-IO-Compress-Lzop/Makefile
index 06d4b05116bc..b1e8c5dc1eb7 100644
--- a/archivers/p5-IO-Compress-Lzop/Makefile
+++ b/archivers/p5-IO-Compress-Lzop/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-Compress-LZO>=0:${PORTSDIR}/archivers/p5-Compress-LZO \
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= IO::Compress::Lzop.3 IO::Uncompress::UnLzop.3
diff --git a/archivers/p5-IO-Compress/Makefile b/archivers/p5-IO-Compress/Makefile
index 2dd0d041cd7f..960c7f9919db 100644
--- a/archivers/p5-IO-Compress/Makefile
+++ b/archivers/p5-IO-Compress/Makefile
@@ -21,7 +21,8 @@ TEST_DEPENDS= p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod
CONFLICTS= p5-Compress-Zlib-2* p5-IO-Compress-Base-2* p5-IO-Compress-Zlib-2* p5-IO-Compress-Bzip2-2*
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Compress::Zlib.3 \
File::GlobMapper.3 \