aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-13 17:10:31 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-13 17:10:31 +0000
commit27f06c66dcc9cf9b26c5064e84d4cd785af8e157 (patch)
tree22c46ac05b7057e447dd7297bcb4edec9aa20c33 /archivers
parentf32147b2fdd34ed33445c5932bbdd1bb213e42ff (diff)
downloadports-27f06c66dcc9cf9b26c5064e84d4cd785af8e157.tar.gz
ports-27f06c66dcc9cf9b26c5064e84d4cd785af8e157.zip
add tardy 1.11
Manipulate the file headers in tar archive files in various ways
Notes
Notes: svn path=/head/; revision=73057
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/tardy/Makefile20
-rw-r--r--archivers/tardy/distinfo1
-rw-r--r--archivers/tardy/files/patch-error.cc10
-rw-r--r--archivers/tardy/files/patch-filename.cc10
-rw-r--r--archivers/tardy/files/patch-tardy.cc10
-rw-r--r--archivers/tardy/pkg-comment1
-rw-r--r--archivers/tardy/pkg-descr17
-rw-r--r--archivers/tardy/pkg-plist1
9 files changed, 71 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 9af37bbdb484..0e40f6f5b2d7 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -51,6 +51,7 @@
SUBDIR += star
SUBDIR += stuffit
SUBDIR += szip
+ SUBDIR += tardy
SUBDIR += ucl
SUBDIR += unace
SUBDIR += unadf
diff --git a/archivers/tardy/Makefile b/archivers/tardy/Makefile
new file mode 100644
index 000000000000..5ad5abd1f086
--- /dev/null
+++ b/archivers/tardy/Makefile
@@ -0,0 +1,20 @@
+# ex:ts=8
+# Ports collection makefile for: tardy
+# Date created: Jan 14, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= tardy
+PORTVERSION= 1.11
+CATEGORIES= archivers
+MASTER_SITES= http://www.canb.auug.org.au/~millerp/
+
+MAINTAINER= ports@FreeBSD.org
+
+GNU_CONFIGURE= yes
+
+MAN1= tardy.1
+
+.include <bsd.port.mk>
diff --git a/archivers/tardy/distinfo b/archivers/tardy/distinfo
new file mode 100644
index 000000000000..d72d083ccbcb
--- /dev/null
+++ b/archivers/tardy/distinfo
@@ -0,0 +1 @@
+MD5 (tardy-1.11.tar.gz) = de9d9c6d8634589c0e6567b70054a0a6
diff --git a/archivers/tardy/files/patch-error.cc b/archivers/tardy/files/patch-error.cc
new file mode 100644
index 000000000000..f4da6594060f
--- /dev/null
+++ b/archivers/tardy/files/patch-error.cc
@@ -0,0 +1,10 @@
+--- common/error.cc.orig Tue Jan 14 00:59:18 2003
++++ common/error.cc Tue Jan 14 00:59:40 2003
+@@ -28,6 +28,7 @@
+ #include <ac/stdlib.h>
+ #include <ac/string.h>
+
++#include <sys/types.h>
+ #include <grp.h>
+ #include <pwd.h>
+ #include <ac/unistd.h>
diff --git a/archivers/tardy/files/patch-filename.cc b/archivers/tardy/files/patch-filename.cc
new file mode 100644
index 000000000000..c4aff0ffceed
--- /dev/null
+++ b/archivers/tardy/files/patch-filename.cc
@@ -0,0 +1,10 @@
+--- common/tar/input/filename.cc.orig Tue Jan 14 01:00:31 2003
++++ common/tar/input/filename.cc Tue Jan 14 01:01:33 2003
+@@ -27,7 +27,6 @@
+ #include <ac/unistd.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+-#include <sys/sysmacros.h>
+ #include <pwd.h>
+ #include <grp.h>
+
diff --git a/archivers/tardy/files/patch-tardy.cc b/archivers/tardy/files/patch-tardy.cc
new file mode 100644
index 000000000000..4d12793c1f01
--- /dev/null
+++ b/archivers/tardy/files/patch-tardy.cc
@@ -0,0 +1,10 @@
+--- tardy/tardy.cc.orig Tue Jan 14 00:58:28 2003
++++ tardy/tardy.cc Tue Jan 14 00:58:44 2003
+@@ -22,6 +22,7 @@
+
+ #include <vector>
+ #include <ac/stdio.h> /* need for grp.h on OSF/1 */
++#include <sys/types.h>
+ #include <grp.h>
+ #include <pwd.h>
+
diff --git a/archivers/tardy/pkg-comment b/archivers/tardy/pkg-comment
new file mode 100644
index 000000000000..3a2bb9daefcd
--- /dev/null
+++ b/archivers/tardy/pkg-comment
@@ -0,0 +1 @@
+Manipulate the file headers in tar archive files in various ways
diff --git a/archivers/tardy/pkg-descr b/archivers/tardy/pkg-descr
new file mode 100644
index 000000000000..59244fe2256c
--- /dev/null
+++ b/archivers/tardy/pkg-descr
@@ -0,0 +1,17 @@
+The tardy program is a tar post-processor. It may be used to manipulate the
+file headers in tar archive files in various ways.
+
+The reason the tardy program was written was because the author wanted to
+"spruce up" tar files before posting them to the net, mostly to remove
+artefacts of the development environment, without introducing more.
+
+The tardy program was designed to allow you to alter certain characteristics
+of files after they have been included in the tar file. Among them are:
+ * change file owner (by number or name)
+ * change file group (by number or name)
+ * add directory prefix (e.g. dot)
+ * change file protections (e.g. from 600 to 644)
+
+Note that all of these affect ALL files in the archive.
+
+WWW: http://www.canb.auug.org.au/~millerp/tardy.html
diff --git a/archivers/tardy/pkg-plist b/archivers/tardy/pkg-plist
new file mode 100644
index 000000000000..e297caf6dd58
--- /dev/null
+++ b/archivers/tardy/pkg-plist
@@ -0,0 +1 @@
+bin/tardy