aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2013-08-02 18:52:07 +0000
committerMathieu Arnold <mat@FreeBSD.org>2013-08-02 18:52:07 +0000
commit4819ca343bfee8a3b54e7ff3ac26d280d1c1696f (patch)
treea4a613f80a0e443c044c2319e43ce75e14c50813 /archivers
parent49b7a7d4a4e27031eeb48b2c26d102a7f8527de9 (diff)
downloadports-4819ca343bfee8a3b54e7ff3ac26d280d1c1696f.tar.gz
ports-4819ca343bfee8a3b54e7ff3ac26d280d1c1696f.zip
- Convert to new perl framework
- Trim Makefile header - Remove MAKE_JOBS_SAFE=yes, it's the default.
Notes
Notes: svn path=/head/; revision=324174
Diffstat (limited to 'archivers')
-rw-r--r--archivers/p5-Archive-Any/Makefile9
-rw-r--r--archivers/p5-Archive-Extract/Makefile4
-rw-r--r--archivers/p5-Archive-Rar/Makefile9
-rw-r--r--archivers/p5-Archive-SimpleExtractor/Makefile9
-rw-r--r--archivers/p5-Archive-Zip/Makefile9
-rw-r--r--archivers/p5-Compress-LZF/Makefile9
-rw-r--r--archivers/p5-Compress-LZO/Makefile3
-rw-r--r--archivers/p5-Compress-LZW/Makefile3
-rw-r--r--archivers/p5-Mac-Macbinary/Makefile9
-rw-r--r--archivers/p5-POE-Filter-Bzip2/Makefile3
-rw-r--r--archivers/p5-POE-Filter-LZF/Makefile3
-rw-r--r--archivers/p5-POE-Filter-LZO/Makefile3
-rw-r--r--archivers/p5-POE-Filter-LZW/Makefile3
-rw-r--r--archivers/p5-POE-Filter-Zlib/Makefile3
-rw-r--r--archivers/p5-PerlIO-gzip/Makefile9
-rw-r--r--archivers/p5-PerlIO-via-Bzip2/Makefile9
16 files changed, 40 insertions, 57 deletions
diff --git a/archivers/p5-Archive-Any/Makefile b/archivers/p5-Archive-Any/Makefile
index e467ac10035f..20550b92f2a3 100644
--- a/archivers/p5-Archive-Any/Makefile
+++ b/archivers/p5-Archive-Any/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Archive-Any
-# Date created: 2006-08-28
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Archive-Any
PORTVERSION= 0.09.32
@@ -26,7 +22,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Perl-Critic>=0:${PORTSDIR}/textproc/p5-Test-Perl-Critic \
p5-Test-Warn>=0:${PORTSDIR}/devel/p5-Test-Warn
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Archive::Any.3 Archive::Any::Plugin.3 \
Archive::Any::Plugin::Tar.3 Archive::Any::Plugin::Zip.3
diff --git a/archivers/p5-Archive-Extract/Makefile b/archivers/p5-Archive-Extract/Makefile
index 6de5b6ce5de2..9002327c8f9a 100644
--- a/archivers/p5-Archive-Extract/Makefile
+++ b/archivers/p5-Archive-Extract/Makefile
@@ -13,8 +13,8 @@ COMMENT= Generic archive extracting mechanism
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-MAKE_JOBS_SAFE= yes
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Archive::Extract.3
diff --git a/archivers/p5-Archive-Rar/Makefile b/archivers/p5-Archive-Rar/Makefile
index f21cd0bb4271..86776f7cf8cf 100644
--- a/archivers/p5-Archive-Rar/Makefile
+++ b/archivers/p5-Archive-Rar/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Archive-Rar
-# Date created: 2009-11-02
-# Whom: Andrey Kostenko <andrey@kostenko.name>
-#
+# Created by: Andrey Kostenko <andrey@kostenko.name>
# $FreeBSD$
-#
PORTNAME= Archive-Rar
PORTVERSION= 2.02
@@ -17,7 +13,8 @@ COMMENT= Interface with the 'rar' command
BUILD_DEPENDS= rar>=0:${PORTSDIR}/archivers/rar \
p5-IPC-Run>=0:${PORTSDIR}/devel/p5-IPC-Run
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Archive::Rar.3 \
Archive::Rar::Passthrough.3
diff --git a/archivers/p5-Archive-SimpleExtractor/Makefile b/archivers/p5-Archive-SimpleExtractor/Makefile
index 76818191bb00..1e6609ff3425 100644
--- a/archivers/p5-Archive-SimpleExtractor/Makefile
+++ b/archivers/p5-Archive-SimpleExtractor/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Archive-SimpleExtractor
-# Date created: 2009-11-02
-# Whom: Andrey Kostenko <andrey@kostenko.name>
-#
+# Created by: Andrey Kostenko <andrey@kostenko.name>
# $FreeBSD$
-#
PORTNAME= Archive-SimpleExtractor
PORTVERSION= 0.11
@@ -21,7 +17,8 @@ BUILD_DEPENDS= p5-Archive-Rar>=2.02:${PORTSDIR}/archivers/p5-Archive-Rar \
p5-Module-Load-Conditional>=0.3:${PORTSDIR}/devel/p5-Module-Load-Conditional
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Archive::SimpleExtractor::Zip.3 \
Archive::SimpleExtractor::Tar.3 \
Archive::SimpleExtractor.3 \
diff --git a/archivers/p5-Archive-Zip/Makefile b/archivers/p5-Archive-Zip/Makefile
index f583ab0b0d9b..f2c0a69e7876 100644
--- a/archivers/p5-Archive-Zip/Makefile
+++ b/archivers/p5-Archive-Zip/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Archive-Zip
-# Date created: Mon Jan 1 09:33:13 2001
-# Whom: will
-#
+# Created by: will
# $FreeBSD$
-#
PORTNAME= Archive-Zip
PORTVERSION= 1.30
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module to create, manipulate, read, and write Zip archive files
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Archive::Zip.3 Archive::Zip::Tree.3 Archive::Zip::FAQ.3 Archive::Zip::MemberRead.3
diff --git a/archivers/p5-Compress-LZF/Makefile b/archivers/p5-Compress-LZF/Makefile
index f8df72c78348..2dc7ee8fc563 100644
--- a/archivers/p5-Compress-LZF/Makefile
+++ b/archivers/p5-Compress-LZF/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Compress-LZF
-# Date created: 2006-09-10
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Compress-LZF
PORTVERSION= 3.43
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Extremely lightweight Lempel-Ziv-Free compression
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Compress::LZF.3
diff --git a/archivers/p5-Compress-LZO/Makefile b/archivers/p5-Compress-LZO/Makefile
index 43e82ec32c2f..ea7996155eda 100644
--- a/archivers/p5-Compress-LZO/Makefile
+++ b/archivers/p5-Compress-LZO/Makefile
@@ -14,7 +14,8 @@ COMMENT= Interface to the LZO compression library
LIB_DEPENDS= lzo2:${PORTSDIR}/archivers/lzo2
CFLAGS+= -I${LOCALBASE}/include/lzo
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
post-patch:
@${REINPLACE_CMD} -i '' -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/Makefile.PL
diff --git a/archivers/p5-Compress-LZW/Makefile b/archivers/p5-Compress-LZW/Makefile
index 69dc2684b915..3e1c4a98fbc6 100644
--- a/archivers/p5-Compress-LZW/Makefile
+++ b/archivers/p5-Compress-LZW/Makefile
@@ -11,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Pure perl implementation of LZW
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Compress::LZW.3
diff --git a/archivers/p5-Mac-Macbinary/Makefile b/archivers/p5-Mac-Macbinary/Makefile
index e6a0bb9d0a13..01fdec0d8e00 100644
--- a/archivers/p5-Mac-Macbinary/Makefile
+++ b/archivers/p5-Mac-Macbinary/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Mac-Macbinary
-# Date created: Wed Jan 3 08:41:22 2001
-# Whom: will
-#
+# Created by: will
# $FreeBSD$
-#
PORTNAME= Mac-Macbinary
PORTVERSION= 0.06
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module that can extract info from Macbinary files
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Mac::Macbinary.3
diff --git a/archivers/p5-POE-Filter-Bzip2/Makefile b/archivers/p5-POE-Filter-Bzip2/Makefile
index e86e2ebbe020..e629d06d297a 100644
--- a/archivers/p5-POE-Filter-Bzip2/Makefile
+++ b/archivers/p5-POE-Filter-Bzip2/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-Compress-Bzip2>=2.08:${PORTSDIR}/archivers/p5-Compress-Bzip2 \
p5-POE>=0.38:${PORTSDIR}/devel/p5-POE
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= POE::Filter::Bzip2.3
diff --git a/archivers/p5-POE-Filter-LZF/Makefile b/archivers/p5-POE-Filter-LZF/Makefile
index 8ad490441a80..8858bebb1c7f 100644
--- a/archivers/p5-POE-Filter-LZF/Makefile
+++ b/archivers/p5-POE-Filter-LZF/Makefile
@@ -16,7 +16,8 @@ BUILD_DEPENDS= p5-Compress-LZF>=1.51:${PORTSDIR}/archivers/p5-Compress-LZF \
p5-POE>=0.38:${PORTSDIR}/devel/p5-POE
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= POE::Filter::LZF.3
diff --git a/archivers/p5-POE-Filter-LZO/Makefile b/archivers/p5-POE-Filter-LZO/Makefile
index b4cff2d609e7..be1160622b3b 100644
--- a/archivers/p5-POE-Filter-LZO/Makefile
+++ b/archivers/p5-POE-Filter-LZO/Makefile
@@ -16,7 +16,8 @@ BUILD_DEPENDS= p5-Compress-LZO>=1.08:${PORTSDIR}/archivers/p5-Compress-LZO \
p5-POE>=0.38:${PORTSDIR}/devel/p5-POE
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= POE::Filter::LZO.3
diff --git a/archivers/p5-POE-Filter-LZW/Makefile b/archivers/p5-POE-Filter-LZW/Makefile
index 5a019aa93608..3abe1dad37ab 100644
--- a/archivers/p5-POE-Filter-LZW/Makefile
+++ b/archivers/p5-POE-Filter-LZW/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-Compress-LZW>=0:${PORTSDIR}/archivers/p5-Compress-LZW \
p5-POE>=0.38:${PORTSDIR}/devel/p5-POE
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= POE::Filter::LZW.3
diff --git a/archivers/p5-POE-Filter-Zlib/Makefile b/archivers/p5-POE-Filter-Zlib/Makefile
index 2fb25e443355..baaade35f619 100644
--- a/archivers/p5-POE-Filter-Zlib/Makefile
+++ b/archivers/p5-POE-Filter-Zlib/Makefile
@@ -15,7 +15,8 @@ COMMENT= POE filter wrapped around Compress::Zlib
BUILD_DEPENDS= p5-POE>=0.38:${PORTSDIR}/devel/p5-POE
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= POE::Filter::Zlib.3 \
POE::Filter::Zlib::Stream.3
diff --git a/archivers/p5-PerlIO-gzip/Makefile b/archivers/p5-PerlIO-gzip/Makefile
index 18a53ba6f0f4..ba222a04a1eb 100644
--- a/archivers/p5-PerlIO-gzip/Makefile
+++ b/archivers/p5-PerlIO-gzip/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: PerlIO-gzip
-# Date created: 08 December 2004
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= PerlIO-gzip
PORTVERSION= 0.18
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl extension to provide a PerlIO layer to gzip/gunzip
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= PerlIO::gzip.3
diff --git a/archivers/p5-PerlIO-via-Bzip2/Makefile b/archivers/p5-PerlIO-via-Bzip2/Makefile
index 261a88db7f20..dabab4e2083d 100644
--- a/archivers/p5-PerlIO-via-Bzip2/Makefile
+++ b/archivers/p5-PerlIO-via-Bzip2/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: PerlIO-via-Bzip2
-# Date created: 18 December 2006
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= PerlIO-via-Bzip2
PORTVERSION= 0.02
@@ -17,7 +13,8 @@ COMMENT= Perl extension to provide a PerlIO layer to bzip2/bunzip2
BUILD_DEPENDS= p5-Compress-Bzip2>=0:${PORTSDIR}/archivers/p5-Compress-Bzip2
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= PerlIO::via::Bzip2.3