aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2014-06-01 07:59:15 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2014-06-01 07:59:15 +0000
commit73969bbf7997cd2e8f7c0690cd27430068ffdc5d (patch)
tree4d307b471693ec4b275c79f06f7f888397796316 /archivers
parent060db7b1f8a1baebf5e7d6b33843990a6fe38a41 (diff)
downloadports-73969bbf7997cd2e8f7c0690cd27430068ffdc5d.tar.gz
ports-73969bbf7997cd2e8f7c0690cd27430068ffdc5d.zip
- fix sanity in CAT archivers
- USE_BZIP2 -> USES=tar:bzip2 - LICENSE=BSD -> BSD[n]CLAUSE
Notes
Notes: svn path=/head/; revision=356058
Diffstat (limited to 'archivers')
-rw-r--r--archivers/fastjar/Makefile5
-rw-r--r--archivers/grzip/Makefile13
-rw-r--r--archivers/hs-tar/Makefile3
-rw-r--r--archivers/hs-zip-archive/Makefile2
-rw-r--r--archivers/hs-zlib-bindings/Makefile2
-rw-r--r--archivers/hs-zlib-conduit/Makefile2
-rw-r--r--archivers/hs-zlib/Makefile2
-rw-r--r--archivers/lrzip/Makefile3
-rw-r--r--archivers/lzma/Makefile9
-rw-r--r--archivers/mscompress/Makefile2
-rw-r--r--archivers/p7zip/Makefile12
-rw-r--r--archivers/pixz/Makefile2
-rw-r--r--archivers/ppmd-7z/Makefile3
-rw-r--r--archivers/rox-archive/Makefile2
-rw-r--r--archivers/squeeze/Makefile3
-rw-r--r--archivers/thunar-archive-plugin/Makefile3
-rw-r--r--archivers/unadf/Makefile2
-rw-r--r--archivers/unfoo/Makefile2
-rw-r--r--archivers/upx/Makefile3
-rw-r--r--archivers/xarchiver/Makefile3
-rw-r--r--archivers/xdms/Makefile2
-rw-r--r--archivers/zip/Makefile2
22 files changed, 36 insertions, 46 deletions
diff --git a/archivers/fastjar/Makefile b/archivers/fastjar/Makefile
index 35bc0bc003eb..639f7e6ac68d 100644
--- a/archivers/fastjar/Makefile
+++ b/archivers/fastjar/Makefile
@@ -12,9 +12,8 @@ COMMENT= Version of JDK's `jar' command written entirely in C
LICENSE= GPLv2
-USES= gmake perl5
+USES= tar:bzip2 gmake perl5
USES_PERL5= build
-USE_BZIP2= yes
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -29,6 +28,6 @@ OPTIONS_DEFINE= DOCS
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>
diff --git a/archivers/grzip/Makefile b/archivers/grzip/Makefile
index 850d06b39c5a..4265526b669e 100644
--- a/archivers/grzip/Makefile
+++ b/archivers/grzip/Makefile
@@ -12,8 +12,7 @@ COMMENT= Efficient file compressor
LICENSE= LGPL21
-USE_BZIP2= yes
-USES= gettext
+USES= tar:bzip2 gettext
USE_LDCONFIG= yes
CFLAGS+= -I${LOCALBASE}/include -fPIC
LDFLAGS+= -L${LOCALBASE}/lib -lintl
@@ -28,13 +27,13 @@ post-patch:
-e '/^PREFIX=/d;/^LDFLAGS/s|=|+=|' ${WRKSRC}/Makefile ${WRKSRC}/po/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${LN} -sf ${PORTNAME} ${STAGEDIR}${PREFIX}/bin/grunzip
${LN} -sf ${PORTNAME} ${STAGEDIR}${PREFIX}/bin/grzcat
- ${INSTALL_SCRIPT} ${WRAPPERS:S|^|${WRKSRC}/scripts/|} ${STAGEDIR}${PREFIX}/bin/
- ${INSTALL_PROGRAM} ${WRKSRC}/lib${PORTNAME}.so ${STAGEDIR}${PREFIX}/lib/
+ ${INSTALL_SCRIPT} ${WRAPPERS:S|^|${WRKSRC}/scripts/|} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/lib${PORTNAME}.so ${STAGEDIR}${PREFIX}/lib
${LN} -sf lib${PORTNAME}.so ${STAGEDIR}${PREFIX}/lib/lib${PORTNAME}.so.0
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.h ${STAGEDIR}${PREFIX}/include/
- cd ${WRKSRC}/po; ${SETENV} ${MAKE_ENV} ${MAKE} PREFIX="${STAGEDIR}${PREFIX}" install
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.h ${STAGEDIR}${PREFIX}/include
+ (cd ${WRKSRC}/po; ${SETENV} ${MAKE_ENV} ${MAKE} PREFIX="${STAGEDIR}${PREFIX}" install)
.include <bsd.port.mk>
diff --git a/archivers/hs-tar/Makefile b/archivers/hs-tar/Makefile
index d0cc14e2772c..75a3124b4a01 100644
--- a/archivers/hs-tar/Makefile
+++ b/archivers/hs-tar/Makefile
@@ -8,8 +8,7 @@ CATEGORIES= archivers haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Reading, writing, and manipulating ".tar" archive files
-LICENSE= BSD
-
+LICENSE= BSD3CLAUSE
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/archivers/hs-zip-archive/Makefile b/archivers/hs-zip-archive/Makefile
index 0217ec183ed2..863d5db2bad4 100644
--- a/archivers/hs-zip-archive/Makefile
+++ b/archivers/hs-zip-archive/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= archivers haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Library for creating and modifying zip archives
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
USE_CABAL= digest>=0.0.0.1 mtl utf8-string>=0.3.1 zlib
diff --git a/archivers/hs-zlib-bindings/Makefile b/archivers/hs-zlib-bindings/Makefile
index 2919f72851a8..0b9c649ea0da 100644
--- a/archivers/hs-zlib-bindings/Makefile
+++ b/archivers/hs-zlib-bindings/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= archivers haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Low-level bindings to the zlib package
-LICENSE= BSD
+LICENSE= BSD2CLAUSE
USE_CABAL= zlib>=0.5.2.0
diff --git a/archivers/hs-zlib-conduit/Makefile b/archivers/hs-zlib-conduit/Makefile
index e39894e926b1..1ffcb8800e9a 100644
--- a/archivers/hs-zlib-conduit/Makefile
+++ b/archivers/hs-zlib-conduit/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= archivers haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Streaming compression/decompression via conduits
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
USE_CABAL= conduit>=1.0 transformers>=0.2.2 void zlib-bindings>=0.1
diff --git a/archivers/hs-zlib/Makefile b/archivers/hs-zlib/Makefile
index ec0f9e10b476..51ba4bd9aa89 100644
--- a/archivers/hs-zlib/Makefile
+++ b/archivers/hs-zlib/Makefile
@@ -9,7 +9,7 @@ CATEGORIES= archivers haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Compression and decompression in the gzip and zlib formats
-LICENSE= BSD
+LICENSE= BSD2CLAUSE
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/archivers/lrzip/Makefile b/archivers/lrzip/Makefile
index eec12d24e22e..69b5f654bb3d 100644
--- a/archivers/lrzip/Makefile
+++ b/archivers/lrzip/Makefile
@@ -19,8 +19,7 @@ CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS+= --enable-asm
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
-USE_BZIP2= yes
-USES= gmake pathfix perl5
+USES= tar:bzip2 gmake pathfix perl5
USE_PERL5= build
USE_LDCONFIG= yes
diff --git a/archivers/lzma/Makefile b/archivers/lzma/Makefile
index 4533d3ab9644..7dbc3c1a1db8 100644
--- a/archivers/lzma/Makefile
+++ b/archivers/lzma/Makefile
@@ -12,8 +12,7 @@ COMMENT= High-ratio LZMA compressor
CONFLICTS= lzmautils-[0-9]* xz-[0-9]*
-USES= gmake dos2unix
-USE_BZIP2= yes
+USES= tar:bzip2 gmake dos2unix
NO_WRKSUBDIR= yes
BUILD_WRKSRC= ${WRKSRC}/CPP/7zip/Bundles/LzmaCon
MAKEFILE= makefile.gcc
@@ -40,9 +39,9 @@ post-patch:
${BUILD_WRKSRC}/${MAKEFILE}
do-install:
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
- @${INSTALL} -d ${STAGEDIR}${DOCSDIR}/
- cd ${WRKSRC}/&&${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ @${INSTALL} -d ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/&&${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
regression-test: build
${BUILD_WRKSRC}/${PORTNAME} b
diff --git a/archivers/mscompress/Makefile b/archivers/mscompress/Makefile
index 5ddb9dd90df1..daa240938663 100644
--- a/archivers/mscompress/Makefile
+++ b/archivers/mscompress/Makefile
@@ -10,7 +10,7 @@ MASTER_SITE_SUBDIR= utils/compress
MAINTAINER= tj@FreeBSD.org
COMMENT= Microsoft "compress.exe/expand.exe" compatible (de)compressor
-USE_BZIP2= yes
+USES= tar:bzip2
HAS_CONFIGURE= yes
PLIST_FILES= bin/mscompress bin/msexpand \
diff --git a/archivers/p7zip/Makefile b/archivers/p7zip/Makefile
index ec99aead53ce..7be0c901884d 100644
--- a/archivers/p7zip/Makefile
+++ b/archivers/p7zip/Makefile
@@ -14,7 +14,7 @@ COMMENT?= File archiver with high compression ratio
LICENSE?= LGPL21
ALL_TARGET?= all3
-USE_BZIP2= yes
+USES= tar:bzip2
MAKEFILE= makefile
MAKE_ARGS= OPTFLAGS="${CXXFLAGS}"
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}
@@ -44,14 +44,14 @@ do-install:
.endfor
${INSTALL_LIB} ${WRKSRC}/bin/7z.so ${STAGEDIR}${PREFIX}/libexec/p7zip
- ${INSTALL_SCRIPT} ${FILESDIR}/7z ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${FILESDIR}/7z ${STAGEDIR}${PREFIX}/bin
${LN} -sf 7z ${STAGEDIR}${PREFIX}/bin/7za
${LN} -sf 7z ${STAGEDIR}${PREFIX}/bin/7zr
- cd ${WRKSRC}/DOCS && \
- ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC}/man1 && \
- ${INSTALL_MAN} 7z*.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ (cd ${WRKSRC}/DOCS && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
+ (cd ${WRKSRC}/man1 && \
+ ${INSTALL_MAN} 7z*.1 ${STAGEDIR}${MAN1PREFIX}/man/man1)
.endif
.include <bsd.port.mk>
diff --git a/archivers/pixz/Makefile b/archivers/pixz/Makefile
index 719e81f5dcb6..d27f7cda13f0 100644
--- a/archivers/pixz/Makefile
+++ b/archivers/pixz/Makefile
@@ -9,7 +9,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= hrs@FreeBSD.org
COMMENT= Parallel, indexing version of XZ
-LICENSE= BSD
+LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
SUB_FILES= Makefile
diff --git a/archivers/ppmd-7z/Makefile b/archivers/ppmd-7z/Makefile
index f194c18ec91f..9569c8af0f20 100644
--- a/archivers/ppmd-7z/Makefile
+++ b/archivers/ppmd-7z/Makefile
@@ -11,8 +11,7 @@ DISTNAME= p7zip_${DISTVERSION}_src_all
MAINTAINER= bf@FreeBSD.org
COMMENT= High-ratio PPMD compressor
-USE_BZIP2= yes
-USES= gmake
+USES= tar:bzip2 gmake
WRKSRC= ${WRKDIR}/p7zip_${DISTVERSION}
BUILD_WRKSRC= ${WRKSRC}/CPP/7zip/Compress/PPMD_Alone
MAKEFILE= makefile
diff --git a/archivers/rox-archive/Makefile b/archivers/rox-archive/Makefile
index ee30b8954d18..6d33baaedbb2 100644
--- a/archivers/rox-archive/Makefile
+++ b/archivers/rox-archive/Makefile
@@ -12,7 +12,7 @@ COMMENT= Archive management tool for the ROX desktop
RUN_DEPENDS= ${LOCALBASE}/bin/rox:${PORTSDIR}/x11-fm/rox-filer \
${LOCALBASE}/lib/ROX-Lib2/python/rox/__init__.py:${PORTSDIR}/devel/py-roxlib
-USE_BZIP2= yes
+USES= tar:bzip2
USE_PYTHON= yes
do-build:
diff --git a/archivers/squeeze/Makefile b/archivers/squeeze/Makefile
index 0e8a04799d4f..82354e4bdaec 100644
--- a/archivers/squeeze/Makefile
+++ b/archivers/squeeze/Makefile
@@ -18,11 +18,10 @@ LIB_DEPENDS= libthunar-vfs-1.so:${PORTSDIR}/x11-fm/thunar-vfs
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-USES= pkgconfig gmake gettext pathfix desktop-file-utils
+USES= tar:bzip2 pkgconfig gmake gettext pathfix desktop-file-utils
USE_XFCE= configenv libutil thunar
USE_XORG= x11
USE_GNOME= gtk20 glib20 intltool intlhack
-USE_BZIP2= yes
USE_LDCONFIG= yes
MAKE_JOB_SAFE= yes
diff --git a/archivers/thunar-archive-plugin/Makefile b/archivers/thunar-archive-plugin/Makefile
index f4426de4742a..a281f9f074d2 100644
--- a/archivers/thunar-archive-plugin/Makefile
+++ b/archivers/thunar-archive-plugin/Makefile
@@ -11,10 +11,9 @@ DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
COMMENT= Archive plugin for the Thunar File Manager
-USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_XFCE= configenv libexo thunar
-USES= gettext gmake pkgconfig
+USES= tar:bzip2 gettext gmake pkgconfig
INSTALLS_ICONS= yes
USE_GNOME= intltool
diff --git a/archivers/unadf/Makefile b/archivers/unadf/Makefile
index abfa6c8a77ca..065f2328cfd9 100644
--- a/archivers/unadf/Makefile
+++ b/archivers/unadf/Makefile
@@ -12,7 +12,7 @@ COMMENT= Extracts files from .adf-files used by Amiga emulators
LICENSE= GPLv2
-USE_BZIP2= yes
+USES= tar:bzip2
MAKE_JOBS_UNSAFE= yes
diff --git a/archivers/unfoo/Makefile b/archivers/unfoo/Makefile
index d710fc9e9b5d..7e5e08749901 100644
--- a/archivers/unfoo/Makefile
+++ b/archivers/unfoo/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= unace:${PORTSDIR}/archivers/unace \
7z:${PORTSDIR}/archivers/p7zip
NO_BUILD= yes
-USE_BZIP2= yes
+USES= tar:bzip2
PLIST_FILES= bin/${PORTNAME}
post-patch:
diff --git a/archivers/upx/Makefile b/archivers/upx/Makefile
index a1c9f60b6ee3..f7bd520d98c4 100644
--- a/archivers/upx/Makefile
+++ b/archivers/upx/Makefile
@@ -16,8 +16,7 @@ LIB_DEPENDS= libucl.so:${PORTSDIR}/archivers/ucl
LZMA_VER= 4.65
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src
-USE_BZIP2= yes
-USES= gmake perl5
+USES= tar:bzip2 gmake perl5
USE_PERL5= build
MAKE_ENV= UPX_UCLDIR=${LOCALBASE}\
UPX_LZMADIR=${WRKDIR}\
diff --git a/archivers/xarchiver/Makefile b/archivers/xarchiver/Makefile
index e7944b14f457..c63720235cff 100644
--- a/archivers/xarchiver/Makefile
+++ b/archivers/xarchiver/Makefile
@@ -16,8 +16,7 @@ RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils \
7zr:${PORTSDIR}/archivers/p7zip \
zip:${PORTSDIR}/archivers/zip
-USES= gmake pkgconfig desktop-file-utils
-USE_BZIP2= yes
+USES= tar:bzip2 gmake pkgconfig desktop-file-utils
USE_GNOME= glib20 gtk20 intltool
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
diff --git a/archivers/xdms/Makefile b/archivers/xdms/Makefile
index 1845333e3e88..cd6cb239f7fc 100644
--- a/archivers/xdms/Makefile
+++ b/archivers/xdms/Makefile
@@ -11,7 +11,7 @@ COMMENT= Tool for decompressing Amiga DMS files
OPTIONS_DEFINE= DOCS
-USE_BZIP2= yes
+USES= tar:bzip2
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
ALL_TARGET= xdms
diff --git a/archivers/zip/Makefile b/archivers/zip/Makefile
index 6021431133d6..42dfce5e83ef 100644
--- a/archivers/zip/Makefile
+++ b/archivers/zip/Makefile
@@ -12,7 +12,7 @@ MAINTAINER= freebsd@skysmurf.nl
COMMENT= Create/update ZIP files compatible with PKZIP
# License is BSD-based, but not identical, so intall with documentation
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
OPTIONS_DEFINE= DOCS