aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1997-11-20 08:18:41 +0000
committerThomas Gellekum <tg@FreeBSD.org>1997-11-20 08:18:41 +0000
commit8c43e0b76f0061eb148b3fd54a59caeb52778d6e (patch)
treeb11577b8265ff2c3704e622e35e50aeb0ffa7b71 /archivers
parent9a3f08689d7e66cad85259994efdb4e703d8084f (diff)
downloadports-8c43e0b76f0061eb148b3fd54a59caeb52778d6e.tar.gz
ports-8c43e0b76f0061eb148b3fd54a59caeb52778d6e.zip
Import bzip2 port. bzip2 is a block-sorting compressor with better
compression than gzip. The author believes that this program uses only patent-free algorithms. The generated files are not compatible to bzip-compressed files.
Notes
Notes: svn path=/head/; revision=8720
Diffstat (limited to 'archivers')
-rw-r--r--archivers/bzip2/Makefile26
-rw-r--r--archivers/bzip2/distinfo1
-rw-r--r--archivers/bzip2/pkg-comment1
-rw-r--r--archivers/bzip2/pkg-descr10
-rw-r--r--archivers/bzip2/pkg-plist5
5 files changed, 43 insertions, 0 deletions
diff --git a/archivers/bzip2/Makefile b/archivers/bzip2/Makefile
new file mode 100644
index 000000000000..b424489bfe2d
--- /dev/null
+++ b/archivers/bzip2/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: bzip2
+# Version required: 0.1pl2
+# Date created: 19 Nov 1997
+# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= bzip2-0.1pl2
+PKGNAME= bzip2-0.1p2
+CATEGORIES= archivers
+MASTER_SITES= http://www.muraroa.demon.co.uk/
+
+MAINTAINER= ports@FreeBSD.org
+
+FETCH_BEFORE_ARGS= -b
+MAN1= bzip2.1 bunzip2.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bzip2 ${PREFIX}/bin
+ ln -sf ${PREFIX}/bin/bzip2 ${PREFIX}/bin/bunzip2
+ ${INSTALL_PROGRAM} ${WRKSRC}/bzip2recover ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/bzip2.1 ${PREFIX}/man/man1
+ ln ${PREFIX}/man/man1/bzip2.1 ${PREFIX}/man/man1/bunzip2.1
+
+.include <bsd.port.mk>
diff --git a/archivers/bzip2/distinfo b/archivers/bzip2/distinfo
new file mode 100644
index 000000000000..7dc56c24d979
--- /dev/null
+++ b/archivers/bzip2/distinfo
@@ -0,0 +1 @@
+MD5 (bzip2-0.1pl2.tar.gz) = e9b98c287b45b0ff232c9e8f0c72f544
diff --git a/archivers/bzip2/pkg-comment b/archivers/bzip2/pkg-comment
new file mode 100644
index 000000000000..b2289372af60
--- /dev/null
+++ b/archivers/bzip2/pkg-comment
@@ -0,0 +1 @@
+A block-sorting file compressor
diff --git a/archivers/bzip2/pkg-descr b/archivers/bzip2/pkg-descr
new file mode 100644
index 000000000000..95d296dfe487
--- /dev/null
+++ b/archivers/bzip2/pkg-descr
@@ -0,0 +1,10 @@
+This is bzip2, a block-sorting file compressor.
+
+From the README:
+
+ To the best of my knowledge, bzip2 does not use any patented
+ algorithms. However, I do not have the resources available to
+ carry out a full patent search. Therefore I cannot give any
+ guarantee of the above statement.
+
+ Julian Seward <jseward@acm.org>
diff --git a/archivers/bzip2/pkg-plist b/archivers/bzip2/pkg-plist
new file mode 100644
index 000000000000..b9552fcd2834
--- /dev/null
+++ b/archivers/bzip2/pkg-plist
@@ -0,0 +1,5 @@
+bin/bzip2
+bin/bunzip2
+bin/bzip2recover
+man/man1/bzip2.1.gz
+man/man1/bunzip2.1.gz