aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2008-03-10 12:21:53 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2008-03-10 12:21:53 +0000
commit5aac148861ab3edd41c18bc55e9fdfbb0f9a7ab2 (patch)
tree1ba1a216d7d71c66bcf04c961d73a07885482d43 /archivers
parentbb97787dbb6a48d76a4621afbd03b0a3b78b9079 (diff)
downloadports-5aac148861ab3edd41c18bc55e9fdfbb0f9a7ab2.tar.gz
ports-5aac148861ab3edd41c18bc55e9fdfbb0f9a7ab2.zip
- use CPAN macro
- fix dependency - switch to PERL_MODBUILD - bump PORTREVISION Submitted by: leeym Approved by: clsung
Notes
Notes: svn path=/head/; revision=208717
Diffstat (limited to 'archivers')
-rw-r--r--archivers/p5-Archive-Any/Makefile26
-rw-r--r--archivers/p5-Archive-Any/pkg-plist1
2 files changed, 17 insertions, 10 deletions
diff --git a/archivers/p5-Archive-Any/Makefile b/archivers/p5-Archive-Any/Makefile
index c9f4cee5a43e..db8ed91f3087 100644
--- a/archivers/p5-Archive-Any/Makefile
+++ b/archivers/p5-Archive-Any/Makefile
@@ -7,25 +7,33 @@
PORTNAME= Archive-Any
PORTVERSION= 0.09.3
+PORTREVISION= 1
CATEGORIES= archivers perl5
-MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
-MASTER_SITE_SUBDIR= Archive
+MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-DISTNAME= ${PORTNAME}-0.093
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
MAINTAINER= clsung@FreeBSD.org
COMMENT= Single interface to deal with file archives
-RUN_DEPENDS= ${SITE_PERL}/MIME/Types.pm:${PORTSDIR}/mail/p5-MIME-Types \
- p5-Archive-Tar>=0.22:${PORTSDIR}/archivers/p5-Archive-Tar \
- p5-Archive-Zip>=1.07:${PORTSDIR}/archivers/p5-Archive-Zip \
+BUILD_DEPENDS= p5-Test-Perl-Critic>=0:${PORTSDIR}/textproc/p5-Test-Perl-Critic \
+ p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Test-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Test-Pod-Coverage \
+ p5-Test-Warn>=0:${PORTSDIR}/devel/p5-Test-Warn
+RUN_DEPENDS= p5-Archive-Zip>=1.07:${PORTSDIR}/archivers/p5-Archive-Zip \
p5-File-MMagic>=1.27:${PORTSDIR}/devel/p5-File-MMagic \
+ p5-MIME-Types>=1.16:${PORTSDIR}/mail/p5-MIME-Types \
p5-Module-Find>=0.05:${PORTSDIR}/devel/p5-Module-Find
-BUILD_DEPENDS= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+PERL_MODBUILD= yes
MAN3= Archive::Any.3 Archive::Any::Plugin.3 \
Archive::Any::Plugin::Tar.3 Archive::Any::Plugin::Zip.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-Archive-Tar>=0.22:${PORTSDIR}/archivers/p5-Archive-Tar
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/archivers/p5-Archive-Any/pkg-plist b/archivers/p5-Archive-Any/pkg-plist
index bfe2d75d100a..3b548cfae9f0 100644
--- a/archivers/p5-Archive-Any/pkg-plist
+++ b/archivers/p5-Archive-Any/pkg-plist
@@ -1,5 +1,4 @@
@comment $FreeBSD$
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Archive/Any/.packlist
%%SITE_PERL%%/Archive/Any.pm
%%SITE_PERL%%/Archive/Any/Plugin.pm
%%SITE_PERL%%/Archive/Any/Plugin/Tar.pm