aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorAlan Eldridge <alane@FreeBSD.org>2002-10-30 02:01:48 +0000
committerAlan Eldridge <alane@FreeBSD.org>2002-10-30 02:01:48 +0000
commit16ae61e738789a6d0c373ad7550868f8768d04df (patch)
tree10afc218e16a685f6cea3e7dcc1b9d8e6cc9f517 /archivers
parente275acfa6b6abd4941b64d304f9c9b2a324bb189 (diff)
downloadports-16ae61e738789a6d0c373ad7550868f8768d04df.tar.gz
ports-16ae61e738789a6d0c373ad7550868f8768d04df.zip
Use File::Spec port only for perl < 5.8.
Approved by: maintainer
Notes
Notes: svn path=/head/; revision=69136
Diffstat (limited to 'archivers')
-rw-r--r--archivers/p5-Archive-Zip/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/archivers/p5-Archive-Zip/Makefile b/archivers/p5-Archive-Zip/Makefile
index 4f6fce1df8fe..44d31ee16e97 100644
--- a/archivers/p5-Archive-Zip/Makefile
+++ b/archivers/p5-Archive-Zip/Makefile
@@ -14,8 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= erwin@lansing.dk
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -23,4 +22,15 @@ PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Archive::Zip.3 Archive::Zip::Tree.3 Archive::Zip::FAQ.3 Archive::Zip::MemberRead.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+SITE_PERL?= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+
+PERL_MAJOR=${PERL_VER:C|^([1-9]+).*|\1|}
+PERL_MINOR=${PERL_VER:C|^[1-9]+\.0*([1-9]+).*|\1|}
+
+.if ${PERL_MAJOR} < 5 || ${PERL_MAJOR} == 5 && ${PERL_MINOR} < 8
+BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+.endif # ${PERL_MAJOR} < 5 || ${PERL_MAJOR} == 5 && ${PERL_MINOR} < 8
+
+.include <bsd.port.post.mk>