aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorFelippe de Meirelles Motta <lippe@FreeBSD.org>2008-06-20 18:38:52 +0000
committerFelippe de Meirelles Motta <lippe@FreeBSD.org>2008-06-20 18:38:52 +0000
commitfdaf7cb5174657593de4f8fedbc790d7218434e8 (patch)
treeae43e8e2ea042e25a32167ab41ad864b4278dee6 /archivers
parente317f516374739360c09d246a3662aac740de2a0 (diff)
downloadports-fdaf7cb5174657593de4f8fedbc790d7218434e8.tar.gz
ports-fdaf7cb5174657593de4f8fedbc790d7218434e8.zip
- Reduce self-test verbosity.
- Add DOCS and EXAMPLES files. - Bump PORTREVISION. PR: ports/124184 Submitted by: Matthias Andree <matthias.andree@gmx.de> (maintainer) Approved by: gabor (mentor, implicit)
Notes
Notes: svn path=/head/; revision=215385
Diffstat (limited to 'archivers')
-rw-r--r--archivers/lzo2/Makefile13
-rw-r--r--archivers/lzo2/files/patch-silence-lzotest.c27
-rw-r--r--archivers/lzo2/pkg-plist17
3 files changed, 55 insertions, 2 deletions
diff --git a/archivers/lzo2/Makefile b/archivers/lzo2/Makefile
index 10b03093f7c3..a66f4aa21074 100644
--- a/archivers/lzo2/Makefile
+++ b/archivers/lzo2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= lzo2
PORTVERSION= 2.03
+PORTREVISION= 1
CATEGORIES= archivers devel
MASTER_SITES= http://www.oberhumer.com/opensource/lzo/download/ \
http://fresh.t-systems-sfr.com/unix/src/misc/ \
@@ -24,12 +25,22 @@ CONFIGURE_ARGS= --enable-shared
USE_LDCONFIG= yes
post-build:
+ @${ECHO_MSG} "===> Running self-tests for ${PKGNAME} (can take a few minutes, without output)"
cd ${WRKSRC} && ${MAKE} test
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+ cd ${WRKSRC} && ${REINPLACE_CMD} -e 's,doc/,,' NEWS README
+.for i in AUTHORS BUGS COPYING NEWS README THANKS
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}/
+.endif
+
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/[a-z]*.[ch] ${EXAMPLESDIR}/
.endif
.include <bsd.port.mk>
diff --git a/archivers/lzo2/files/patch-silence-lzotest.c b/archivers/lzo2/files/patch-silence-lzotest.c
new file mode 100644
index 000000000000..921bf7c6a5c3
--- /dev/null
+++ b/archivers/lzo2/files/patch-silence-lzotest.c
@@ -0,0 +1,27 @@
+This test reduces the lzotest verbosity so that it doesn't print anything
+on success.
+
+--- lzotest/lzotest.c.orig 2008-06-01 10:01:36.000000000 +0200
++++ lzotest/lzotest.c 2008-06-01 10:03:10.000000000 +0200
+@@ -226,7 +226,7 @@
+
+ struct corpus_entry_t;
+
+-int opt_verbose = 2;
++int opt_verbose = 1;
+
+ long opt_c_loops = 0;
+ long opt_d_loops = 0;
+@@ -1910,10 +1910,12 @@
+ #elif defined(LZOTEST_USE_DYNLOAD)
+ # include "dynload/init.ch"
+ #else
++#if 0
+ printf("\nLZO real-time data compression library (v%s, %s).\n",
+ lzo_version_string(), lzo_version_date());
+ printf("Copyright (C) 1996-2008 Markus Franz Xaver Johannes Oberhumer\nAll Rights Reserved.\n\n");
++#endif
+ #endif
+
+
+ /*
diff --git a/archivers/lzo2/pkg-plist b/archivers/lzo2/pkg-plist
index 665b68d190d2..b9d38a38848f 100644
--- a/archivers/lzo2/pkg-plist
+++ b/archivers/lzo2/pkg-plist
@@ -11,13 +11,28 @@ include/lzo/lzo_asm.h
include/lzo/lzoconf.h
include/lzo/lzodefs.h
include/lzo/lzoutil.h
+@dirrm include/lzo
lib/liblzo2.a
lib/liblzo2.la
lib/liblzo2.so
lib/liblzo2.so.2
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/BUGS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/LZO.FAQ
%%PORTDOCS%%%%DOCSDIR%%/LZO.TXT
%%PORTDOCS%%%%DOCSDIR%%/LZOAPI.TXT
%%PORTDOCS%%%%DOCSDIR%%/LZOTEST.TXT
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/THANKS
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dict.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lzopack.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/overlap.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/portab.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/portab_a.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/precomp.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/precomp2.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple.c
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm include/lzo