aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-06-28 14:00:45 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-06-28 14:00:45 +0000
commitdca255c3cec21c0c66003eb626763c7fdc2cb59a (patch)
treee6eac391e081f99a997be8b0d8e036d22d5fe2a9 /archivers
parent4973e5b396de5fdc84495adcdcb1f40854c8ebcd (diff)
downloadports-dca255c3cec21c0c66003eb626763c7fdc2cb59a.tar.gz
ports-dca255c3cec21c0c66003eb626763c7fdc2cb59a.zip
Convert USE_PHP*=yes into USES=php*
PR: 210529 Submitted by: mat Exp-run by: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D6936
Notes
Notes: svn path=/head/; revision=417719
Diffstat (limited to 'archivers')
-rw-r--r--archivers/pecl-lzf/Makefile4
-rw-r--r--archivers/pecl-phk/Makefile6
-rw-r--r--archivers/pecl-rar/Makefile6
-rw-r--r--archivers/php-horde_lz4/Makefile3
-rw-r--r--archivers/php5-snappy/Makefile3
5 files changed, 7 insertions, 15 deletions
diff --git a/archivers/pecl-lzf/Makefile b/archivers/pecl-lzf/Makefile
index 8a5b81384772..e6c3a8d4a058 100644
--- a/archivers/pecl-lzf/Makefile
+++ b/archivers/pecl-lzf/Makefile
@@ -14,9 +14,7 @@ COMMENT= Handles LZF de/compression
LICENSE= PHP202
-USES= tar:tgz
-USE_PHP= yes
-USE_PHPEXT= yes
+USES= php:ext tar:tgz
CONFIGURE_ARGS= --enable-lzf
WRKSRC= ${WRKDIR}/${DISTNAME:tu}
diff --git a/archivers/pecl-phk/Makefile b/archivers/pecl-phk/Makefile
index b70b5bfc4b2c..849879801d62 100644
--- a/archivers/pecl-phk/Makefile
+++ b/archivers/pecl-phk/Makefile
@@ -15,10 +15,8 @@ LICENSE= PHP301
BROKEN_powerpc64= Does not build
-USES= tar:tgz
-USE_PHP= hash
-USE_PHP_BUILD= yes
-USE_PHPEXT= yes
+USES= php:ext tar:tgz
+USE_PHP= hash:build
IGNORE_WITH_PHP= 70
CONFIGURE_ARGS= --enable-phk
diff --git a/archivers/pecl-rar/Makefile b/archivers/pecl-rar/Makefile
index 1b4bca0a4a65..2796da811ece 100644
--- a/archivers/pecl-rar/Makefile
+++ b/archivers/pecl-rar/Makefile
@@ -13,10 +13,8 @@ COMMENT= PECL extension to create and read RAR files
LICENSE= PHP301
-USES= tar:tgz
-USE_PHP= spl
-USE_PHPEXT= yes
-USE_PHP_BUILD= yes
+USES= php:ext tar:tgz
+USE_PHP= spl:build
IGNORE_WITH_PHP= 70
diff --git a/archivers/php-horde_lz4/Makefile b/archivers/php-horde_lz4/Makefile
index 6ee37dc6175f..fae9e9e31c25 100644
--- a/archivers/php-horde_lz4/Makefile
+++ b/archivers/php-horde_lz4/Makefile
@@ -12,8 +12,7 @@ DIST_SUBDIR= PECL
MAINTAINER= mm@FreeBSD.org
COMMENT= Horde LZ4 Compression Extension for php
-USE_PHP= yes
-USE_PHPEXT= yes
+USES= php:ext
IGNORE_WITH_PHP= 70
CONFIGURE_ARGS= --enable-horde_lz4
diff --git a/archivers/php5-snappy/Makefile b/archivers/php5-snappy/Makefile
index 159779964715..a3ccdcab97f2 100644
--- a/archivers/php5-snappy/Makefile
+++ b/archivers/php5-snappy/Makefile
@@ -17,8 +17,7 @@ LICENSE= BSD2CLAUSE
LIB_DEPENDS+= libsnappy.so:archivers/snappy
CONFIGURE_ARGS+= --with-snappy-includedir=${LOCALBASE}/include
-USE_PHP= yes
-USE_PHPEXT= yes
+USES= php:ext
PHP_MODNAME= snappy
WRKSRC= ${WRKDIR}/${PROJECTHOST}
OPTIONS_DEFINE= TEST