aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>1994-12-31 18:07:46 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>1994-12-31 18:07:46 +0000
commit06c00ece0f8c969e6b9570637ad66de0277944ea (patch)
tree6c92527ba8ff1f0a20854925f42fffc9cb5465cb /archivers
parent7570343cac8e02f32372145530a547b03b02c471 (diff)
downloadports-06c00ece0f8c969e6b9570637ad66de0277944ea.tar.gz
ports-06c00ece0f8c969e6b9570637ad66de0277944ea.zip
ARC archiver
Notes
Notes: svn path=/head/; revision=656
Diffstat (limited to 'archivers')
-rw-r--r--archivers/arc/Makefile13
-rw-r--r--archivers/arc/files/patch-aa94
2 files changed, 107 insertions, 0 deletions
diff --git a/archivers/arc/Makefile b/archivers/arc/Makefile
new file mode 100644
index 000000000000..8183855e5937
--- /dev/null
+++ b/archivers/arc/Makefile
@@ -0,0 +1,13 @@
+# New ports collection makefile for: arc
+# Version required: 5.21e
+# Date created: 31 Dec 1994
+# Whom: ache
+#
+# $Id: Makefile,v 1.1.1.1 1994/12/26 09:10:32 ache Exp $
+#
+DISTNAME= arc521e.pl8
+EXTRACT_SUFX= .tar.Z
+MASTER_SITES= ftp://ftp.kiae.su/unix/arcers/
+NO_WRKSUBDIR= yes
+
+.include <bsd.port.mk>
diff --git a/archivers/arc/files/patch-aa b/archivers/arc/files/patch-aa
new file mode 100644
index 000000000000..68f082482c26
--- /dev/null
+++ b/archivers/arc/files/patch-aa
@@ -0,0 +1,94 @@
+*** Makefile.old Wed Apr 15 02:57:58 1992
+--- Makefile Sat Dec 31 20:36:07 1994
+***************
+*** 32,45 ****
+ OPT = -O
+ # For MWC 3.0 on the Atari ST, use:
+ #CFLAGS = -VCOMPAC -VPEEP
+! CFLAGS = $(OPT) $(SYSTEM)
+
+ # GNU's gcc is very nice, if you've got it. Otherwise just cc.
+ #CC = cgcc -mshort
+! CC = cc
+
+ # tmclock is only needed on Unix systems...
+! TMCLOCK = tmclock.o
+
+ # Files needed for System V
+ #SYSVOBJ = getwd.o rename.o scandir.o utimes.o
+--- 32,46 ----
+ OPT = -O
+ # For MWC 3.0 on the Atari ST, use:
+ #CFLAGS = -VCOMPAC -VPEEP
+! #CFLAGS = $(OPT) $(SYSTEM)
+! CFLAGS+=$(SYSTEM)
+
+ # GNU's gcc is very nice, if you've got it. Otherwise just cc.
+ #CC = cgcc -mshort
+! #CC = cc
+
+ # tmclock is only needed on Unix systems...
+! TMCLOCK = #tmclock.o
+
+ # Files needed for System V
+ #SYSVOBJ = getwd.o rename.o scandir.o utimes.o
+***************
+*** 61,66 ****
+--- 62,71 ----
+
+ clean:
+ -rm *.o arc$(PROG) marc$(PROG)
++
++ install:
++ install -cs -o bin -g bin arc marc ${PREFIX}/bin
++ install -c -o bin -g bin arc.1 ${PREFIX}/man/man1
+
+ arc.o: $(SRCDIR)arc.c $(HEADER)
+ $(CC) $(CFLAGS) -c $(SRCDIR)arc.c
+*** arcdos.c.old Wed Apr 15 02:58:21 1992
+--- arcdos.c Sat Dec 31 20:32:25 1994
+***************
+*** 173,186 ****
+--- 173,192 ----
+ struct tm tm;
+ struct timeval tvp[2];
+ int utimes();
++ #ifndef __FreeBSD__
+ long tmclock();
++ #endif
+ tm.tm_sec = (time & 31) * 2;
+ tm.tm_min = (time >> 5) & 63;
+ tm.tm_hour = (time >> 11);
+ tm.tm_mday = date & 31;
+ tm.tm_mon = ((date >> 5) & 15) - 1;
+ tm.tm_year = (date >> 9) + 80;
++ #ifndef __FreeBSD__
+ tvp[0].tv_sec = tmclock(&tm);
++ #else
++ tvp[0].tv_sec = timelocal(&tm);
++ #endif
+ tvp[1].tv_sec = tvp[0].tv_sec;
+ tvp[0].tv_usec = tvp[1].tv_usec = 0;
+ utimes(f, tvp);
+*** marc.c.old Wed Apr 15 02:59:21 1992
+--- marc.c Sat Dec 31 20:40:30 1994
+***************
+*** 35,40 ****
+--- 35,41 ----
+ #endif
+ VOID arcdie();
+ static VOID expandlst(), merge();
++ char *makefnam(); /* filename fixup routine */
+
+ FILE *src; /* source archive */
+ char srcname[STRLEN]; /* source archive name */
+***************
+*** 47,53 ****
+ int nargs; /* number of arguments */
+ char *arg[]; /* pointers to arguments */
+ {
+- char *makefnam(); /* filename fixup routine */
+ char *envfind();
+ #if !_MTS
+ char *arctemp2, *mktemp(); /* temp file stuff */
+--- 48,53 ----