aboutsummaryrefslogtreecommitdiff
path: root/astro/aa
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-02 08:33:09 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-02 08:33:09 +0000
commit592b7bcbab29db21e1b93b44d1f6cd2856054110 (patch)
tree94ddb98b38776d0f292379878791c924b9f225d3 /astro/aa
parenta7d37825227b50d5691a50d8d4b60daec569aac0 (diff)
downloadports-592b7bcbab29db21e1b93b44d1f6cd2856054110.tar.gz
ports-592b7bcbab29db21e1b93b44d1f6cd2856054110.zip
- Convert Makefile header to the new two-line form
- Remove 404'ing URL from MASTER_SITES - Do not explicitly set EXTRACT_AFTER_ARGS, use NO_WRKSUBDIR instead - Avoid patching makefile: pass correct values via MAKE_ARGS; this also remove double whitespace before -Wall from the build logs (nice) - NOPORTDOCS -> PORT_OPTIONS:MDOCS, get rid of .for loops, unmute the installation commands, make pkg-message display consistent with package - Reformat port description for better readability while here
Notes
Notes: svn path=/head/; revision=324154
Diffstat (limited to 'astro/aa')
-rw-r--r--astro/aa/Makefile33
-rw-r--r--astro/aa/pkg-descr12
2 files changed, 21 insertions, 24 deletions
diff --git a/astro/aa/Makefile b/astro/aa/Makefile
index 2d5a5453cff9..dcd1d932f28f 100644
--- a/astro/aa/Makefile
+++ b/astro/aa/Makefile
@@ -1,26 +1,22 @@
-# New ports collection makefile for: aa
-# Date created: 11 August 2006
-# Whom: Frank W. Josellis <frank@dynamical-systems.org>
-#
+# Created by: Frank W. Josellis <frank@dynamical-systems.org>
# $FreeBSD$
-#
PORTNAME= aa
PORTVERSION= 56
PORTREVISION= 2
CATEGORIES= astro
-MASTER_SITES= http://moshier.net/ \
- http://www.mirrorservice.org/sites/www.moshier.net/
+MASTER_SITES= http://moshier.net/
MAINTAINER= frank@dynamical-systems.org
COMMENT= Self-contained ephemeris calculator
-EXTRACT_AFTER_ARGS= -d ${WRKSRC}
EXTRACT_BEFORE_ARGS= -aqo
USE_ZIP= yes
MAKEFILE= makefile
ALL_TARGET= aa
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -Wall"
+NO_WRKSUBDIR= yes
SUB_FILES= pkg-message
@@ -28,30 +24,31 @@ PORTDOCS= read.me readme.404 Readme.FreeBSD
PORTDATA= messier.cat orbit.cat star.cat
PLIST_FILES= bin/aa etc/aa.ini.default
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} \
's|%%PREFIX%%|${PREFIX}|g ; s|%%DATADIR%%|${DATADIR}|g' \
${WRKSRC}/kfiles.c
- @${REINPLACE_CMD} 's|CFLAGS= -O2|CFLAGS+=| ; s|CC=|CC?=|' ${WRKSRC}/makefile
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/aa ${PREFIX}/bin
- @${INSTALL_DATA} ${WRKSRC}/aa.ini ${PREFIX}/etc/aa.ini.default
+ ${INSTALL_PROGRAM} ${WRKSRC}/aa ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/aa.ini ${PREFIX}/etc/aa.ini.default
.if !defined(NOPORTDATA)
@${MKDIR} ${DATADIR}
-.for i in ${PORTDATA}
- @${INSTALL_DATA} ${WRKSRC}/${i} ${DATADIR}
-.endfor
+ ${INSTALL_DATA} ${PORTDATA:S|^|${WRKSRC}/|} ${DATADIR}
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${CAT} ${PKGMESSAGE} > ${WRKSRC}/Readme.FreeBSD
@${MKDIR} ${DOCSDIR}
-.for i in ${PORTDOCS}
- @${INSTALL_MAN} ${WRKSRC}/${i} ${DOCSDIR}
-.endfor
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
+ @${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
.include <bsd.port.mk>
diff --git a/astro/aa/pkg-descr b/astro/aa/pkg-descr
index e47079c1f84c..70b191931678 100644
--- a/astro/aa/pkg-descr
+++ b/astro/aa/pkg-descr
@@ -1,10 +1,10 @@
This program computes ephemerides of Sun, Moon, planets, comets, and stars
-using rigorous reduction methods from the _Astronomical Almanac_ and related
-sources. Includes PLAN404 series for positions of the planets, and a long-term
-extension of modern Lunar theory for the Moon's position. Reads ASCII file
-catalogues of stars and orbital elements. Displays all adjustments as it finds
-local azimuth and elevation, rise and set times, etc.
+using rigorous reduction methods from the Astronomical Almanac and related
+sources.
-Latest update 2008-09-21.
+It includes PLAN404 series for positions of the planets, and a long-term
+extension of modern Lunar theory for the Moon's position; reads ASCII file
+catalogues of stars and orbital elements; displays all adjustments as it
+finds local azimuth and elevation, rise and set times, etc.
WWW: http://moshier.net/aadoc.html