aboutsummaryrefslogtreecommitdiff
path: root/astro/celestia/Makefile
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-03-13 10:17:18 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-03-13 10:17:18 +0000
commitf86287ac73816874c676ca3dac217bf4370af46e (patch)
tree86c271c4d55e54cb52f962c7f596bd6c44de571f /astro/celestia/Makefile
parentdd7325ed6acfefea8cb5e2adfdb87f327811b9ca (diff)
downloadports-f86287ac73816874c676ca3dac217bf4370af46e.tar.gz
ports-f86287ac73816874c676ca3dac217bf4370af46e.zip
BROKEN on !i386: Does not compile
Notes
Notes: svn path=/head/; revision=103868
Diffstat (limited to 'astro/celestia/Makefile')
-rw-r--r--astro/celestia/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index fc161ab69205..181d6382495f 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -41,6 +41,12 @@ CONFIGURE_ENV= \
CONFIGURE_ARGS+= --without-gtk
.endif
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
pre-patch:
${REINPLACE_CMD} -e \
's:-O2::g; s:-Wall::g; s:-ffast-math::g; s:-fexpensive-optimizations::g; s:! /bin/sh:! ${LOCALBASE}/bin/bash:g' \
@@ -106,4 +112,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/textures/medres/*.??? \
${DATADIR}/textures/medres/
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>