aboutsummaryrefslogtreecommitdiff
path: root/astro/glunarclock
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-07-10 17:52:02 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-07-10 17:52:02 +0000
commit38ae89925962202550ec6f11ddc0cbdc4c3a6ec2 (patch)
tree4e10f0e500448868ec0e91d42423b019d3f3f4c8 /astro/glunarclock
parent6cb9017d8fa2ec021ebc58d07e3f78d3182ca008 (diff)
downloadports-38ae89925962202550ec6f11ddc0cbdc4c3a6ec2.tar.gz
ports-38ae89925962202550ec6f11ddc0cbdc4c3a6ec2.zip
- Add patch missed in the previous commit;
- use USE_REINPLACE while I here.
Notes
Notes: svn path=/head/; revision=62784
Diffstat (limited to 'astro/glunarclock')
-rw-r--r--astro/glunarclock/Makefile8
-rw-r--r--astro/glunarclock/files/patch-po::Makefile.in.in14
2 files changed, 19 insertions, 3 deletions
diff --git a/astro/glunarclock/Makefile b/astro/glunarclock/Makefile
index 40b3b0b659a4..41c4f1f2315e 100644
--- a/astro/glunarclock/Makefile
+++ b/astro/glunarclock/Makefile
@@ -7,6 +7,7 @@
PORTNAME= glunarclock
PORTVERSION= 0.24.1
+PORTREVISION= 1
CATEGORIES= astro gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,6 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= sobomax@FreeBSD.org
USE_X_PREFIX= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
USE_GNOME= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -27,8 +29,8 @@ pre-configure:
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+ @find ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
+ s|[(]datadir[)]/locale|(prefix)/share/locale|g'
.include <bsd.port.mk>
diff --git a/astro/glunarclock/files/patch-po::Makefile.in.in b/astro/glunarclock/files/patch-po::Makefile.in.in
new file mode 100644
index 000000000000..3efb7ba3c2ce
--- /dev/null
+++ b/astro/glunarclock/files/patch-po::Makefile.in.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- po/Makefile.in.in 2002/06/10 10:14:08 1.1
++++ po/Makefile.in.in 2002/06/10 10:14:19
+@@ -106,7 +106,7 @@
+ @catalogs='$(CATALOGS)'; \
+ for cat in $$catalogs; do \
+ cat=`basename $$cat`; \
+- lang=`echo $$cat | sed 's/\.gmo$$//'`; \
++ lang=`echo $$cat | sed 's/\.mo$$//'`; \
+ dir=$(localedir)/$$lang/LC_MESSAGES; \
+ $(mkinstalldirs) $(DESTDIR)$$dir; \
+ if test -r $$cat; then \