aboutsummaryrefslogtreecommitdiff
path: root/astro/google-earth
diff options
context:
space:
mode:
authorJohannes Jost Meixner <xmj@FreeBSD.org>2014-09-22 10:40:00 +0000
committerJohannes Jost Meixner <xmj@FreeBSD.org>2014-09-22 10:40:00 +0000
commit05317facbedf1ed4566b56f4e09e6e4a49fc3f38 (patch)
treef0614b64c20d137667eadfbdc5663150937dc6c3 /astro/google-earth
parentf287925fdbb7ff7ab55ee8aaa28cf756fe49a296 (diff)
downloadports-05317facbedf1ed4566b56f4e09e6e4a49fc3f38.tar.gz
ports-05317facbedf1ed4566b56f4e09e6e4a49fc3f38.zip
Update CentOS base to 6.5, add userland ports
The Fedora 10 infrastructure ports have been in use since June 2009 and, while having served a great deed, have become unsupported upstream and hence affected by unfixed security vulnerabilities. In addition to that, many recent Linux binaries need newer libc / stdlibc++ versions. This commit adds the linux-c6- userland as drop-in replacement for the -f10 infrastructure, as well as upgrading the linux_base-c6 port to CentOS 6.5. If you want to switch to linux-c6 ports, please define at /etc/make.conf: OVERRIDE_LINUX_BASE_PORT=c6 OVERRIDE_LINUX_NONBASE_PORTS=c6 Additionally, please add the following line to /etc/sysctl.conf: compat.linux.osrelease=2.6.18 Upgrading procedures are shown in /usr/ports/UPDATING. This work has been inspired by Artyom Mirgorodskiy's post to emulation@ in November 2013, using and extending mav@'s work. It has been tested extensively and most reported issues were already fixed. Please report any additional bug or "features" to the emulation mailing list. Many thanks to: mav@, rene@, allanjude@, netchild@, antoine@, everyone who's filed Issues and Pull requests on GitHub, PR: 186820 Differential Revision: https://reviews.freebsd.org/D793 Reviewed by: allanjude, antoine, bapt, rene Approved by: portmgr (antoine, bapt) Approved by: koobs (mentor) Sponsored by: Perceivon Hosting Inc.
Notes
Notes: svn path=/head/; revision=368845
Diffstat (limited to 'astro/google-earth')
-rw-r--r--astro/google-earth/Makefile18
-rw-r--r--astro/google-earth/files/patch-bin-googleearth21
2 files changed, 31 insertions, 8 deletions
diff --git a/astro/google-earth/Makefile b/astro/google-earth/Makefile
index 8b4a1001e2d8..c1f5e2558818 100644
--- a/astro/google-earth/Makefile
+++ b/astro/google-earth/Makefile
@@ -2,7 +2,7 @@
PORTNAME= google-earth
PORTVERSION= 6.0.3.2197
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 3
CATEGORIES= astro deskutils geography
MASTER_SITES= http://dl.google.com/earth/client/advanced/previous/:previous \
@@ -20,19 +20,24 @@ RESTRICTED= Not really sure about the redistribution terms
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/\..*//g}/
+OPTIONS_DEFINE= NVIDIA
+
USE_LINUX= yes
USE_LINUX_APPS= xorglibs curl
USES= perl5 shared-mime-info desktop-file-utils
USE_PERL5= patch build
+#SUB_FILES= bin/googleearth
.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
UNMAKESELF= ${LOCALBASE}/bin/unmakeself
-.if defined(WITH_NVIDIA_GL)
+.if ${PORT_OPTIONS:MNVIDIA}
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
.else
-USE_LINUX_APPS+= dri
+USE_LINUX_APPS+= dri libpciaccess
+LIBGL_ALWAYS_SOFTWARE=LIBGL_ALWAYS_SOFTWARE=yes
.endif
# Fixed by the first post-patch target line? Also, linprocfs needs to be mounted.
@@ -48,9 +53,10 @@ do-extract:
@cd ${WRKSRC} && ${TAR} xf googleearth-linux-x86.tar && ${RM} -f googleearth-linux-x86.tar
post-patch:
- @${REINPLACE_CMD} -i "" -e '/OS.*=/s|linux|FreeBSD|' ${WRKSRC}/drivers.ini
- @${REINPLACE_CMD} -i "" -e 's|^# Set the home.*|GOOGLEEARTH_DATA_PATH=${DATADIR}|' ${WRKSRC}/bin/googleearth
- @${REINPLACE_CMD} -i "" -e "s|^# Let's boogie.*|rm -f \$${HOME}/.googleearth/instance-running-lock|" ${WRKSRC}/bin/googleearth
+ @${REINPLACE_CMD} -e '/OS.*=/s|linux|FreeBSD|' ${WRKSRC}/drivers.ini
+ @${REINPLACE_CMD} -e 's|^# Set the home.*|GOOGLEEARTH_DATA_PATH=${DATADIR}|; \
+ s|%%LIBGL_ALWAYS_SOFTWARE%%|${LIBGL_ALWAYS_SOFTWARE}|' ${WRKSRC}/bin/googleearth
+ @${REINPLACE_CMD} -i "" -e "s|^# Let's boogie.*|rm -f ${LINUXBASE}\$${HOME}/.googleearth/instance-running-lock|" ${WRKSRC}/bin/googleearth
@${REINPLACE_CMD} -i "" -e 's/^TMPPATH.*/exit 0/' ${WRKSRC}/postinstall.sh
@${REINPLACE_CMD} -i "" -e 's|\"\$$SETUP_INSTALLPATH/|\"${WRKSRC}/|' ${WRKSRC}/postinstall.sh
@${REINPLACE_CMD} -i "" -e 's|\$$SETUP_INSTALLPATH/googleearth |${PREFIX}/bin/googleearth |' ${WRKSRC}/postinstall.sh
diff --git a/astro/google-earth/files/patch-bin-googleearth b/astro/google-earth/files/patch-bin-googleearth
index 1d14941af2b5..a56aeb9494d6 100644
--- a/astro/google-earth/files/patch-bin-googleearth
+++ b/astro/google-earth/files/patch-bin-googleearth
@@ -1,5 +1,6 @@
-Index: bin/googleearth
-@@ -8,6 +8,16 @@ if [ "${GOOGLEEARTH_DATA_PATH}" = "" ];
+--- ./bin/googleearth.orig 2011-05-17 10:42:02.000000000 +0300
++++ ./bin/googleearth 2014-03-13 08:59:26.456795260 +0200
+@@ -8,6 +8,17 @@
GOOGLEEARTH_DATA_PATH="$(dirname "$(readlink -f "$0")")"
fi
@@ -8,6 +9,7 @@ Index: bin/googleearth
+# For browser wrapper script (to use original LD_LIBRARY_PATH)
+if [ -n "${BROWSER}" ]
+then
++
+ export REAL_BROWSER="${BROWSER}"
+ export REAL_LD_LIBRARY_PATH="${LD_LIBRARY_PATH}"
+ export BROWSER=${GOOGLEEARTH_DATA_PATH}/bin/browserwrapper
@@ -16,3 +18,18 @@ Index: bin/googleearth
LD_LIBRARY_PATH=.:${GOOGLEEARTH_DATA_PATH}:${LD_LIBRARY_PATH}
export LD_LIBRARY_PATH
+@@ -15,10 +26,11 @@
+ if [ -x "${GOOGLEEARTH_DATA_PATH}/googleearth-bin" ]
+ then
+ cd "${GOOGLEEARTH_DATA_PATH}/"
+- exec "./googleearth-bin" "$@"
++ LIBGL_DEBUG="verbose" %%LIBGL_ALWAYS_SOFTWARE%% exec "./googleearth-bin" "$@"
++else
++ echo "Couldn't run Google Earth (googleearth-bin). Is GOOGLEEARTH_DATA_PATH set?"
++ exit 1
+ fi
+-echo "Couldn't run Google Earth (googleearth-bin). Is GOOGLEEARTH_DATA_PATH set?"
+-exit 1
+
+ # end of googleearth ...
+